Jump to content

Archived

This topic is now archived and is closed to further replies.

Scaramouche

[suite]Pb de gest° de propriété/droits de partit°

Recommended Posts

EDIT du 30/04/2005 : voir en deuxième page pour la suite de mes problèmes :ouioui:

bon.. il semblerait que la Mandrakelinux soit une petite farceuse... j'explique :

je suis en dual-boot win/nux sur mon portable (1DD) qui comprend un partition windows en FAT32 (hda1, nommée windows sous linux), une de données en FAT32 (hda2, nommée data sous linux), puis celles de la Mandrakelinux (classique). Mes partitions windows et data sont montées dans mon home par commodité.

le problème est que je n'arrive pas à conserver la propriété / les droits complèts pour mon utilisateur à chaque reboot ces partitions se retrouvent attribuées à root et je n'ai plus qu'un droit de lecture... ce qui est plutôt génant.

j'ai vérifié ça hier soir encore en faisant la chose suivante :

- édit du fstab en mettant en commentaire les lignes correspondant à windows et data (je ne pouvait pas changer les droits sans ça.. il me disait que c'était occupé par autre chose).

- reboot

- chown annaig: data et chown annaig: windows (annaig étant l'utilisateur)

- edit du fstab pour enlever les # de comentaire

- puis rien a faire, les partitions ont été montées automatiquement.... et après vérif, j'en suis bien propriétaire j'avais bien les droits dessus.

- reboot de vérif : j'ai perdu les droits, c'est root qui est propritétaire.. :mdr:

et je vous met ci-dessous mon fstab si ça peut servir :

/dev/hda5 / ext3 noatime 1 1
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda1 /home/annaig/windows vfat user,rw,noatime,umask=000,iocharset=iso8859-15,codepage=850 0 0
/dev/hda2 /home/annaig/data vfat user,rw,noatime,umask=000,iocharset=iso8859-15,codepage=850 0 0 none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,kudzu,codepage=850,noauto,exec,users 0 0

voilà.. si vous voyez d'où ça peut venir... ça m'arrangerait bien parce que là c'est plutôt galère :transpi:

merci d'avance :francais:

Link to post
Share on other sites

Refait un fstab correct, et tapes

chattr +i /etc/fstab

Il bougera plus comme ça.

Si tu veut le remodifier fait pareil mais avec -i .

edit : mauvaise idée en fait si tu veut que ta clé USB apparaise dynamiquement sur le bureau, car un script modifie le fstab à la volée.

Link to post
Share on other sites

qu'appelles-tu un fstab correct ?

parce que c'est duke qui me l'a fait et je ne vois pas ce qui merde dedans...

ta commande empèche ses changements sur le fichier sur lequel c'est appliqué ?

(sinon je testerai vos propositions pas avant ce soir.. là je suis au boulot :francais: )

Edit : effectivement ma clée me sert bien en ce moment...surtout quand je n'ai qu'elle pour tranférer des fichiers de linux à win vu que win ne lit pas mes partitions linux.... :transpi:

Link to post
Share on other sites

J4ai ecrit un tuto sur fstab...

Il faut que tu ajoutes user dans la ligne du fstab dans les options, et les droits qui t'interessent avec umask=xyz avec xyz ton masque.

EDT : grosse connerie effacée.

Link to post
Share on other sites

(j'avais lu le tuto sur fstab fût un temps... :yes:)

le user y est bien... autrement.. je vais mettre 777 je pense pour que tout le monde ait tous les droits... c'est bien ça ?

mais ça va pas arranger le schmilblic ça... :transpi:

ça m'évitera juste de faire un chmode 777 après (je l'avais éludé mais j'en faisais un )

Link to post
Share on other sites

Eh bien sinon, tu peux spécifier peut etre un certain group de user, mais je trouve bizarre que les droits reviennent à root a chaque fois. Mais si c'est du fat, on ne peut gérer les droits, ca vole à chaque fois. C'est un systeme de fichier obsolete.

7 = rwx ( 111 en binaire )

5 = r-x ( 101 en binaire )

Link to post
Share on other sites
Eh bien sinon, tu peux spécifier peut etre un certain group de user, mais je trouve bizarre que les droits  reviennent à root a chaque fois. Mais si c'est du fat, on ne peut gérer les droits, ca vole à chaque fois. C'est un systeme de fichier obsolete.

7 = rwx ( 111 en binaire )

5 = r-x  ( 101 en binaire )

en user y'a que moi (et root)..donc pas de prise de ête, c'est mon ordi perso

le système c'est FAT32...

Le fstab est modifié au boot ???? :transpi:

en fait je sais pas.. mais je pense pas...

je referai la manip ce soir et comparerai avant et après reboot (là c'est après reboot)

Link to post
Share on other sites
Bon, :transpi: rem, apres lecture complete du post, je changerai umask=000 par umask=777 ou 775 ou encore 755 selon les droits que tu veux.

en lisant ca je me suis rendu compte que j'avais pas bien lu tout ce qu'il y avait dans le topic.

en fait c'est bien moi qui ai mis les 000 pour umask.

par contre quand je l'ai fait ca a très bien marché. En plus je fait comme ca depuis toujours sur ma gentoo et tout est ok.

je viendrais voir la suite mais plus tard ....

Link to post
Share on other sites

j'ai dit une grosse connerie, j'ai confondu umask avec l'opposé, mode. umask est soustrait de 777, donc surtout pas 777 car ca donnerait aucun droit pour personne.

Généralement c'est 022, mais 000 est fortement possible aussi.

simplement, c'est juste le systeme de fichier qui ne doit pas autoriser le user a s'en servir.

ps : vous pouvez editer vos posts pour effacer mes conneries citées, merci :transpi:

Mlle Scara ; c'est pas dur; ls -l /etc | grep fstab te donnera la date et l'heure de la derniere modif.

Link to post
Share on other sites

bon... je verrai ça ce soir :byebye:

donc je laisse mes 000 et je refaisla manip en surveillant les modifs du fstab... et je viens au rappot ensuite

note : Je n'ai rien à changer dans mon fstab pour l'instant alors.. vous me le confirmez ?

(rem : pour l'édit, ce que j'ai quoté doit aller vu qu'il n'y a pas umask ou mode de cité..)

C'est encore un coup Mandrake qui s'amuse à triffouiller tout seul les fichiers de conf je pense

(cf resolv.conf)

pour la solution faut trouver le truc qui s'amuse à modifier le fichier.

fait une recherche sur les problemes réseau/DNS/ADSL/Mandrake. il y a des topics dessus

au fait, pour le dernier paragraphe... je vois pas pourquoi tu me dis de faire une recherche là dessus... je ne vois pas le rapport... :transpi:

Link to post
Share on other sites

Bon, j'ai recommencé depuis le départ :

un petit ls me donne

drwxrwxrwx  27 root   root    16K jan  1  1970 windows/
drwxrwxrwx  14 root   root   8,0K jan  1  1970 data/

et effectivement.. je ne peux pas par exemple supprimer un fichier de data

le fstab a à ce moment là cette tête :

/dev/hda5 / ext3 noatime 1 1
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda1 /home/annaig/windows vfat user,rw,noatime,umask=000,iocharset=iso8859-15,codepage=850 0 0
/dev/hda2 /home/annaig/data vfat user,rw,noatime,umask=000,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,kudzu,codepage=850,noauto,exec,users 0 0

je passe les lignes de hda1 et hda2 en commentaires.. puis je reboote pour que mon nouvel fstab soit pris en compte....

là je vérifie les droits sur data et windows... normalement mon futur montage devrait fonctionner vu que j'ai bien les droits sur ces dossiers :

drwxrwxrwx   2 annaig annaig 4,0K jan  2 11:50 windows/
drwxrwxrwx   2 annaig annaig 4,0K jan  4 16:56 data/

j'édite le fstab en enlevant les commentaires... ça se monte tout seul... puis un chmod 777 data et idem pour windows.

Et j'ai manisfestement bien les droits qu'il faut :

drwxrwxrwx  27 annaig annaig  16384 jan  1  1970 windows/
drwxrwxrwx  14 annaig annaig   8192 jan  1  1970 data/

mais quand je veux effacer un fichier je peux pas... un petit exemple :

[annaig@annaig1 MesDocs]$ rm solution.txt
rm: détruire fichier régulier `solution.txt'? y
rm: ne peut enlever `solution.txt': Permission denied

J'ai vérifié les droits sur ce fichiers par exemple et j'ai ça :

-rwxrwxrwx   1 annaig annaig     906 oct 29 19:14 solution.txt*

donc je comprends pas pourquoi ça merde... :chinois: (et c'est quoi cette * à la fin ?)

Enfin bref... donc le reboot y est pour rien en fait.. ça ne marche pas dès le départ :francais:

@ noobietux : j'ai quasiment les mêmes infos que toi.. juste users et rw en plus il me semble... est-ce que ça pourrait jouer ?

Link to post
Share on other sites

Il faudrait que tu essaies avec du uid, et gid, pour spécifier le propriétaire et le groupe de ta partition: par exemple, comme cela:

/dev/hda1 /home/annaig/windows vfat user,uid=1000,gid=100,umask=022 0 0

Pareil pour l'autre.

Link to post
Share on other sites

:non:

bon, j'ai été potasser lea et il semble qu'il faille effectivement que j'ajoute uid et gid.....

uid/gid

ces options permettent de fixer l'uid (user identifier) et le gid (group identifier) de tous les fichiers de ce système de fichier. Elles utilisent la syntaxe :

/dev/hda2 /mnt/dos_c vfat user,uid=500,gid=500 0 0

Lorsque la partition /dev/hda2 est montée, tous ses fichiers appartiennent au groupe 500 et à l'utilisateur 500 (voir les fichiers /etc/group et /etc/passwd pour savoir leur nom !).

Si vous ne précisez rien : les fichiers appartiennent à l'utilisateur ayant appelé mount (root si vous n'avez rien fait de spécial).

:transpi: neologix :francais:

je n'ai plus qu'à trouver quel nombre correspond à mon utilisateur :transpi:

Edit : bon, je pense que mon utilisateur et mon groupe annaig (précision : l'utilisateur annaig est dans le groupe annaig) ont 501 comme numéro vu que le fichier group donne ça :

 annaig:x:501:

et le fichier password donne ça :

 annaig:x:501:501:***** Annaig:/home/annaig:/bin/bash

(les * sont là pour cacher mon nom :keskidit:)

du coup j'ai changé les lignes de mon fstab pour les partitions windows et data :

/dev/hda1 /home/annaig/windows vfat user,rw,noatime,gid=501,uid=0,umask=002,iocharset=iso8859-15,codepage=850 0 0
/dev/hda2 /home/annaig/data vfat user,rw,noatime,gid=501,uid=0,umask=002,iocharset=iso8859-15,codepage=850 0 0

donc j'ai bien comme groupe : annaig et comme utilisateur c'est root....

mais je ne peux toujours pas supprimer un fichier.... :mdr:

est-ce qu'il faut que je mette uid=501 aussi ou pas.. sinon est-ce que je ne devrais pas mettre umask=000 pour éviter ce problème ? ...... je suis un peu larguée là...

Link to post
Share on other sites

c'est sûr que ça serait mieux (merci du conseil) mais c'est mon portable perso et personne n'y touche donc ça ne m'inquiète pas : je suis le seul utilisateur (et en plus il boote par défaut sous windows si quelqu'un veut vraiment l'allumer)

ça me fait penser qu'il va falloir que je vois comment demander le mot de passe utilisateur au démarrage.. ça serait mieux.

Link to post
Share on other sites

bon, je croyais aussi que c'était résolu.. mais que nenni.. en réutilisant un peu plus ma mandrakelinux que j'avais délaissé quelque peu, je me suis rendue compte que ça merdait encore :-D

je re-explique je suis en dual boot windows XP home -Mandrakelinux 10.1 Official

j'ai deux partitions en FAT32 montées dans mon home : celle où est localisée windows et que j'ai appelé.. windows et celle de données qui s'appelle data. (je ne sais pas s'il est utile de signaler que cette dernière partition était d'origine sur le DD de mon portable [config dans mon profil])

voici mon fstab, qui définit mon user annaig comme propriétéaire de ces partitions normalement. le umask en plus est à zéro donc tout le monde devrait pouvoir tout faire...

/dev/hda5 / ext3 noatime 1 1 /dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda1 /home/annaig/windows vfat  user,rw,noatime,gid=501,uid=501,umask=000,iocharset=iso8859-15,codepage=850 0 0
/dev/hda2 /home/annaig/data vfat user,rw,noatime,gid=501,uid=501,umask=000,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0 
/dev/sda1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,kudzu,codepage=850,noauto,exec,users 0 0

quand je regarde les droits sur data et windows.. ça colle

drwxrwxrwx  27 annaig annaig  16K jan  1  1970 windows/
drwxrwxrwx  13 annaig annaig 8,0K jan  1  1970 data/

mais en fait tout ne va pas bien dans le meilleur des mondes... quand je regarde les sous dossiers de la partition data par exemple ... y'a des problèmes... (vous remarquerez le merdier de dossiers installés de base dans cette partition par Windows :/ )

drwxrwxrwx  13 annaig annaig 8,0K jan  1  1970 ./
drwxrwxrwx   3 annaig annaig 8,0K jun  6  2002 patch/
drwxrwxrwx   2 annaig annaig 8,0K jun  6  2002 images/
drwxrwxrwx   2 annaig annaig 8,0K jun  6  2002 office/
drwxrwxrwx   2 annaig annaig 8,0K jun  6  2002 other/
drwxrwxrwx   3 annaig annaig 8,0K aoû  4  2004 System Volume Information/
drwxrwxrwx   2 annaig annaig  88K aoû  4  2004 Recycled/
drwxrwxrwx   3 annaig annaig 8,0K aoû  4  2004 fdbcfe33d702977bed40f1cf2d33/
drwxrwxrwx   3 annaig annaig 8,0K aoû  4  2004 Program Files/
drwxrwxrwx   3 annaig annaig 8,0K jan  3 20:20 Thunderbird/
dr-xr-xr-x   3 annaig annaig 8,0K jan 18 11:46 MSOCache/
dr-xr-xr-x  18 annaig annaig  16K avr 16 00:00 MesDocs/

il faut surtout regarder le dernier de cette liste : MesDocs, qui est le dossier qui contient toutes mes données : je n'ai pas les droit complêts dessus.. ce qui est plutôt génant.... (le dossier "Mes Documents" de windows pointe là dessus en fait)

est-ce que vous comprenez pourquoi ?

merci d'avance

Link to post
Share on other sites

c'est dans la partition data en fait ces dossiers (j'ai éditer pour mieux expliquer).. donc je vais plutot faire un

chmod -R 777 /home/annaig/data

:-D

(je suppose que je dois être en root ? )

ça marche effectivement, j'ai bien maintenant :

drwxrwxrwx  18 annaig annaig  16K avr 16 00:00 MesDocs/

mais est-ce que ça ne risque pas de recommencer au prochain reboot ou remontage de ces partitions ?

Link to post
Share on other sites

×
×
  • Create New...