Jump to content

Installe Drivers Radeon via tuto PC INpact...


Recommended Posts

Bonjour, et aussi merci de m'accueillir sur votre forum car ceci est mon premier post.

Je suis novice sur linux et encore plus sur debian..même si je suis dur a la comprenette je m'améliore de jrs en jrs et j'adore linux et le gpl!!!

J'essaye étape par étape d'avancer dans la configuration de ma debian, Aujourdhui j'ai essayé de configurer ma Radeon 9500 Pro pour pouvoir jouer par la suite.

J'ai donc pr ca suivi votre tuto ici: voici un copié collé de ma console qui resumera mieux que mes mots ce que j'ai fait et mes versions xfree et kernel.

# uname -r

2.6.8-1-686

debian:/home/root# XFree86 -version

This is a pre-release version of XFree86, and is not supported in any

way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted

to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,

please check the latest version in the XFree86 CVS repository

(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-8 20040928112350 fabbione@fabbione.net)

Release Date: 15 August 2003

X Protocol Version 11, Revision 0, Release 6.6

Build Operating System: Linux 2.4.26 i686 [ELF]

Build Date: 28 September 2004

        Before reporting problems, check http://www.XFree86.Org/

        to make sure that you have the latest version.

Module Loader present

OS Kernel: Linux version 2.6.8-1-686 (dilinger@toaster.hq.voxel.net) (gcc version 3.3.4 (Debian 1:3.3.4-11)) #1 Tue Sep 14 00:22:58 EDT 2004

debian:/home/root# alien fglrx-4.3.0-3.14.1.i386.rpm

fglrx_4.3.0-4.14_i386.deb generated

debian:/home/root# dpkg -i --force-overwrite fglrx_4.3.0-4.14_i386.deb

(Lecture de la base de données... 101746 fichiers et répertoires déjà installés.)

Préparation du remplacement de fglrx 4.3.0-4.14 (en utilisant fglrx_4.3.0-4.14_i386.deb) ...

Dépaquetage de la mise à jour de fglrx ...

Paramétrage de fglrx (4.3.0-4.14) ...

debian:/home/root# cd /lib/modules/fglrx/build_mod

debian:/lib/modules/fglrx/build_mod# chmod +x ./make.sh

debian:/lib/modules/fglrx/build_mod# ./make.sh

ATI module generator V 2.0

==========================

initializing...

kernel includes at /usr/src/linux/include not found or incomplete

file: /usr/src/linux/include/linux/version.h

debian:/lib/modules/fglrx/build_mod# cd ..

debian:/lib/modules/fglrx# chmod +x ./make_install.sh

debian:/lib/modules/fglrx# ./make_install

bash: ./make_install: Aucun fichier ou répertoire de ce type

debian:/lib/modules/fglrx#

J'ai deja fait l'experience jusqu'au bout ensuite en passant l'erreur "Aucun fichier ou répertoire de ce type" je suis arrivé a la configuration que j'ai passé avec succés,malheureusement je n'ai toujrs pas de 3D.

Merci d'avance de toute l'aide que vous pourrez m'apporter.

PS:je suis sous Nforce2 avec une Abit Nf7-s rev2.0.

Link to comment
Share on other sites

salut..et merci de prendre du temps pr me repondre...

alors ne voyant pas trop ce que je dois faire avec les lignes que tu m'a données voici ce que j'ai fait,si cela peut t'aider a m'aider :francais:

# ls -l /usr/src

total 8

drwxr-xr-x  2 root root 4096 2004-10-10 18:56 ATI

drwxr-xr-x  7 root root 4096 2004-10-10 09:27 rpm

debian:/home/root# du -h /usr/src/linux

du: ne peut accéder `/usr/src/linux': Aucun fichier ou répertoire de ce type

debian:/home/root# cat /proc/version

Linux version 2.6.8-1-686 (dilinger@toaster.hq.voxel.net) (gcc version 3.3.4 (Debian 1:3.3.4-11)) #1 Tue Sep 14 00:22:58 EDT 2004

debian:/home/root#

J'ai installé le kernel via Synaptic.. ceci explic PEUT-ETRE cela? Jpensait que ça me suffisait jtrouvait d'ailleurs étrange de ne pas avoir entendu parler de compilation ou autre mots que je connais pas trop.... ;)

Comment je peut installer mes sources?

merci.

Link to comment
Share on other sites

Eh bien il te faut les sources du noyau pour pouvoir installer ce genre de driver.

Sous debian, il faut regarder du coté de apt-cache search kernel-source. Ensuite il faut créer un lien symbolique /usr/src/linux pour le faire pointer sur les entetes du noyau actuel. A mon avis, tu as quelques tutos à lire.... Meilleurs topics forum linux dans ma signature.

Link to comment
Share on other sites

Jvais donc m'essayer avec ce tuto ici..

j'ai donc fait la premiere partie.. facile,le reste a l'air beaucoup moins sympa :inpactamd:

Je suis rendu ici ou tout les packages suivant sont installé:

which gcc

dpkg -l | grep kernel-package

dpkg -l | grep libncurses5

dpkg -l | grep binutils

dpkg -l | grep module-init-tools

l'etape 3.2 Configuration et recompilatio je suis obligé d'y passer je suppose :incline:

merci en tout cas de tes reponses...

Link to comment
Share on other sites

debian:/lib/modules/fglrx# chmod +x ./make_install.sh

debian:/lib/modules/fglrx# ./make_install

bash: ./make_install: Aucun fichier ou répertoire de ce type

T'es sûr qu'il ne faut pas taper "./make_install.sh" au lieu de ./make_install ??

Link to comment
Share on other sites

Bonjour, j'ai ete un peu long a repondre, mais un wk de feu et un debut de semaine qui est pas mal non plus...lol

je retiendrais surtout ton message vinced33 qui ressemble tout a fait a mon probleme,et comme d'apres ce que j'ai vu tu a bien expliqué comment faire je devrais reussir... au pire je sais ou venir crier a l'aide..

:yes:

merci beaucoup jvous tiens au courant dés que j'ai fait!!!

encore merci pr l'aide........... :eeek2::yes:

Link to comment
Share on other sites

salut

eh bien voila latruite on est tout deux a avoir une carte ATI et a avoir le kernel 2.6.8.1

ca va etre pas mal car on va pouvoir evolué dans nos demarches ensemble :keskidit:

quel chipset de carte mere utilises tu? si c'est du nvidia alors on possedera quasiment la meme chose et si c'est une asus a7n8x ca sera le comble du comble car nos config sera tres similaire

Link to comment
Share on other sites

salut a tous

j'ai donc reussi a configurer "partiellement" le drivers ATI sur ma machine

Pourquoi partiellement?

Et bien en fait je suis en bi ecran donc pour les modes single et clone ca fonctionne avec l'acceleration en bidouillant quand meme le Xfree a la main ( je trouve quand meme les perf mediocres 2060-2100).

# File: XF86Config-4

# File generated by fglrxconfig © ATI Research, a substitute for xf86config.

# **********************************************************************

# DRI Section

# **********************************************************************

Section "dri"

# Access to OpenGL ICD is allowed for all users:

    Mode 0666

EndSection

# **********************************************************************

# Module section -- this  section  is used to specify

# which dynamically loadable modules to load.

# **********************************************************************

#

Section "Module"

  Load        "dbe"  # Double buffer extension

    SubSection  "extmod"

      Option    "omit xfree86-dga"  # don't initialise the DGA extension

    EndSubSection

# This loads the Type1 and FreeType font modules

    Load        "type1"

    Load        "freetype"

# This loads the GLX module

    Load        "glx"  # libglx.a

    Load        "dri"  # libdri.a

EndSection

# **********************************************************************

# Files section.  This allows default font and rgb paths to be set

# **********************************************************************

Section "Files"

    RgbPath "/usr/X11R6/lib/X11/rgb"

#  FontPath  "/usr/X11R6/lib/X11/fonts/local/"

    FontPath  "/usr/X11R6/lib/X11/fonts/misc/"

    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"

    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"

    FontPath  "/usr/X11R6/lib/X11/fonts/Type1/"

    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo/"

    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/"

    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/"

# The module search path.  The default path is shown here.

#    ModulePath "/usr/X11R6/lib/modules"

EndSection

# **********************************************************************

# Monitor section

# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "Monitor0"

    HorizSync  31.5 - 48.4

    VertRefresh 60 - 75

    Option "DPMS"

EndSection

Section "Monitor"

    Identifier  "Monitor1"

    HorizSync  31.5 - 48.4

    VertRefresh 60 - 75

    Option "DPMS"

EndSection

# **********************************************************************

# Graphics device section

# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"

    Identifier  "Standard VGA"

    VendorName  "ATI"

  Chipset      "ATI RV350 AR (R9600 PRO)"

    Driver      "fglrx"

    Option      "AGPMode" "8"[/color=red]

    Option      "UseCCEFor2D" "false"

    BoardName  "Unknown"

#    BusID      "PCI:0:10:0"

#    VideoRam    256

#    Clocks      25.2 28.3

EndSection

###############################################################################################

###############################################################################################

# === ATI device section ===

Section "Device"

    Identifier                          "ATI Graphics Adapter"

    Driver                              "fglrx"

# ### generic DRI settings ###

# === disable PnP Monitor  ===

    #Option                              "NoDDC"

# === disable/enable XAA/DRI ===

    Option "no_accel"                  "no"

    Option "no_dri"                    "no"

# === misc DRI settings ===

  Option "mtrr"                      "on" # disable DRI mtrr mapper, driver has its own code for mtrr[/color=red]

# ### FireGL DDX driver module specific settings ###

# === Screen Management ===

    Option "DesktopSetup"              "0x00000100"

    Option "MonitorLayout"              "AUTO, AUTO"

    Option "IgnoreEDID"                "off"

    Option "HSync2"                    "31.5 - 48.4"

    Option "VRefresh2"                  "60 - 75"

    Option "ScreenOverlap"              "0"

# === TV-out Management ===

    Option "NoTV"                      "yes"   

    Option "TVStandard"                "NTSC-M"   

    Option "TVHSizeAdj"                "0"   

    Option "TVVSizeAdj"                "0"   

    Option "TVHPosAdj"                  "0"   

    Option "TVVPosAdj"                  "0"   

    Option "TVHStartAdj"                "0"   

    Option "TVColorAdj"                "0"   

    Option "GammaCorrectionI"          "0x00000000"

    Option "GammaCorrectionII"          "0x00000000"

# === OpenGL specific profiles/settings ===

    Option "Capabilities"              "0x00000000"

# === Video Overlay for the Xv extension ===

    Option "VideoOverlay"              "on"

# === OpenGL Overlay ===

# Note: When OpenGL Overlay is enabled, Video Overlay

#      will be disabled automatically

    Option "OpenGLOverlay"              "off"

# === Center Mode (Laptops only) ===

    Option "CenterMode"                "off"

# === Pseudo Color Visuals (8-bit visuals) ===

    Option "PseudoColorVisuals"        "off"

# === QBS Management ===

    Option "Stereo"                    "off"

    Option "StereoSyncEnable"          "1"

# === FSAA Management ===

    Option "FSAAEnable"                "no"

    Option "FSAAScale"                  "1"

    Option "FSAADisableGamma"          "no"

    Option "FSAACustomizeMSPos"        "no"

    Option "FSAAMSPosX0"                "0.000000"

    Option "FSAAMSPosY0"                "0.000000"

    Option "FSAAMSPosX1"                "0.000000"

    Option "FSAAMSPosY1"                "0.000000"

    Option "FSAAMSPosX2"                "0.000000"

    Option "FSAAMSPosY2"                "0.000000"

    Option "FSAAMSPosX3"                "0.000000"

    Option "FSAAMSPosY3"                "0.000000"

    Option "FSAAMSPosX4"                "0.000000"

    Option "FSAAMSPosY4"                "0.000000"

    Option "FSAAMSPosX5"                "0.000000"

    Option "FSAAMSPosY5"                "0.000000"

# === Misc Options ===

    Option "UseFastTLS"                "0"

    Option "BlockSignalsOnLock"        "on"

    Option "UseInternalAGPGART"        "no"

    Option "ForceGenericCPU"            "no"

    BusID "PCI:3:0:0"    # vendor=1002, device=4152

    Screen 0

EndSection

# **********************************************************************

# Screen sections

# **********************************************************************

Section "Screen"

    Identifier  "Screen0"

    Device      "ATI Graphics Adapter"

    Monitor    "Monitor0"

    DefaultDepth 24

    #Option "backingstore"

    Subsection "Display"

        Depth      24

        Modes      "1024x768"

        ViewPort    0 0  # initial origin if mode is smaller than desktop

#        Virtual    1280 1024

    EndSubsection

EndSection

# **********************************************************************

# ServerLayout sections.

# **********************************************************************

Section "ServerLayout"

    Identifier  "Server Layout"

    Screen "Screen0"

    InputDevice "Mouse1" "CorePointer"

    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

### EOF ###

Le but etant evidement d'avoir un bureau different sur les ecrans sinon cela ne sert a rien mais c'est la ou ca coince.

les 2 autres modes ecran large et double bureau ne fonctionnent pas, impossible de demarrer X , les deux ecrans deviennent noir et initialise pas l'interface tout reste bloqué et je suis obligé de rebooter a la sauvage.

Autre petit prebleme mais il y est depuis le debut de l'installation des drivers.

Dans le log Xfree il y a ceci:

(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found

peut etre y a t'il un rapport avec mon probleme

pas de nouvelle de latruite,c'est domage enfin pourvu qu'il revienne assez vite pour qu'il nous dises comment c'est passé sa compilation

Ah oui j'oubliais j'ai installé Tuxracer pour essayer l'acceleration materielle et il plante literalement ecran noir et obligé de rebooter aussi a la facon sauvage.

Link to comment
Share on other sites

j'ai trouvé une autre erreur mais cette fois dans dmsg toujours a propos de mon ati

agpgart: AGP aperture is 64M @ 0xe0000000

Power management callback for AGP chipset installed

[fglrx] AGP detected, AgpState  = 0x00000000 (hardware caps of chipset)

[fglrx:firegl_unlock] *ERROR* Process 2897 using kernel context 0

et comment savoir si l'agp 8x est bien activé?

Link to comment
Share on other sites

[tsubasa@mdk101 tsubasa]$ cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 8x

Fast Writes: Disabled

SBA: Enabled

[tsubasa@mdk101 tsubasa]$

[tsubasa@mdk101 tsubasa]$ cat /proc/driver/nvidia/agp/host-bridge

Host Bridge: PCI device 10de:01e0

Fast Writes: Supported

SBA: Supported

AGP Rates: 8x 4x

Registers: 0x1f00421b:0x00000302

[tsubasa@mdk101 tsubasa]$

Link to comment
Share on other sites

alors la je dois vraiment avoir un soucis

debian:~# cat /proc/driver/nvidia/agp/status

cat: /proc/driver/nvidia/agp/status: Aucun fichier ou répertoire de ce type

debian:~# cat /proc/driver/nvidia/agp/host-bridge

cat: /proc/driver/nvidia/agp/host-bridge: Aucun fichier ou répertoire de ce type

Link to comment
Share on other sites

bon j'ai regardé un peu dans proc ce qu'il y avait et evidement ca ne pouvait pas fonctionner.

debian:/proc# ls

1      2620  2847  3046  3169  64        crypto      ioports  partitions

1005  2623  2848  3048  3171  65        devices      irq      scsi

2      2638  2849  3075  3175  66        diskstats    kallsyms  self

203    2683  2850  3091  3183  724        dma          kcore    slabinfo

2040  2689  2851  3097  3403  812        dri          kmsg      stat

2060  2695  2852  3099  3953  813        driver      loadavg  swaps

21332  2754  2863  3101  4    814        execdomains  locks    sys

22003  2755  2914  3119  4406  acpi      fb          meminfo  sysvipc

22074  2756  2961  3121  4407  asound    filesystems  misc      tty

22075  2759  3    3123  48    buddyinfo  fs          modules  uptime

22076  2765  3022  3127  5    bus        ide          mounts    version

22373  2790  3042  3133  562  cmdline    interrupts  mtrr      vmstat

2431  2841  3044  3159  63    cpuinfo    iomem        net

debian:/proc# ls driver

emu10k1  rtc  snd-page-alloc

debian:/proc# cat misc

  1 psaux

135 rtc

175 agpgart

donc voila pas de nvdia

voila ce que j'ai trouvé avec agp mais c'est tout.

aucun nvdia-agp ?

encore moins fglrx peut etre a cause des drivers proprio

PS : impossible de naviguer dans le repertoire proc en mode graphique (page blanche)

Link to comment
Share on other sites

salut a tous

j'ai recompilé mon kernel en 2.6.9 et j'ai essayé d'optimiser un peu en meme temps

j'ai reinstallé mes drivers ati et maintenant les problemes sont resolu tout du moins je crois.

probleme dans dmsg

agpgart: AGP aperture is 64M @ 0xe0000000

Power management callback for AGP chipset installed

[fglrx] AGP detected, AgpState  = 0x00000000 (hardware caps of chipset)

[fglrx:firegl_unlock] *ERROR* Process 2897 using kernel context 0

et maintenant

agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.

agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode

agpgart: Putting AGP V3 device at 0000:03:00.0 into 8x mode

[fglrx] AGP enabled,  AgpCommand = 0x1f004312 (selected caps)

:craint:

enfin l'agp 8x est bien defini

agpgart: AGP aperture is 64M @ 0xe0000000

par contre ca je l'ai toujours mais c'est dans le bios que ca se modifie

faut il reelement le changer (128 a tester)

dans le log XFree j'ai toujours ca mais on m'a dit que c'etait normal que tous le monde l'avait (si c'est vrai va falloir que ati bosse un peu pour les drivers)

(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found

donc j'ai testé glxgears (9600XT)

10318 frames in 5.0 seconds = 2063.600 FPS

10318 frames in 5.0 seconds = 2063.600 FPS

10318 frames in 5.0 seconds = 2063.600 FPS

10318 frames in 5.0 seconds = 2063.600 FPS

10317 frames in 5.0 seconds = 2063.400 FPS

pas fameux

test avec fgl_glxgears

debian:~# fgl_glxgears

1613 frames in 5.0 seconds = 322.600 FPS

1559 frames in 5.0 seconds = 311.800 FPS

2010 frames in 5.0 seconds = 402.000 FPS

2012 frames in 5.0 seconds = 402.400 FPS

2012 frames in 5.0 seconds = 402.400 FPS

2013 frames in 5.0 seconds = 402.600 FPS

2012 frames in 5.0 seconds = 402.400 FPS

et voila

ah oui et tuxracer fonctionne correctement alors qu'avant c'etait un crash complet de la machine

prochain episode on essait de mettre le bi ecran

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...