Jump to content

xorg + fglrx


swoke

Recommended Posts

Bonjour à tous.

Je suis sous debian sarge noyau 2.6.7 avec une radeon 9600 pro.

J'ai récuperé les sources CVS de xorg, que j'ai compilé puis installé.

J'ai ensuite créé mon fichier xorg.conf sur la base de celui de Xfree.

Probleme 1 : GDM ne marche pas (pas grave, je passe par xdm en attendant).

Là, tout marche bien jusqu'à ce que je lance un glxgears, qui reboot mon X, et me renvois sur xdm.

Un grep WW de /var/log/Xorg.0.conf me donne :

(WW) The directory "/usr/X11R6/lib/X11/fonts/Speedo/" does not exist.

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

(WW) fglrx: No matching Device section for instance (BusID PCI:2:0:1) found

(WW) fglrx(0): board is an unknown third party board, chipset is supported

(WW) fglrx(0): Cannot read colourmap from VGA.  Will restore with default

(WW) fglrx(0): could not detect XFree86 version (query_status=-3)

Des idées ?

Merci d'avance...

Link to comment
Share on other sites

On en a déjà parlé...

Les drivers ATi font en effet planter automatiquement X.org avec l'openGL

allez, on ressort le texte des ebuils gentoo, quand on veut utiliser ati-drivers avec X.org 6.8 :

You must downgrade to xorg-x11-6.7.0 otherwise

trying to use opengl will crash X

Better safe than sorry.

Les drivers libres ne marchent qu'avec les Radeon<9200 ... et encore, pas en 3D...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...