Jump to content

Archived

This topic is now archived and is closed to further replies.

etiennegaloup

Compilation PHP

Recommended Posts

En terme de charge Postgresql est plus stable et plus performant sur des requet bien farfelut que Mysql Par contre pour ce qui est du cluster Postgresql en propose un aussi mais il est tiré par les cheveux.

Mais bon Mon coeur ira toujours vers mon Gros nounours ORACLE :muscu:

Share this post


Link to post
Share on other sites

J'ai lu le topic debian sur la gestion des packages.

J'ai supprimé toutes les entrées CD de mon fichier sources.list et je les ai réajoutés avec apt-cdrom add,

ça fait exactement la même chose.

Par contre je n'ai pas le fichier preferences...

Sinon vous me conseillez de laisser tomber mes CD et de mettre un miroir dans sources.lists ?

Merci pour votre aide...

++

Share this post


Link to post
Share on other sites
Sinon vous me conseillez de laisser tomber mes CD et de mettre un miroir dans sources.lists ?

absolument

Share this post


Link to post
Share on other sites

Dernière petite question, vu les entrées CDROM que j'ai dans sources.lists, j'ai certainement installé des paquets UNSTABLE.

Comment le vérifier ?

Moi qui veut-être en STABLE, me conseillez-vous de réinstaller ma config ?

Ou n'est-ce pas la peine ?

Share this post


Link to post
Share on other sites
Dernière petite question, vu les entrées CDROM que j'ai dans sources.lists, j'ai certainement installé des paquets UNSTABLE.

à priori, non...

Tout ce qui est sur les CDroms est en stable (si c'est bien des cd debian woody)

Et les miroirs étaient marqué stable...

Share this post


Link to post
Share on other sites

Oui les miroirs sont en stable...

Et tu es d'accord pour dire que les CDROM sont en stables, et pourtant dans mon sources.lists

Pour chacun de mes CD, j'ai:

deb cdrom:[Debian GNU/Linux 3.0 r2 _Woody_ - Official i386 Binary-5 (20031201)]/ unstable contrib main non-US/contrib non-US/main

alors j'ai un peu de mal à comprendre, je suis en stable ou en unstable ?

J'ai quand même un peu de mal ... :-)

Share this post


Link to post
Share on other sites

gentoo powaa... suffit d'enlever le accept-keyword, et il te reconstruit tout le système si ya besoin pour etre stable

je sui sur que personne ne l'a vu... par contre l'odeur...

Share this post


Link to post
Share on other sites

je sui sur que personne ne l'a vu... par contre l'odeur...

il ressemblerait pas un peu a ce mec la : :yes: ??

Ben je ne sais comment tu as fait ton install, mais en tout cas, c'est loin d'etre propre. Ni avec quels cd d'ailleurs. Je te conseille :

:ouioui: Cree un fichier /etc/apt/preferences, et ajoutes y l'entree suivante :

Package: *

     Pin: release a=stable

     Pin-Priority: 1001

;) Ensuite, modifie ton /etc/apt/sources.list pour n'y ajouter que 2 entrees :

deb http://ftp.fr.debian.org/debian stable main contrib non-free

le security update qui doit deja y etre

ensuite,

:eeek2: apt-get clean && apt-get update && apt-get dist-upgrade

Share this post


Link to post
Share on other sites

Ok merci pour tes conseils,

pour mon install, j'ai pas fait grand chose de spécial...j'ai suivi une formation trouvé une très bonne formation sur le ouebe

Je ne comprends pas ce qui s'est passé...

Tu penses que je devrais tout réinstaller ?

De toute manière sur les CD, tous les packages sont en stable, vu qu'en plus mes CD sont des Woody... ? C toujours ce qu'on m'a dit...

Moi je veux juste comprendre

Merci encore...

A +

Share this post


Link to post
Share on other sites

pour mon install, j'ai pas fait grand chose de spécial...j'ai suivi une formation trouvé une très bonne formation sur le ouebe

je pensais que concernant debian, ce forum n'etait pas trop mal place, et qu'au pire les liens de ma signature etaient utiles...

elle est de qui ta formation debian ( je commence a pas trop mal connaitre les acteurs du monde debian... :reflechis: )

Share this post


Link to post
Share on other sites

Alexis Delattre !

Mais attention je ne remets pas en cause sa formation, elle est très bien...

C moi qui ait du merder quelque part, mais ou ?

C quoi la différence entre woody et stable ?

Parce que à chaque fois je vois les deux...La woody est stable...

Share this post


Link to post
Share on other sites

La formation d'alexis delattre est excellente. Je l'ai lu a plusieurs reprise ( elle est meme imprimee et reliee ) et je t'assures que si tu avais suivi sa formation, tu n'aurais pas eu ces merdes.

Bon, y a qd meme 2/3 trucs sur ce qu'il dit, pour une workstation, moi je recommande le passage en testing, et non en stable. apres delattre, les guide de reference debian sont plus pointus et techniquement plus corrects, mais moins accessible pour un debutant. donc, apres delattre, c'est bien !

Sinon, je pense que tes cd y a une couille, je ne sais pas ou tu les as eu, mais ils sont mal estampilles. Pas la peine de tout reinstaller si tu as suivi la manoeuvre que je t'ai donne.

Share this post


Link to post
Share on other sites

Ok merci beaucoup,

oui oui je l'ai lu aussi plusieurs fois et elle m'a bien aidé...

Donc sur mes CD y a une merdes, je les avais eu sur isolinux.org...

Quand je les parcours, il y a des répertoires stables,unstables, et testing...

Tant pis...

A plus,

sinon pour le RAID 1, j'ai installé des modules de mon noyaux 2.6.6 mais je crois que j'ai problème avec la détection de mon controleur RAID promise 20378...pourtant j'ai installé le module promise 20376 du noyau comme il est indiqué dans la doc...

Du coup même en RAID logiciel, je n'arrive pas à détecter mes DD,

A plus, merci encore...

Share this post


Link to post
Share on other sites
lors j'ai un peu de mal à comprendre, je suis en stable ou en unstable ?

Woody c'est stable. Donc tu as du stable à moins que tu n'ais fait un

#apt-get install foo -t unstable

ou

#apt-get install foo unstable/unstable

Ceci dit le

E: Sorry, broken packages
peut venir de deux versions différentes (donc stale et non-stable).

Tu peut aussi avoir un

nmap ran out of room
ou quelque chose comme ça, je ne sais plus. Dans ce cas, crée un apt.conf

Mais ce genre de truc ainsi que le source.list stable/unstable sans preferences et apt.conf, ça craint.

Je te conseille de te documenter sur le sujet, avec les tutos/google. Tu as le forum si tu n'y arrives pas, cherche avant.

Je te conseille aussi de virer les sources cdrom, c'est complètement inutile si tu as une bonne connection (ou un proxy apt :mad2:), et chiant à gérer.

C'est pas facile au début, moi j'ai beaucoup galéré sur ma debian au début (première distrib theo=>;)). Mais que du plaisir après.

Share this post


Link to post
Share on other sites

Bonsoir,

je n'ai pas fait

apt-get install foo unstable/unstable

Etant donné que c un serveur, j'ai voulu rester en stable.

apt-get install postgresql-dev

....

Sorry, but the following packages have unmet dependencies:

  postgresql-dev: Depends: libssl-dev but it is not going to be installed

E: Sorry, broken packages

Ce qui s'est passé exactement avec postgresql-dev:

l'apt-get voulait m'installer deux packages supplémentaires dont libssl-dev.

J'ai fait ensuite un apt-get install libssl-dev.

Il a m'a trouvé une dépendance avec un autre package déjà installé ssl-0.9.6 (un nom de ce genre, je ne me souviens plus). Ensuite il m'a dit que la version était 0.9.6-4 et lui voulait la 0.9.6-6. Je ne me souviens plus exactement mais c t quelque chose de ce genre.

Voili Voilou,

Sinon je pourrais tenter une réinstallation d'apt ? Je ne sais pas si c possible !!!

Vu que tu dis qu'il est bizarre que je n'ai pas de fichier preferences...

A d'c 4

++

Share this post


Link to post
Share on other sites

cherches pas, fait ce que je te dis, je pense avoir suffisament d'experience sous linux pour que tu me crois...Tu l'edites et tu le fait ton fichier de preferences....

Decidement Ethienne, j'ai vraiment l'impression de parler dans le vent avec toi !

Pour le raid, preferes du raid software tant que ton ctrl n'est pas supporte en natif par les noyaux des install...

Share this post


Link to post
Share on other sites
Il a m'a trouvé une dépendance avec un autre package déjà installé ssl-0.9.6 (un nom de ce genre, je ne me souviens plus). Ensuite il m'a dit que la version était 0.9.6-4 et lui voulait la 0.9.6-6. Je ne me souviens plus exactement mais c t quelque chose de ce genre.

Laisse moi deviner...

Tu as 0.9.7d-4 ou 0.9.7d-5 (testing/unstable)

Et lui veut installer 0.9.6c-2.woody.6 (stable)

http://packages.debian.org/cgi-bin/search_...all&release=all

Nan ? :reflechis:

Sinon les preferences/apt.conf tu les crée à la main. Sauf que si tu ne gardes que les stable dans ton sources.list, c'est inutile.

Share this post


Link to post
Share on other sites

Non Rémy, tu ne parles pas dans le vent, n'ai pas cette impression là, je n'ai pas du tout mis en doute ce que tu m'avais dit.

J'ai fait ce que tu m'as dit et ca marche nickel, merci encore....

pour mon dernier message je répondais à theocrite. Voila tout j'expliquais exactement ce que j'avais eu comme message d'erreur.

Tu as 0.9.7d-4 ou 0.9.7d-5 (testing/unstable)

Et lui veut installer 0.9.6c-2.woody.6 (stable)

Non pas exactement,

moi j'ai 0.9.6c-2.woody.4 (stable) et lui voulais 0.9.6c-2.woody.6 (stable)....

Un jour je viendra, je deviendrai un maître du linux

Share this post


Link to post
Share on other sites

Un jour je viendra, je deviendrai un maître du linux

Beaucoup croient etre des maitres linux. Et en rencotrant des grands maitres linux, tu te rends comptes que finallemet tu es tres loin d'etre un maitre linux, que tu connais simplement la base minimum, mais que ta cnnaissance est suffisante pour l'exploiter et l'utiliser tous les jours, avec un niveau un peu superieur a la moyenne, comme Sandeman ou moi par exemple. Je connais reellement 1 maitre linux, et via le net qq autres, mais c'est extremement rare.

Et si je devais noter mes connaissances par rapport a eux, ca donnerait 20% je pense, ouqqchose dans le genre. Je suis ingenieur de formation, pris en main par un maitre linux ( co auteur de squid et de sendmail, entre autres ), je travaille tous lesjours dedans, et j'en apprends tous les jours, donc, je ne pensepas qu'on puisse dire un jour je deviendrai un maitre linux. Sandeman a peu pres le meme cursus...

Un jour, peut etre que je serais un maitre linux serait plus correct.

La route est si longue pour devenir un maitre linux.... Sandeman, tres experiemente dans le domaine partagera certainement mon avis.

Share this post


Link to post
Share on other sites

bah oui, Sandeman il est tout petit scarabée en Linux, comparé à l'expert Linux que j'ai recruté dans mon équipe ... déjà lui il a son nom dans les changelog du noyau et de postgres ... :keskidit:

Share this post


Link to post
Share on other sites

Tu vois Ethienne, Sandeman et moi sommes d'accord sur ce point, on est loin d'etre maitres linuxiens, tres tres loin, et pourtant, il n'y a pas encore un pb sur ce forum auquel nous n'avons pas su repondre, . ( pas a ma connaissance ni dans mes souvenirs ). Et on n'a pas besoin d'aller chercher sur google les reponses... :chinois:

Long the way to the force is. :keskidit:

ps : Sandeman, faudrait que dans l'aprem on fasse leplan de notre article.... -> mail ou MP.

Share this post


Link to post
Share on other sites

Ok Ok j'en prends bonne note...

Merci pour votre précieuse aide...

Ouaoh, si déjà vous, vous n'êtes pas des maîtres linux, alors moi qu'est-ce que je suis, j'crois que j'ai encore pas mal de chemin à accomplir, et ça fait combien de tant que vous baignez dedans ?

Share this post


Link to post
Share on other sites

5 ans pour ma part, bientot 6. Et il n'y a pas 2 jours sans que je sois dedans... C'est mon taf et a la fois une passion...

Share this post


Link to post
Share on other sites

première compile de noyau : 1.2.8

ce qui nous amène à ... mai 95 ...

en 2ème année d'école d'ingé (

:pciwin:

On avait un allumé, prénommé Remi et surnommé Rémix :transpi::D qui nous avait proposé une install party avec les 65 disquettes de la Slack de l'époque (stockées sur le LAN, quand même, on était pas furieux à ce point).

Share this post


Link to post
Share on other sites

×
×
  • Create New...