Jump to content

Archived

This topic is now archived and is closed to further replies.

falcom

Vmware sous linux

Recommended Posts

Oui question bateau, mais qu'on m'explique

Pour installer Vmware sous linux faut le kernel source, ca ok.

En theorie il est sous /usr/src

Je l'indique lors de l'install de Vmware (./vmware-config.pl) et il me sort ca:

The directory of kernel headers (version 2.6.4-52-default) does not match your

running kernel (version 2.6.5-7.95-default). Even if the module were to compile

successfully, it would not load into the running kernel.

Ma question est quel kernel qu'il lui faut car sous la SUSE 9.1, y a le kernel defaut, le kernel source et kernel-smp the standard kernel.

En fait je l'ai installer hier et vmware se lancait, j'ai relancer la becane et il veut plus, et quand je relance l'install j'ai le message d'erreur ci dessus.

Share this post


Link to post
Share on other sites

Ben il faut que les sources correspondent au noyau...

Donc si tu peux, il faut que tu mette la bonne version...

Mais le meilleur moyen est quand même de recompiler... Pour moi, ça a toujours été plus rapide que de trouver les sources correspondant au noyau (en plus, ça accélère :transpi:)

Share this post


Link to post
Share on other sites

le script "vmware-config.pl" (ou un nom du genre) ne te fait pas tout bien comme il faut ?

(c'est là que vous apprécieriez une Gentoo ... pour installer une vmware il n'y a besoin que ... du serial :)

Share this post


Link to post
Share on other sites
Jamais eu de sous avec VMWare sous Redhat et Fedora :roll:

Moi non plus, j'ai jamais eu de sous avec VMware...

'sont vachement radins... :transpi:

Share this post


Link to post
Share on other sites
;) pas beaucoup dormi

je voulais dire

pas eu de probleme

Ouais j'avais compris, mais j'ai pas pu m'empêcher :D

Share this post


Link to post
Share on other sites

c'est clair sous fedora, auun problème , même avec le dernier noyau ( il faut la dernière version de vmware par contre .... )

Share this post


Link to post
Share on other sites

Salut,

Le problème n'est pas une question de distrib ...

Mais de la manière dont le noyau a été installé.

Installes le dernier noyau de la SuSE (2.6.5-7.95) ainsi que ses sources.

Tu verras tout ira mieux.

Donc tu installes le "kernel-default" qui est juste l'image.

Et le "kernel-soure" qui corespont à ton image.

Vérifies bien (mais Yast le fait automatiquement) que "/usr/src/linux" pointe bien vers "/usr/src/linux-ton-noyau"

Share this post


Link to post
Share on other sites

Je sais que l'install n'est pas tres complique, j'avais reussit a l'installer sous MDK10 et FEDORA CORE 2

Comme je l'ai preciser plus haut sur la suse 9.1, j'ai reussit a l'installer apres avoir mis le kernel sourceet le lancer. Mais si je me souvient bien a pres j'ai fait une mise a jour du systeme.

Apres vmware n'a plus voulu se lancer (reboot machine en tres temps pour prise en compte mise a jour), me disant qu'il n'avait jamais ete configurer. Du coup je veut le relancer et la il m'affiche le message d'erreur que j'ai mis au premier message.

Comme disait tuXXX, le plus simple c'est de recompiler le noyau par rapport a la source, que je ferais plus tard. Et vous tiendrais au courant

Sinon question bete, si je reinstalle tous linux, y a moyen de conserver les donnees sur la plus grande partoche et ne toucher qu'au system???

Je suis un noobs linux :mad2:

Share this post


Link to post
Share on other sites
Sinon question bete, si je reinstalle tous linux, y a moyen de conserver les donnees sur la plus grande partoche et ne toucher qu'au system???

Ben tu copie tes donnée sur une partition qur tu montera en home... (/home/utilisateur)

Donc tu installe linux comme si de rien n'était (enfin normalement quoi :yes:), et après tu pettra ta partition de données sur ton home dans le fstab...

Share this post


Link to post
Share on other sites

C'est quoi l'intérêt d'installer WMWare (propriétaire et payant) lorsqu'il existe Qemu (libre et gratuit) ?

Et qu'il existe des packages pour chaque distribution ?

Et que l'utilisation est super simple (y'a pas a jouer avec le kernel).

Share this post


Link to post
Share on other sites

Peut etre parce que c'est le meilleur du marché :yes:

Et quand un logiciel est bon et efficace j'ai pas de mal à payer une licence

:yes:

Share this post


Link to post
Share on other sites

Il n'ya pas encore de version stable de Qemu alors que Vmware est la depuis longtemps

Share this post


Link to post
Share on other sites

Je me suis aperçu que vmware workstation était inclu dans ma distrib.

J'ai un problème à l'install, voilà une copie du post que j'ai mis sur hardware.Fr :

Je possède une mandrake 10.0 

J'ai voulu installer vmware workstation (qui est inclu dans la distrib) 

J'ai bien installé le kernel source correspondant (2.6.3-19) à la version du noyau que j'utilise. 

Puisque j'utilise un noyau 2.6, j'ai également téléchargé et éxécuté vmware-any-any-version. À la fin de l'execution de ce script, on me dit que l'install s'est correctement déroulée, et qu'il suffit de taper /usr/bin/vmware pour que cela fonctionne.

malheureusemen je reçois toujours le même message d'erreur : apparait une boite de dialogue me disant que "vmware has been installed but it hasn't have been correctly configured for your kernel" ...

Je suis dans une impasse, mes recherches sur le net n'ont rien données; si quelqu'un a une idée qu'il n'hésite pas

Je ne vois pas de solution...

Share this post


Link to post
Share on other sites

plus sérieusement, t'as lancé tout ça en root?

Parce que je me souvient qu'un programme créait les modules noyau et les installait...

Share this post


Link to post
Share on other sites
plus sérieusement, t'as lancé tout ça en root?

Parce que je me souvient qu'un programme créait les modules noyau et les installait...

Oui, le tout en root...

Je me suis testé qemu, toute la doc est en anglais (j'ai quand même trouvé un tuto en français !) c'est une horreur ça me saoule d'arriver à rien (/dev/net/tun no virtual machine => cette erreur sous google me retourne 4 pauvres réponses en espagnol ou hongrois) d'autant plus que je dois aller au taf RAHHHAHHAHAHAHAHHAJ

moioaohzohdoehfpohfpzjnehdfoziefhioezhofihizohfcjezofcjiiojzijfioejiiiiiiidfoecfojzjiiiiilzdrkcfjfiochridhcjdhzcjhrzcfffzjhef

HIHUIHUHIHUHUHIHIH

Ça ira mieux ce soir... :fou: :fou: :fou:

:francais::mdr::eeek2::yes::francais::-D:francais::love::mdr::francais::smack::pleure::pleure::pleure::pleure:

Share this post


Link to post
Share on other sites

faut installer la 0.6...

(et sous gentoo, faut activer "softmmu", sinon c pas super...)

ensuite, créer un disque virtuel avec dd...

et lancer :

qemu -hda [nom de l'image disque] -cdrom [iso] -boot d

(pour booter sur un cd d'install)

ou bien

qemu -hda [image disque]

(une fois que c bon)

Il faut tun/tap driver pour pouvoir utiliser le réseau, mais sans, ça marche quand même...

(et -enable-audio pour avoir le son)

Share this post


Link to post
Share on other sites

×
×
  • Create New...