Jump to content

Archived

This topic is now archived and is closed to further replies.

vinced33

Driver ATI MDK 10 OFF

Recommended Posts

salut

apres une journee laborieuse avec les drivers ati, j ai tout de meme reussi a les installer alors je vous fait profiter de cette installation pour ceux qui auraiient des probleme et je crois que je ne suis pas le seul avec ce que j ai pu voir sur different forum

bon alors voila reinstallation effectue de mandrake 10 officiel

en detaiils

telechargement des drivers sur www.ati.com

rpm -Uvh --force fglrx-4.3.0-.3.9.0.i386.rpm

et la probleme de kernel source donc :

cd /lib/modules/fglrx/build_mod/

sh ./make.sh ok

cd..

sh ./make_install.sh ok

chargement du kernel-source 2.6.3.7 ok

ensuite configuration

fglrxconfig ------> tout par defaut

un petit coup de lsmod pour voir ce qu il y a

fglrx

agpgart

tout a l air pas trop mal pour le moment

comme j ai une a7n8x (NVIDIA) j utilise le module nvidia-agp

donc je decharge le tout

en root

rmmod fglrx

rmmod agpgart

et je recharge

modprobe fglrx

modprobe nvidia-agp

lsmod pour visualise et les 2 y sont ok

je regarde mon syslog et a priori tout y est

je refais un fglrxconfig avec les nouveaux parametres

ok pas de probleme

[root@localhost vinced33]# lsmod

Module Size Used by

fglrx 205028 0

nvidia-agp 7388 1

agpgart 31016 1 nvidia-agp

mais voila agpgart est toujours la

cd /usr/X11R6/lib

rm libGL.so.1

ln -s libGL.so.1.2 libGL.so.1

ajout de

fglrx

nvidia-agp

dans etc/modprobepreload

lsmod

nvidia-agp 7388 1

agpgart 31016 1 nvidia-agp

fglrx 205028 0

fglrxconfig

attention au port souris apparement c'est important normalement avec une ps2 c'est

/dev/psaux

mettre yes a external agp

cd /usr/X11R6/lib

rm libGL.so.1

ln -s libGL.so.1.2 libGL.so.1

exit

reboot

[vinced33@localhost vinced33]$ glxinfo

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.2

direct rendering a YES ca fait plaisir je crois qu'on y est cette fois

un petit test avec la commande glxgears

[vinced33@localhost vinced33]$ glxgears

15069 frames in 5.0 seconds = 3013.800 FPS

16256 frames in 5.0 seconds = 3251.200 FPS

16259 frames in 5.0 seconds = 3251.800 FPS

16260 frames in 5.0 seconds = 3252.000 FPS

16260 frames in 5.0 seconds = 3252.000 FPS

18665 frames in 5.0 seconds = 3733.000 FPS

19730 frames in 5.0 seconds = 3946.000 FPS

19750 frames in 5.0 seconds = 3950.000 FPS

19747 frames in 5.0 seconds = 3949.400 FPS

19092 frames in 5.0 seconds = 3818.400 FPS

21360 frames in 5.0 seconds = 4272.000 FPS

23618 frames in 5.0 seconds = 4723.600 FPS

23525 frames in 5.0 seconds = 4705.000 FPS

23622 frames in 5.0 seconds = 4724.400 FPS

23416 frames in 5.0 seconds = 4683.200 FPS

23525 frames in 5.0 seconds = 4705.000 FPS

23467 frames in 5.0 seconds = 4693.400 FPS

23294 frames in 5.0 seconds = 4658.800 FPS

23872 frames in 5.0 seconds = 4774.400 FPS

et ca y est enfin on y est arrive

test avec tux racer ca fonctionne a merveille

test

lsmod

nvidia-agp 7388 1

agpgart 31016 2 nvidia-agp

fglrx 205028 128

toujours les 3 je ne sais pas pourquoi mais ca marche donc on va pas chercher plus loin.

Share this post


Link to post
Share on other sites

Marrant le coup des "ln -s" sur les libLG.so (moi je dis :byebye: quand même :dors:)

Sinon par rapport au lsmod

lsmod

nvidia-agp 7388 1

agpgart 31016 2 nvidia-agp

fglrx 205028 128

tu vois bien que nvidia-agp est utilisé par agpgart, donc tu ne risque pas le voir partir (nvidia-agp est utilisé, mais à traver agpgart...)

Ah oui, sinon, rassure-moi, pour le glxgears, tu as redimensionné ta fenêtre pour que ça augmente comme ça...

Share this post


Link to post
Share on other sites

salut

tu vois bien que nvidia-agp est utilisé par agpgart, donc tu ne risque pas le voir partir (nvidia-agp est utilisé, mais à traver agpgart...)

ok donc c est normal alors

Ah oui, sinon, rassure-moi, pour le glxgears, tu as redimensionné ta fenêtre pour que ça augmente comme ça...

non pas du tout je ne savais pas du tout qu on pouvait la redimensionner

j avais plus la tete a ca j y etais depuis lce matin

je croyais que c etais normal

je vais reesayer pour voir

[vinced33@localhost vinced33]$ glxgears

12914 frames in 5.0 seconds = 2582.800 FPS

15044 frames in 5.0 seconds = 3008.800 FPS

23348 frames in 5.0 seconds = 4669.600 FPS

26408 frames in 5.0 seconds = 5281.600 FPS

26522 frames in 5.0 seconds = 5304.400 FPS

26326 frames in 5.0 seconds = 5265.200 FPS

21512 frames in 6.0 seconds = 3585.333 FPS

24955 frames in 5.0 seconds = 4991.000 FPS

26159 frames in 5.0 seconds = 5231.800 FPS

non c est bien comme ca pourquoi c est pas normal?

Share this post


Link to post
Share on other sites

Oué c po "normal" que ca augmente comme ca, chez moi sous debian sid ca reste a 3900/4000 fps sans bouger la fenetre avec une 9700pro et un 1700+, quelle carte as-tu toi?

Share this post


Link to post
Share on other sites

ouais bah chez moi ca dépasse pas les 2400 ;'(

Bon, chuis sur un portable avec une sale GF fx 5200

ca fait pleurer quand même, surtout que le cpu est un P4 3,06 GHz :'(

Mais les perfs varient quand même selon ce que j'ai d'ouvert ( ce qui est normal me direz vous ;-) )

Share this post


Link to post
Share on other sites

Moi, en général, le premier score est d'environ 2500, et les autres 2700...

Avec ma GF3...

Mais bon, glxgears est pas très représentatif, il faut essayer un jeu pour voir bien...

'fin bon, j'ai jamais vu un truc faire ça (passer de 2500 à 5200 en augmentant petit à petit lol)

Share this post


Link to post
Share on other sites

salut

pourtant c est bien ce que j ai d ecrit, apres ca se stabilise entre 5000 et 5200 donc etant debutant sous linux je pensaiis que c etais normal.

config utilisé

A7N8X -e deluxe + XP 2400 + 512 DRR corsair + 9600XT iceQ (HIS) +HDD 120 SATA150 + HDD 120ATA les 2 hitachi

donc c est une config correct mais pas non plus un monstre de guerre

peut etre y a til des processus qui sont actif chez moi et qui ne le sont pas chez vous je n en sais rien

Share this post


Link to post
Share on other sites

Bonjour, bonjour,

tout d'abord, je suis vraiment newb de chez newd dans la communauté pingoin, alors désolé si mes questions peuvent paraitre conne.

1- C quoi glxgears? Faut le lancer dans un shell ou en faisant ctrl + Alt +F1?

En shell ça me fais un fenetre avec des engrenage, mais j'ai pas vos chiffres. Hors interface graphique, ça me fais error: couldn't open display (null)

2- J'ai essayer ce tutorial d'install, et après qq erreurs, notamment une a la compilation du pilot et le sh make_install.sh ( erreur de permission sur le fichier fglrx.ko) j'ai config le pilote. mon interafce graphique ne me propose plus que 640*480 comme résolution.

3- TuxRacer marche, mais il marchait déjà avant, ça veut dire que l'accélération3D était déjà installé?

merci

Share this post


Link to post
Share on other sites

Au fait, j'ai remarqué que la fréquence de la ram est très miportante dans le score glxgears (plusieurs centaines de points gagnés en passant de 460MHz à 470MHz)

vincebel :

1) glxgears est une application qui utilise "glx" (opengl, quoi) pour afficher des engrenages (gears) à l'écran, et affiche en même temps le nombre d'images affichées par seconde...

Il faut lancer une console en mode graphique (konsole, gnome-terminal, xterm), et taper "glxgears" dedans... puis laisser environ 15s (voire plus...) et fermer la fenêtre... dans le terminal, les fps sont écris (toutes les 5s pendant que ça tournait)

2) dès qu'il y a une erreur, ça ne marche pas, et il faut être root (et configurer correctement X)

3) glx marche même sans accélération graphique (en software donc)

Share this post


Link to post
Share on other sites

Bon bah je vais essayer de recompiler le pilote, voir ce qu'il raconte de beau, afin de pouvoir vous donnez le code d'erreur exacte.

en tout cas merci pour les réponses

Share this post


Link to post
Share on other sites

Bon bah finalement j'ai plus de message d'erreur

L'erreur intervenait quand je tapais

cd /lib/modules/fglrx/build_mod

sh make.sh

cd..

sh make_install.sh

après le make install j'avais une erreur de permission sur le fichioer fglrx.ko (en étant en root bien sur)

maintenant ça me dit :

- creating symlink

- recreating module dependency list

- trying s sample load of the kernel module

done.

donc je suppose que ya pas d'erreur.....

en revanche après un glxgears j'obtiens:

2851 frames in 5.0 seconds = 570.200 FPS

2248 frames in 5.0 seconds = 449.600 FPS

3483 frames in 5.0 seconds = 696.600 FPS

3484 frames in 5.0 seconds = 696.800 FPS

3484 frames in 5.0 seconds = 696.800 FPS

3483 frames in 5.0 seconds = 696.600 FPS

3484 frames in 5.0 seconds = 696.800 FPS

3484 frames in 5.0 seconds = 696.800 FPS

Donc si je comprends bien l'accélération de mon ATI Radeon 9200SE n'est pas actvée?

Autre question: quelle est la commande pour avoir un affichage partie par partie avec lsmod? tout defile, j'ai pas le temps de voir tout les modules (je suis vraiment newb en linux, et en ligne de commande...).

Share this post


Link to post
Share on other sites
donc je suppose que ya pas d'erreur.....

en revanche après un glxgears j'obtiens:

[...]

3484 frames in 5.0 seconds = 696.800 FPS

Donc si je comprends bien l'accélération de mon ATI Radeon 9200SE n'est pas actvée?

ben à priori, oui...

lance fglrxconfig pour mettre le bon driver pour X...

Autre question: quelle est la commande pour avoir un affichage partie par partie avec lsmod? tout defile, j'ai pas le temps de voir tout les modules (je suis vraiment newb en linux, et en ligne de commande...).

Ouahou.... lsmod trop grand pour un terminal :francais:

Enfin bref... http://www.pcinpact.com/forum/sujet_23814.htm pour de l'aide...

par exemple, ici "lsmod | less"

Share this post


Link to post
Share on other sites

Bah en fait j'ai déjà utiliser fglrx, mais bon j'avoue que pour bcp de choses, j'ai laissé la config par défaut, sauf pour la résolution, la fréquence, la souris. Pour le reste, c 'est un peu du chinois, et en anglais qui plus est :youhou: .

j'ai changer ma commande lsmod, et j'obtiens:

nvidia-agp 7388 0

fglrx 205028 183

via-agp 7360 1

agpgart 31016 3 nvidia-agp,via-agp

j'ai pas un peu trop de truc?

Share this post


Link to post
Share on other sites
Bah en fait j'ai déjà utiliser fglrx, mais bon j'avoue que pour bcp de choses, j'ai laissé la config par défaut, sauf pour la résolution, la fréquence, la souris. Pour le reste, c 'est un peu du chinois, et en anglais qui plus est :francais: .

j'ai changer ma commande lsmod, et j'obtiens:

nvidia-agp 7388 0

fglrx 205028 183

via-agp 7360 1

agpgart 31016 3 nvidia-agp,via-agp

j'ai pas un peu trop de truc?

ben à part avoir "nvidia-agp" et "via-agp", ça va...

regarde dans la section "Device" du XF86Config, normalement il y a "driver", et ça doit être "fglrx" (avec les guillements)

Share this post


Link to post
Share on other sites

1- justement, y'en a pas un en trop entre nvidia-agp et le via-agp?

2- voilà ce que j'ai dans la section Device

# === ATI device section ===

Section "Device"

Identifier "ATI Graphics Adapter"

Driver "fglrx"

# ### generic DRI settings ###

# === disable PnP Monitor ===

#Option "NoDDC"

# === disable/enable XAA/DRI ===

Option "no_accel" "no"

Option "no_dri" "no"

# === misc DRI settings ===

Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr

# ### FireGL DDX driver module specific settings ###

# === Screen Management ===

Option "DesktopSetup" "0x00000000"

Option "MonitorLayout" "AUTO, AUTO"

Option "IgnoreEDID" "off"

Option "HSync2" "unspecified"

Option "VRefresh2" "unspecified"

Option "ScreenOverlap" "0"

# === TV-out Management ===

Option "NoTV" "yes"

Option "TVStandard" "NTSC-M"

Option "TVHSizeAdj" "0"

Option "TVVSizeAdj" "0"

Option "TVHPosAdj" "0"

Option "TVVPosAdj" "0"

Option "TVHStartAdj" "0"

Option "TVColorAdj" "0"

Option "GammaCorrectionI" "0x00000000"

Option "GammaCorrectionII" "0x00000000"

# === OpenGL specific profiles/settings ===

Option "Capabilities" "0x00000000"

# === Video Overlay for the Xv extension ===

Option "VideoOverlay" "on"

# === OpenGL Overlay ===

# Note: When OpenGL Overlay is enabled, Video Overlay

# will be disabled automatically

Option "OpenGLOverlay" "off"

# === Center Mode (Laptops only) ===

Option "CenterMode" "off"

# === Pseudo Color Visuals (8-bit visuals) ===

Option "PseudoColorVisuals" "off"

# === QBS Management ===

Option "Stereo" "off"

Option "StereoSyncEnable" "1"

# === FSAA Management ===

Option "FSAAEnable" "no"

Option "FSAAScale" "1"

Option "FSAADisableGamma" "no"

Option "FSAACustomizeMSPos" "no"

Option "FSAAMSPosX0" "0.000000"

Option "FSAAMSPosY0" "0.000000"

Option "FSAAMSPosX1" "0.000000"

Option "FSAAMSPosY1" "0.000000"

Option "FSAAMSPosX2" "0.000000"

Option "FSAAMSPosY2" "0.000000"

Option "FSAAMSPosX3" "0.000000"

Option "FSAAMSPosY3" "0.000000"

Option "FSAAMSPosX4" "0.000000"

Option "FSAAMSPosY4" "0.000000"

Option "FSAAMSPosX5" "0.000000"

Option "FSAAMSPosY5" "0.000000"

# === Misc Options ===

Option "UseFastTLS" "0"

Option "BlockSignalsOnLock" "on"

Option "UseInternalAGPGART" "no"

Option "ForceGenericCPU" "no"

BusID "PCI:1:0:0" # vendor=1002, device=5964

Screen 0

EndSection

TU vois quelques choses qui cloche?

Share this post


Link to post
Share on other sites

ben oui, ça me semble bizarre, 2 agp...

la config semble bien (on voit que ça a été fait par fglrxconfig :transpi:)

Vérifie que tu as bien <<Load "glx">>

Share this post


Link to post
Share on other sites

bon, tout d'abord je confirme que dans la section modules j'ai bien:

# This loads the GLX module

Load "glx" # libglx.a

Load "dri" # libdri.a

Ensuite j'ai essayer de virer via-agp et donc de garder nvidia-agp par la commane rmmod via-agp. J'ai le message suivant :

ERROR : Module via-agp is in use

En ravanche je peux supprimer nvidia-agp sans problème, c'est du a quoi?

( quand je supprime nvidia-agp je tombe de 600 a 300fps, peut être que l'acceleration 3D était vraiment enclencher.... enfin 600fps ça fait qd même pas bequcoup)

Share this post


Link to post
Share on other sites

Ben sinon ça veut dire que la radeon 9200SE est vraiment, vraimenr pourrie...

Faudrait tester avec un jeu genre Q3 pour voir la diff entre avec et sans drivers...

Share this post


Link to post
Share on other sites

salut vincebel

desole pour le retard mais je n etais pas present en ce moment

apparement tu as des problemes avec les drivers ati

1/ as tu mis le bon kernel source car il pose pose probleme par la commande suivante :

2/Si y'a une erreur qui parle de kernel includes, c'est parce qu'a l'install de Mdk 10, dans mise a jour ils ont mis kernel-source-2.6.3-9 et le kernel est un 2.6.3-7... Donc si c'est installé: revenir au 2.6.3-7: (En root)

CODE

urpme kernel-source

(seulement si une autre version est istallée...) puis

CODE

urpmi kernel-source-2.6.3-7

et ça marche...

(merci a user pour cette aide)

3/urpmi --allaw-force fglrx.xxxx..xxxx..xxxx.rpm

4/fglrxconfig

-pour la souris generalement c est psaux

-external agp mettre yes

-le reste par defaut sera bon

4/initialisation des modules

#modprobe fglrx

#modprobe nvidia-agp (pour chip nvidia)

exit

startx

5/test

ouvrir dans une console

glxgears -- si superireur a 2000 ok

6/ reste a mettre en place l auto chargement des modules

en mode superutils ajouter les lignes dans :

/etc/modprobe.preload

fglrx

nvidia-agp (pour chip nvidia)

et normalement tout est ok

Share this post


Link to post
Share on other sites

pour ton cas peux tu taper en mode console glxinfo et me le montrer

juste les 10 premiere ligne

avec un glxgears

courage

Share this post


Link to post
Share on other sites

merci merci de l'attention que vous me porter.

>>vinced33

1et 2 - oui j'ai les bonne sources d'installer kernel-source2.3.6-7mdk, conforme avec le resultat de uname -a qui renvouie 2.6.3-7mdk

3- J'ai plutot utilisé l'install manuelle qui me renvoyais une erreur lors du sh make_install.sh dans le repertoire /etc/modules/fglrx/

4- c'est que j'ai fait

et un lsmod me donne

nvidia-agp 7388 0

agpgart 31016 1 nvidia-agp

fglrx 205028 0

donc je suppose que les modules sont chargé, non?

5- Resultat de glxgears ( c vraiment si bof la radéon 9200SE ?)

1410 frames in 5.0 seconds = 282.000 FPS

1600 frames in 5.0 seconds = 320.000 FPS

1520 frames in 5.0 seconds = 304.000 FPS

1600 frames in 5.0 seconds = 320.000 FPS

1520 frames in 5.0 seconds = 304.000 FPS

1600 frames in 5.0 seconds = 320.000 FPS

1520 frames in 5.0 seconds = 304.000 FPS

1600 frames in 5.0 seconds = 320.000 FPS

6- Contenu de modprobe.preload?

scsi_hostadapter

fglrx

nvidia-agp

7- Résultat de glxinfo

ame of display: :0.0

display: :0 screen: 0

direct rendering: No

server glx vendor string: SGI

server glx version string: 1.2

server glx extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context

client glx vendor string: ATI

client glx version string: 1.3

client glx extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,

GLX_ATI_render_texture

GLX extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context

OpenGL vendor string: Mesa project: www.mesa3d.org

OpenGL renderer string: Mesa GLX Indirect

OpenGL version string: 1.3 Mesa 4.0.4

OpenGL extensions:

GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,

GL_ARB_texture_cube_map, GL_ARB_texture_env_add,

GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,

GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,

GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,

GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,

GL_EXT_texture_lod_bias

glu version: 1.3

glu extensions:

GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

Share this post


Link to post
Share on other sites
7- Résultat de glxinfo

name of display: :0.0

display: :0 screen: 0

direct rendering: No

=> glx pas chargé...donc il faut l'activer pour utiliser les drivers...

vérifier qu'il y ait :

Load "glx"

dans la section "Module" de /etc/X11/XF86Config-4

Share this post


Link to post
Share on other sites

Il y est....

This loads the GLX module

Load "glx" # libglx.a

Load "dri" # libdri.a

Je commence a plus comprendre qrand chose.

Share this post


Link to post
Share on other sites

Sinon je remarque que les textes sont pas très net à l'écran, sous mozilla et Konqueror. ça peut venir des driver ATI, voir ceux de l'écran (ACER AL1711? je pense que ça vient plutot des polices d'écritures, vous utilisez quoi vous?

Share this post


Link to post
Share on other sites

ok donc a direct rendering tu dois avoir yes dans tout les cas

direct rendering: No

tout ne sait pas bien charger apparement

ca m'est arrivé aussi

il faudrait refaire une tentative

mode console

$su

$mot de passe

#init 3 pour tuer le serveur graphique

decharger les modules

#rmmod fglrx

#rmmod agpgart

#rmmod nvidia-agp

une fois le tout decharge

refaire fglrxconfig

comme je t'ai indique au dessus

tu recharges les modules

#modprobe fglrx

#modprobe nvidia-agp

#exit

#startx pour redemarrer le serveur x (graphique)

ta carte doit voir un nombre quand superieur meme si cela reste une light

Share this post


Link to post
Share on other sites

×
×
  • Create New...