Jump to content

Archived

This topic is now archived and is closed to further replies.

Duke98

Installation de Knop.... Debian

Recommended Posts

bon voila je tente d'installer une knoppix 3.4 sur mon futur serveur (cf signature)

je suis un peu nul en linux mais je me soigne :chinois:

j'ai fais:

su

knx2hd

et il ne veux pas m'installer car il ne vois pas le disque (alors que j'ai tout configuré avec qtparted sans aucun problème)

j'ai sans doute trouvé la solution:

message

Réponse1

Réponse2

mon seul probleme est que je ne comprends pas ce qu'ils font vraiment....

elle ont l'air super les ligne de codes, mais je les met ou ???

si quelqu'un compend, je veux bien une petite explication, merci d'avance

Share this post


Link to post
Share on other sites

Bon en lisant la suite des réponse on trouve d'autres problemes....

mais bon si quelqu'un comprend quoique ce soit je suis prenneur :-D

Share this post


Link to post
Share on other sites

J'ai sans doute trouvé la solution:

oui, +1 :pleure:

mon seul probleme est que je ne comprends pas ce qu'ils font vraiment....

Ils vont modifier le script de knx-hdinstall afin qu'il prenne en compte le tableau raid du serveur, car par defaut il regarde seulement les disques ide.

elle ont l'air super les ligne de codes, mais je les met ou ???

Regarde a l'aide de la commande find ( ou locate si tu l'as installe ) ou se trouve le script en question. ptet qu'il s'appelle vraiment knx-hdinstall ou qu'un repertoire porte ce nom et contient un script. ensuites tu prends ton editeur prefere ( Vim power :-D ) et tu modifie le script comme indique. Ensuite, tu reessaies ton install avec cela.

Long est le chemin qui mene a la force jeune padawan !

Share this post


Link to post
Share on other sites

ca s'éclairci un peu ....

je sais pas trop ou chercher ce scipt mais je vais voir ca

merci pour l'aide

Share this post


Link to post
Share on other sites

knx-hdinstall a été remplacé par knx2hd dans la version 3.4.....

j'ai pu édité ce scipt, mais il ne ressemble pas du tout au précédent...

impossible de trouver le moindre bout de code se rappochant un peu

de nouveau bloqué :incline:

Share this post


Link to post
Share on other sites

bon je suis passé sous DEbian, avec un kernel 2.6

install ok jusquà grub, puis plouff

je recommence depuis le début, je crois bien que ce con m'a tout cassé.... :D

question au passage j'ai 5 cartes réso identiques je fais comment lors de l'install pour savoir laquelle est eth0 eth1 .... ?

cpour brancher mon modem pour la fin de l'install (net-installer)

Share this post


Link to post
Share on other sites
bon je suis passé sous DEbian, avec un kernel 2.6

install ok jusquà grub, puis plouff

je recommence depuis le début, je crois bien que ce con m'a tout cassé.... :D

question au passage j'ai 5 cartes réso identiques je fais comment lors de l'install pour savoir laquelle est eth0 eth1 .... ?

cpour brancher mon modem pour la fin de l'install (net-installer)

normal pour lilo /grub :D

je pense qu'il ne sait pas ou se mettre :incline:

en fait j'ai un peu le même problème, car avec mon raid software, ça ne marche pas non plus comme je voudrais :bravo:

il devrait 'booter' sur le raid , si ça foire sur le disque 1, et si ça foire sur le disque 2...

hors ça foire toujours sur le raid :-D , du coup c'est toujours l'option de sauvegarde.... ( il doit booter sur hda il me semble)

Tout ça pour revenir à ton problème

:-D

il ne peut pas se mettre dans le master boot :D ( enfin a priori non, sinon sur quel disque? :D ) ( en fait chez moi lilo est dans les masterboot de mes 2 disques en théorie)

donc la solution ( je sais pas si c'est encore possible) c'est soit de rentre une partition amorçable ( ce qui ne doit pas marcher chez moi :D ) soit le mieux, ce searait de faire une disquette de boot :D

avec la disquette de boot pas besoin de masterboot, de partition de boot ou autre....

tu boote sur la disquette et zou......

maisd je sais pas si il y a cette option à l'install...

Share this post


Link to post
Share on other sites

Pour les 5 cartes réseau ...

du temps de l'ISA l'ordre était celui des adresses MAC des cartes

en PCI je sais pas, c'st soit ça soit l'ordre des périphériques

en tout cas si tu peux sortir les cartes, les mettre dans l'ordre ... ensuite quand tu fais ifconfig il te donne l'@MAC, y'a pu ka faire la corrélation ...

Share this post


Link to post
Share on other sites

ok, je tente quand meme de metre /dev/ida/c0d0p1

(mon /boot sur le raid....)

a la place de hda pour grub

et si ca marche pas j'opte pour la floppy, pour un serveur c'est pas vraiment génant

si quelqu'un a une solution un peu plus "propre" je suis preneur :craint:

:transpi: Dark

Share this post


Link to post
Share on other sites

faut essayer sur la disquette :mdr:

voila mon linux pour exemple :transpi:

# Specifies the boot device.  This is where Lilo installs its boot

# block.  It can be either a partition, or the raw device, in which

# case it installs in the MBR, and will overwrite the current MBR.

#

#boot=/dev/hda

boot=/dev/md1

raid-extra-boot=/dev/hda,/dev/hdc

donc Lilo devarit s'installé sur la partition /boot qui en raid 0 ( /dev/md1 dans mon cas )

mais bon ç ane marche pas :arrow:

du coup il se rabat sur le raid-extra-boot ....

mais sinon en réfléchissant, le pc au boot il ne que booter si il lit dans le masterboot.

le boot sur une partition ça marche, si on met sur une disquette amorçable non ???

Share this post


Link to post
Share on other sites
Pour les 5 cartes réseau ...

du temps de l'ISA l'ordre était celui des adresses MAC des cartes

en PCI je sais pas, c'st soit ça soit l'ordre des périphériques

en tout cas si tu peux sortir les cartes, les mettre dans l'ordre ... ensuite quand tu fais ifconfig il te donne l'@MAC, y'a pu ka faire la corrélation ...

ca a marché a la perfection :modoreussi::D

bon la nouvelle étape la configuration du réseau......

j'ai encore pas mal de lecture pour tout comprendre :chinois::chinois:

Share this post


Link to post
Share on other sites

bon impossible de mettre grub ou lilo sur le raid.....

mais la sarge me propose pas de faire une disquette de boot....

il me dit juste root=/dev/ida/c0d0p4

je veux bien faire une disquette de boot mais je fait comment pour mettre lilo dessus ?

j'ai pas d'autre linux installé...

Share this post


Link to post
Share on other sites
bon impossible de mettre grub ou lilo sur le raid.....

mais la sarge me propose pas de faire une disquette de boot....

il me dit juste root=/dev/ida/c0d0p4

je veux bien faire une disquette de boot mais je fait comment pour mettre lilo dessus ?

j'ai pas d'autre linux installé...

en fait avec grub ç adevarit être possible.....

http://www.finix.eu.org/spip/article.php3?id_article=69

avec ce sytème, on ne mets pas le noyau sur la disquette, mais juste grub....

mais bon je sais pas si on peut le faire à l'install.. :mad2:

donc avec un lmive cd de knoppix ou autre, il fuadrait faire le fichier de config de grub, lancer grub histoirte d'avoir une diquette opérationnelle et voila :yes:

par contre grub j'y connais rien.....

Share this post


Link to post
Share on other sites

avec lilo ça ne devrait pas être possible ou d moins pas très cool, car il faut quer le kernel soit sur la disquette...

avec grub pas besoin...

Share this post


Link to post
Share on other sites

j'avais le tuto mais j'ai pas pensé a utiliser la knoppix à un seul moment.... :yes:

je m'y jette :mad2:

Share this post


Link to post
Share on other sites

avec lilo ça ne devrait pas être possible ou du moins pas très cool, car il faut quer le kernel soit sur la disquette...

avec grub pas besoin...

en gros il faut faire un fichier de config ou tu mets :

ta partition de boot c'est /dev/tontruc

ta partition root c'est /dev/tontruc

au lieu de copier tous ça dans le mbr, il faut le mettre sur une disquette... :yes:

Installation de grub sur une disquette

Premièrement, formatez la disquette au format ext2fs et créez-y les répertoires boot et boot/grub :

# mke2fs /dev/fd0

# mount -t ext2 /dev/fd0 /floppy

# mkdir /floppy/boot

# mkdir /floppy/boot/grub

Ensuite, on copie sur la disquette les fichiers stage1 et stage2 de grub (les fichiers *stage1_5 ne sont pas indispensables ici).

# cp /usr/lib/grub/i386-pc/stage[12] /floppy/boot/grub [1]

Enfin, on peut passer à l'installation de grub proprement dite.

# umount /floppy

# grub

Probing devices to guess BIOS drives. This may take a long time.

  GRUB  version 0.91  (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported.  For the first word, TAB

  lists possible command completions.  Anywhere else TAB lists the possible

  completions of a device/filename. ]

grub> root (fd0)

Filesystem type is ext2fs, using whole disk

grub> setup (fd0)

Checking if "/boot/grub/stage1" exists... yes

Checking if "/boot/grub/stage2" exists... yes

Checking if "/boot/grub/e2fs_stage1_5" exists... no

Running "install /boot/grub/stage1 d (fd0) /boot/grub/stage2 p /boot/grub/menu.lst "... succeeded

Done.

grub> quit

Voilà, grub est installé sur la disquette, il n'y a plus qu'à le configurer.

ensuite il faut editer le fichier de config /floppy/boot/grub/menu.lst.

donc le fichier de config qui a cette tête peut être ( je pense )

timeout 2

default 0

title Linux 2.6.0-test10 (disquette)

root (hd0,0)

kernel /vmlinuz root=/dev/ida/c0d0p1

avec ça ça devrait marcher

hd0,0 correspond à ta partition /boot ( a toi de mettre ce qu'il faut mais ça devrait être ça )

sous debian le kernel s'appelle vmlinuz et se trouve la

root= c'est t apartion racine...

je sais pas si c'est clair....

donc tout cela doit être possible de le faire avec un knoppix en live cd

Share this post


Link to post
Share on other sites

ouaip pour l'instant ca roule, je suis en tran de mettre grub sur la floppy

pour l'instant j'ai l'impression d'avoir tout compris :-D

:fumer: Dark pour toutes ces explications

Share this post


Link to post
Share on other sites

la seule chose que j'ai fait c'est ça

timeout 2

default 0

title Linux 2.6.0-test10 (disquette)

root (hd0,0)

kernel /vmlinuz root=/dev/ida/c0d0p1

ensuite je ne sais pas ( j'ai pas cherche à comprendre non plus il faut dire :-D ) comment grub comprend le (hd0,0)

tu as partitinnor comment ???

hd0,0 doit correspondre à la permière partion detecté :fumer:

en fait c'est ça, hd0 correspond au premier dur, et le 0 ensuite à la première partition...

ensuite truvé ça ici

http://www.gnu.org/software/grub/grub-faq.en.html#q6

9. How can I specify an arbitrary memory size to Linux?

Pass a mem= option to your Linux kernel, like this:

grub> kernel /vmlinuz mem=128M

You may pass other options in the same way. See the documentation for Linux, for available options.

si tu en as besoin pour ton système bizarre :transpi:

Share this post


Link to post
Share on other sites

oki compris pour moi ca doit donc etre hd0,2

(en 0 j'ai la partition dos pour la config systeme et en 1 j'ai le swap)

pour la memoire, tu a raison, je viens d'avoir mon kernel panic habituel

par contre je penche plus sur le memmap304M@16M

je vais voir ce que ca donne

Share this post


Link to post
Share on other sites

à toi de modifier bien sûr :fumer:

donc ça a quand même reussi à booter sur la disquette ????? :-D

Share this post


Link to post
Share on other sites

la disquette marche bien.... mais mon menu est pas encore au point

en fait c'est sans doute bien hd0,0

en hd0,0 il me dit impossible de monter partition de type 0x83 (pourtant ca doit etre mon ext3 ca)

en hd0,2 il me dit impossible de monter partition de type 0x12 ma partition dos system)

le hd0,1 ca doit etre le swap...

enfait ca devrait etre hd0,1 d'après l'install de la debian....

tiens d'ailleurs je peux bouter sur la partition compaq à partir de grub

menu.lst

------------------------

timeout 2

default 0

title Linux 2.6 (disque dur)

root (hd0,1)

kernel /boot/vmlinuz root=/dev/ida/c0d0p2

title Linux 2.6 (disquette)

root (fd0)

kernel /boot/vmlinuz root=/dev/ida/c0d0p2

title Utilitaire Compaq

hide (hd0,0)

hide (hd0,1)

unhide (hd0,2)

rootnoverify (hd0,2)

chainloader +1

makeactive

----------------------------

je crois qu'il y a un petit probleme de syntaxe quelque part.... :chinois:

bon et ben il ne me monte pas le disque ..... pfffff

Share this post


Link to post
Share on other sites
la disquette marche bien.... mais mon menu est pas encore au point

en fait c'est sans doute bien hd0,0

en hd0,0 il me dit impossible de monter partition de type 0x83 (pourtant ca doit etre mon ext3 ca)

en hd0,2 il me dit impossible de monter partition de type 0x12 ma partition dos system)

le hd0,1 ca doit etre le swap...

enfait ca devrait etre hd0,1 d'après l'install de la debian....

tiens d'ailleurs je peux bouter sur la partition compaq à partir de grub

menu.lst

------------------------

timeout 2

default 0

title Linux 2.6 (disque dur)

root (hd0,1)

kernel /boot/vmlinuz root=/dev/ida/c0d0p2

title Linux 2.6 (disquette)

root (fd0)

kernel /boot/vmlinuz root=/dev/ida/c0d0p2

title Utilitaire Compaq

hide (hd0,0)

hide (hd0,1)

unhide (hd0,2)

rootnoverify (hd0,2)

chainloader +1

makeactive

----------------------------

je crois qu'il y a un petit probleme de syntaxe quelque part.... :-D

bon et ben il ne me monte pas le disque ..... pfffff

j'ai trouvé l'erreur :transpi: ( enfin peut être :D )

kernel /boot/vmlinuz

c'est pas ça :-D ( c'est pas ce que j'avais marqué :incline: )

c'est kernel /vmlinuz

voila sur ma debian ce qu'il y a à la racine

ls -la /

total 129

drwxr-xr-x  26 root    root        4096 mai 19 17:50 .

drwxr-xr-x  26 root    root        4096 mai 19 17:50 ..

drwxrwxrwx    4 alexandr alexandr    4096 avr 26 20:17 1giga

drwxrwxrwx    8 alexandr alexandr    4096 jun  7 21:06 20giga

drwxrwxrwx  11 alexandr alexandr    4096 jun 11 10:04 70giga

drwxrwxrwx    5 alexandr alexandr    4096 fév  6 16:57 80giga

drwxr-xr-x    2 root    root        4096 jun  2 23:02 bin

drwxr-xr-x    2 root    root        1024 mai 27 12:34 boot

drwxr-xr-x    2 root    root        4096 jan 17 14:07 cdrom

drwxr-xr-x  12 root    root        24576 mai 31 20:24 dev

drwxr-xr-x  72 root    root        4096 jun  9 11:50 etc

drwxr-xr-x    2 root    root        4096 jan 17 14:07 floppy

drwxrwsr-x    4 root    staff        4096 mai  7 19:12 home

drwxr-xr-x    2 root    root        4096 jan 17 14:07 initrd

drwxr-xr-x    6 root    root        4096 mai 31 20:24 lib

drwx------    2 root    root        16384 jan 17 14:04 lost+found

drwxr-xr-x    4 root    root        4096 mai 19 15:48 mnt

drwxr-xr-x    4 root    root        4096 avr  6 14:12 opt

dr-xr-xr-x  126 root    root            0 mai 21 18:51 proc

drwxr-xr-x    5 root    root        4096 jun 11 10:01 root

drwxr-xr-x    2 root    root        4096 jun  2 23:02 sbin

drwxr-xr-x    2 root    root        4096 avr 21 20:58 sys

drwxr-xr-x    2 root    root        4096 avr  6 14:12 tftpboot

drwxrwxrwt    4 root    root        4096 jun 12 18:50 tmp

drwxr-xr-x  13 root    root        4096 avr  6 14:10 usr

drwxr-xr-x  16 root    root        4096 avr  6 14:12 var

lrwxr-xr-x    1 root    root          18 mai 19 17:50 vmlinuz -> boot/vmlinuz-2.6.6

lrwxrwxrwx    1 root    root          18 avr  6 14:09 vmlinuz.old -> boot/vmlinuz-2.6.5

donc pour le kernel soit tu mets

/vmlinuz

et donc via le lien symbolique il va cherché la bonne version du kernel dans /boot

ou

/boot/vmlinuz-version ( ou version = ta version de kernel )

la meilleure solution c'est

kernel /vmlinuz

car quand tu changes de kernel, tu n'as pas besoin de refaire une disquette ( c'est toujours /vmlinuz) il y a juste le lien symbolique à changer, et le lien symbolique est changé automatique lors de l'install d'u nouveau kernel, donc rien à faire :chinois: )

j'espère que c'est ça ....:-D

tiens moi au courant

Share this post


Link to post
Share on other sites

bon sous la knoppix je fait un

mount /dev/ida/c0d0p2 /mnt

je vois le disque tout est ok

quand je boot avec grub, il me dit qu'il reconnait pas la partition....

question est-ce qu'avec grub je demarre bien en 2.6.6 ????

Share this post


Link to post
Share on other sites

il y a aussi un alias vmlinuz dans le /boot

donc /vmlinuz ou /boot/vmlinuz pour moi ca change rien....

mais il pointe vers le 2.4.26

il fait changer ca non ?

Share this post


Link to post
Share on other sites

Par contre, faites gaffe; quand on installe grub à un endroit, cet endroit devient audomatiquement hd0 (sauf pour les disquettes ...)

Aussi, vous pouvez faire "e" au démarrage pour modifier les commandes de démarrage ....

Share this post


Link to post
Share on other sites

×
×
  • Create New...