Jump to content

[Résolu] Pc Portable n'utilise pas la carte graphique dédiée sur certains vieux jeux


bred94
 Share

Recommended Posts

Bonjour à tous, 🙂

Je rencontre un souci sur un pc portable ACER Aspire VX 15 (VX5-591G-54MY) équipé d'un core i5-7300HQ + GTX 1050Ti 4Go : sur certains vieux jeux (GOG en l’occurrence mais je ne pense pas que cela a une importance) genre Unreal Tournament 2004 ou Serious Sam (les 2 premiers sur pc), la carte graphique n'est pas du tout sollicitée, c'est l'igpu qui bosse et l’expérience n'est pas du tout fluide, il y a souvent des lag d'une demi-seconde bref c'est difficilement jouable en l'état.

Il me semble que j'avais déjà parlé de ce problème sur le forum mais je n'ai pas retrouvé à quel endroit puis la solution dont on m'avait parlé, à savoir aller dans les paramètres graphiques de Windows 10 pour régler tel GPU sur tel programme ne fonctionne pas, pas plus que les réglages proposés dans le panneau de configuration Nvidia...

Je joins des captures d'écran pour imager le problème rencontré : igpu sollicité, GTX1050Ti à zéro de charge

Je les ai capturées en jouant un peu puis en faisant un retour sur windows pour voir le gestionnaire des tâches (onglet performance)

A noter que sur des jeux plus récents styte GRID ou Age of Wonders 3 la carte graphique est bien sollicitée, ces jeux là répondent bien.

Savez-vous comment solutionner ce souci ou avez -vous une idée des causes de la sollicitation on/off de la carte dédiée en fonction des jeux?

En vous remerciant 🙏

Image : réglages Nvidia

Réglages Nvidia pour UT 2004.png

Image : réglages windows

Réglages paramètres graphiques windows 10 pour UT2004.png

image : utilisation carte graphique dédiée à zéro pendant une partie de UT2004

Unreal Tournament 2004 - utilisation GTX 1050Ti à zéro.png

 

 

 

Edited by bred94
Link to comment
Share on other sites

  • bred94 changed the title to Pc Portable n'utilise pas la carte graphique dédiée sur certains vieux jeux

Passes-tu par un launcher? Il faudrait peut-être signaler à windows que le launcher doit passer par l'IGPU.

Par ailleurs c'est bizarre que UT2004/Serious Sam ne passe pas bien sur un iGPU , même à l'époque ils étaient plutôt jouables sur les iGPU de l'époque, et les iGPU de maintenant sont tout à fait capables de tenir ces jeux (les iGPU Intel HD530/HD630 font passer Grid 3 en 50-60 FPS sur des résolutions proches du FHD) (oui, je joue souvent sur iGPU).

 

Sinon, si tu vas dans ton panneau NVidia, menu "bureau", tu trouveras une option pour activer "lancer avec l'accélérateur graphique".

Cela ajoutera une option "Lancer avec l'accélérateur graphique" au menu du click-droit.

Dernière chose: il est possible que ces vieux jeux aient un launcher intégré (genre un menu qui s'affiche avant de lancer le jeu). Il faudra certainement aller dans l répertoire du jeu, identifier les fichiers exe autres (parfois il y avait un exe pour l'opengl et un pour direct3D) et modifier leurs paramètres Windows pour qu eux aussi soient lancés avec la CG.

Edited by brice.wernet
  • Aime 1
Link to comment
Share on other sites

Bonjour Brice 🙂

Merci pour cette aide, elle m'a amené à faire d'autres réglages sur le type de pilote utilisé par ces deux jeux qui ne voulaient pas utiliser la GTX1050Ti. :yes:

 

Il y a 4 heures, brice.wernet a écrit :

Passes-tu par un launcher? Il faudrait peut-être signaler à windows que le launcher doit passer par l'IGPU.

Oui, je passe par le lanceur GOG galaxy en général.

Je suppose que tu voulais dire d'attribuer au launcher la carte graphique dédiée (et non l'IGPU), c'est que j'ai fais dans le doute.

Je ne sais pas si cela a aidé, j'ai fais plusieurs manipulations d'affilé donc je ne suis plus sûr mais de mémoire cela n'a pas trop fonctionné, cependant je suis également passé sur le pilote OpenGL dans les options de Serious Sam (second encounter), le mode D3D ne permet pas de sélectionner autre chose que l'IGPU dans les options et avec le rendu OPenGL, il y a bien écrit que la Geforce est utilisée, et dans UT2004 (via le fichier UT2004.ini on peut choisir différents pilotes, j'ai choisi l'OpenGL également) ce qui m'a permis d'augmenter pas mal les FPS et de retrouver une fluidité très agréable.

Quand je regarde le gestionnaire des tâches au cours d'une partie de ces jeux, la GTX 1050Ti est enfin sollicitée (pas beaucoup environ 70% d'occupation de l'IGPU et 20-30% pour la carte graphique).

Voici globalement les infos sur les FPS :

- Serious Sam SE : passe de environ 90FPS max de mémoire //--> edit : plus sûr ici si j'avais lancé FRAPS.. // (sans sensation de fluidité) à environ 150-180FPS et une bonne fluidité.

- UT2004 : je passe de 40-70FPS sans fluidité à 80-120FPS ici aussi je retrouve de bonnes conditions de jeu, enfin !

Personnellement les IGPU Intel de cette gen. me paraissent quand même insuffisants pour jouer en FullHD qualité max à ces jeux.. (à noter que j'ai dû modifier certains paramètres dans les fichiers de config' de ces 2 jeux afin de débloquer la résolution FullHD qui n'est pas accessible par défaut).

 

Il y a 4 heures, brice.wernet a écrit :

Sinon, si tu vas dans ton panneau NVidia, menu "bureau", tu trouveras une option pour activer "lancer avec l'accélérateur graphique".

Je n'ai pas trouvé cette option dans les paramètres graphiques Nvidia du pc portable (voir image), j'ai l'impression qu'il n'y a pas beaucoup d'options.

 

Cela a l'air de rouler avec le choix du pilote OpenGL, je peux enfin jouer un peu à ces jeux dans de bonnes conditions lorsque je fais une partie avec mon frère^^

Paramètres Nvidia PC Portable.jpg

Edited by bred94
Link to comment
Share on other sites

Il y a 2 heures, bred94 a écrit :

Je n'ai pas trouvé cette option dans les paramètres graphiques Nvidia du pc portable (voir image), j'ai l'impression qu'il n'y a pas beaucoup d'options.

OK, je n'ai pas de carte NVidia, donc j'avais traduit depuis un message en Anglais toruvé sur un forum. Chez toi, c'est coché, c'est "Ajouter des menus contextuels".

Je pense que tu as donc via le click-droit sur un exe un menu avec un choix entre le iGPU et le dGPU.

Link to comment
Share on other sites

Il y a 11 minutes, brice.wernet a écrit :

Je pense que tu as donc via le click-droit sur un exe un menu avec un choix entre le iGPU et le dGPU.

Je viens de regarder le menu contextuel de l'exe de quelques jeux dans l'explorateur de fichiers, je n'ai rien pour sélectionner tel ou tel GPU.

Edited by bred94
Link to comment
Share on other sites

Je clos le sujet, d'après ce que j'observe du problème rencontré, le rendu en D3D ne permet pas l'utilisation de la carte graphique dédiée quelque soit le réglage Windows ou Nvidia sur ces  jeux, du moins sur ce pc portable (ainsi qu'un autre pc portable basée sur la même config' -7300 HQ+GTX 1050 Ti- que j'ai revendu), le mode OpenGL le permet de manière modérée (IGP 70% - GPU 30% en moyenne).. Je ne capte pas trop et je n'ai pas rejoué beaucoup, mais bon ça tourne déjà mieux ainsi 🙂

 

Link to comment
Share on other sites

  • bred94 changed the title to [CLOS] Pc Portable n'utilise pas la carte graphique dédiée sur certains vieux jeux

j'ai pas regardé tout le thread mais je ne pense pas que ça ai avoir quoi que ce soit avec les panneaux de config ou autre c'est un problème vieux depuis très longtemps.

Il n'existe pas une solution universelle mais plusieurs personnes ont dis avoir une solution

1/ désactiver le secure boot car semble poser problème avec justement les vieux jeux (raison inconnu mais à marché pour certain)

2/ désactiver le pilote intel dans le gestionnaire de périphérique comme ça l'UE voit que la carte nvidia et l'utilise bien (un peu chiant au quotidien mais bon semble marcher)

3/ sur les pc portables la sortie vidéo de la carte nvidia passe toujours par le gpu intégré donc en fait c'est comme si c'était un co processeur graphique qu'une vrai carte et donc l'UE ne la considère pas valide, il faut créer une sortie vidéo "virtuelle" sur la carte nvidia pour qu'elle soit reconnu pas l'UE.

voir ici pour créer la sortie virtuelle https://helping-squad.com/fake-connect-a-monitor/

C'est propre à l'UE (unreal engine) donc tous les jeux utilisant ce moteur ont ce soucis donc il existe une bonne quantité de thread sur ce soucis et peu trouve effectivement une solution mais j'ai recensé pour toi celle que j'ai trouvé où des gens ont confirmé le fonctionnement sur portable.

  • Aime 2
Link to comment
Share on other sites

  • bred94 changed the title to [Résolu] Pc Portable n'utilise pas la carte graphique dédiée sur certains vieux jeux
  • 2 months later...

Bonjour,

Ayant souhaité relancer UT2004 sur le pc portable en question, j'ai pu faire quelques tests rapides et je relaie mes observations.

1. La désactivation du secure boot ne semble pas aider sur le débit d'image, il est identique et se situe entre 45 et 65 FPS en mode D3D FullHD (GPU utilisé à 0%) et autour de 90FPS pendant la partie avec la sélection manuelle du pilote OpenGL dans le fichier "UT2004.ini" (GPU utilisé à ~20%). Par contre j'avais régulièrement des petits freezes d'une 1/2 seconde et là je n'en ai plus observé. 😀

2. La désactivation de la puce graphique intel HD 630 dans le gestionnaire de périphérique aggrave la situation, le pc affiche 10FPS dans les menus. (je n'ai pas redémarré le pc pour ce test après la désactivation de l'IGPU)

3. Je n'ai pas essayé la création d'une sortie vidéo virtuelle.

++

Edited by bred94
Link to comment
Share on other sites

  • 2 weeks later...

merci pour tes retours

pour 1/ de toute façon je ne voyais pas trop la raison ni de lien de cause à effet peut être juste un effet de bord

2/ dommage mais d'un autre coté comme je l'ai dis sur les portable la carte graphique dédiée est souvent câblée/utilisé en co processeur de l'igp donc semble aussi normal que ça aggrave la situation

3/ semble être le plus prometteur n'hésite pas a refaire un retour quand tu l'essaie

  • Aime 1
Link to comment
Share on other sites

C'est noté merci à toi pour les précisions :yes:, je ne manquerais pas de faire un retour sur ce point si d'occasion je me re-penche sur le souci :chinois: Dorénavant j'utiliserais sûrement un autre pc portable quand je suis en déplacement (un Dell G5 5505 avec une RX5600M) sur lequel le jeu s'exécute mieux donc je serais moins confronté à ce désagrément^^.

Un autre jeu GOG, le titre "Silverfall", avait présenté le même problème de faible performance graphique sur le pc portable d'un ami avec CG dédiée (GTX1060 3Go mobile). Sur ce jeu, la sélection du processeur graphique dédié dans les "paramètres graphiques" (dans paramètres/système/affichage) avait solutionné le souci de performance graphique^^

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...