Jump to content
matt30-bis

[RESOLU] Freeze de Mint 19.3

Recommended Posts

Posted (edited)

Bonjour, j’ai en ma possession un ordinateur portable MSI de 2010 (Intel I3−330M, ATI Radeon HD5470, 2x2GB de DDR3) qui tourne sous Windows 7. Je souhaitais y installer Linux Mint 19.3 XFCE à la place.

J’ai donc créé une clef usb bootable avec laquelle j’ai démarré la machine. Mais je n’ai pas le temps de lancer l’installation puisque le PC freeze aussi tôt la session ouverte. Rien ne répond, ni la souris, ni le clavier. La seule chose que je puisse faire est d’étendre l’ordinateur.

J’ai, il y a plusieurs mois, déjà essayé d’installer d’autres versions de Linux : Ubuntu 18.04, Fédora, Kubuntu et j’en oublie certainement.

Sauriez−vous me dire pourquoi ça freeze ? Est−ce une incompatibilité matériel ? Est−ce autre chose ?

Edited by matt30-bis

Share this post


Link to post
Share on other sites

Bonjour, une piste classique : un problème de carte graphique.
Sur une tour, on peut la retirer physiquement et la réinstaller après, sur un portable, plus difficile.
Il y a moyen de modifier le mode de démarrage du liveUSB : voir nomodeset, par exemple.

  • Like 1

Share this post


Link to post
Share on other sites

PS. Je viens de voir que la distribution Pop!_OS (que je ne connais pas du tout, mais elle est basée sur Ubuntu LTS), propose dès l'installation des pilotes graphiques INTEL/AMD ou NVIDIA.

 


 

Share this post


Link to post
Share on other sites
Posted (edited)

=+1 pour le nomodeset, c'est une piste.

 

Il y aurait pas un secure boot sur ton bouzin, quoique ce doit être un bios, j'ai une fonction sur mon eeepc pour installer un OS (OS installation) qu'il faut mettre sur start, sinon ça crash.

Les bios de portable sont parfois très exotiques.

 

Arf pas tout lu, my bad.

Tu dis que ça crash à peine la session lancée, donc tu as installé qqch ou c'est la session live ?

Si tu as installé et que tu arrives à l'écran de connection de session puis crash après avoir entré user et mdp pour la session utilisateur, c'est peut être le grand classique des firmwares non libres à installer.

Dur les vendredi fériés.

Ça plante au lancement de l'installation, mais ça arrive sur la liste de choix et plante quand tu lances l'installation ou ça n'arrive même pas là.

 

Edited by Chromosome3

Share this post


Link to post
Share on other sites

@serpolet La carte graphique est mal en point. Je m’explique : j’ai fait une réinstallation de Windows 7, les drivers sont donc ceux par défaut et lorsque j’essaie de mettre celui de la CG à jour je me retrouve avec un magnifique BSOD puis la machine redémarre re-BSOD. Je lance l’ordinateur en mode sans échec, désinstalle le driver récemment installé et là tout roule.

@Chromosome3C’est la session live qui crash, j’ai aucun soucis pour démarrer à partir d’une clef USB et ouvrir une session. C’est quelque minutes après l’ouverture que ça freeze.

Share this post


Link to post
Share on other sites
Posted (edited)

Ta carte n'est plus supportée que par les catalyst 15.9 sur linux et 15.7.1/crimson 16.2.1 sur Windows 10.

Tu risques de pas pouvoir installer les drivers officiels, à moins qu'ils aient réglé les soucis avec le noyau mais j'en doute, j'avais été embêté avec ma vieille 4650 à l'époque. Mais les drivers libres devraient faire le taf. Je parle de linux là hein.

Si tu crash à l'ouverture de session live, le nomodeset peut régler le problème pour le live, mais c'est assez typique des firmware non libres à installer et des drivers par défaut mals supportés par la machine. J'avais fait un tuto la dessus pour debian pour les firmware, de toute façon il faut les installer^^.

 

Pour info, en cas de crash, ne pas oublier l'option magic key.

 

Faut que je recherche mon tuto

 

Edit : tuto là. C'est pour debian, donc à adapter, il faut installer ta distribution avant (la version netinstall c'est le bien amha, si elle existe, si tu as une bonne co).

Edited by Chromosome3

Share this post


Link to post
Share on other sites

Je pense avoir résolu le problème. J’ai lancé ma live session en "nomodeset" de là j’ai pu installer Mint sans soucis. J’ai par la suite mis à jour le système. Et pour finir j’ai modifié le fichier "grub" afin que la machine démarre toujours en "nomodeset".

Voir ce guide.

Merci à vous pour votre aide.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...