Jump to content
brice.wernet

[Résolu] Lancement d'un service au démarrage

Recommended Posts

Bonjour,

Voilà mon petit soucis.

J'ai installé une deb 10 sur mon NUC, puis MPD pour la lecture audio. Tout fonctionne.

J'ai créé un fichier rc_keymap grâce aux codes captés par ir-keytable. Au démarrage, le keymap est chargé et quand j'apuie sur les touches de la téléommande de mon ampli, je reçois bien les évènvement de touches.

J'ai trouvé empcd, je l'ai recompilé et installé pour réagir à ces évènements et piloter MPD.

Ca marche en ligne de commande: je peux passer à la piste suivante, arrêter et redémarrer la lecture...

Mais impossible de configurer empcd pour  le lancer au démarrage (marre de systemd)... A priori, empcd essaie d'appliquer un autre utilisateur (mpd), ce qu'il arrive à faire en ligne de commande sudo, mais semble échouer quand c'est systemd qui exécute le script...

 

Une idée?

Edited by brice.wernet
Résolu
Link to post
Share on other sites

tu peux dire au script systemd d'utiliser un utilisateur précis plutôt que root.

[Service]
User=mpd

les scripts se trouvent généralement dans /usr/lib/systemd/system/ mais tu peux avoir le chemin exact en faisant un systemctl status mpd. en plus ça te donnera les logs ce qui peut éventuellement t'aider à la résolution du problème.

Link to post
Share on other sites

OK, j'ai trouvé: dans le fichier .service, le service était en "simple" alors qu'il est de type "forking".

Du coup, systemd ne gérait pas correctement le service et le killait automatiquement.

  • Thanks 1
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...