Jump to content

Archived

This topic is now archived and is closed to further replies.

Francois_D

Pb de terminal...

Recommended Posts

Hello les amis,
je ne viens pas souvent du côté de Linux mais là j'ai un pb avec Debian...
J'ai installé Debian Wheezy sur mon EeePC. C'est une install très standard.
Quand j'utilise Gnome, tout va bien : le terminal se lance et j'ai un prompt
Petit PB : quand je change d'environnement (j'ai installé xfce ou e17), le terminal se lance mais sans le prompt...
Une idée pour m'aider ?
Mici ;-)
F

Share this post


Link to post
Share on other sites

Tu as juste "$" ou rien du tout ? Tu peux tout de même taper des commandes ?

Regarde dans le /etc/passwd (c'est un tableau qui utilise ":" comme séparateur de colonne) :

Sur la dernière colonne il doit y avoir un shell par exemple /bin/bash , cela peut aussi être /bin/sh ou /bin/dash.

Si tu as /bin/false, /sbin/nologin ou rien il y a un problème.

Ta ligne devrait être du style :

login:x:1000:1000:éventuellement_ton_nom:/home/login:/bin/bash

Remarques :

- La deuxième colonne est le mot de passe, comme il est dans /etc/shadow (plus sécurisé) il y a un "x" marqué.

- Colonnes 3 et 4 c'est tes UID et GID cela peut varier selon ta config, ne pas les toucher.

- /home/login c'est ton répertoire personnel

- Il y a aussi des utilisateurs système, ne les modifies pas.

Share this post


Link to post
Share on other sites

Ce que je soupçonne c'est que tu n'utilises pas le même bash (bash, sh, zsh, ....) parce que le prompt est configuré dans les fichiers de configuration .sh ou autres à la racine de ton home.

Regardes sur Internet pour changer le prompt et mets cette configuration dans le bon fichier :windu:

Édit: Il me semble que les fichiers de configuration se terminent par rc

Share this post


Link to post
Share on other sites

@Raph : je ne vois rien du tout : une fenetre vide !

@foetus : je vais regarder ça.

Merci à tous les deux, je vais gamberger ça. Ce que je pense c'est que, comme toujours avec Linux, je vais trop vite (Mac addict que je suis ;-))

ceci dit, c'est pas trop grave : j'ai réussi (sous Gnome Classic, pas top mais bon) à faire les manips que je voulais (installer Cardpeek).

Bonne soirée

F

Share this post


Link to post
Share on other sites

Bon les amis j'ai trouvé un palliatif :

quand j'utilise un terminal je n'ai rin MAIS quand j'utilise le terminal du systeme (xterm), quelque soit l'environnement, ça marche !

et donc voilà ! pour ce que je fais de mon Debian, ça ira bien ;)

F

Share this post


Link to post
Share on other sites

×
×
  • Create New...