Jump to content

Repository EPEL au travers d'un proxy Squid


Recommended Posts

Bonjour,

J'ai installé une machine virtuelle avec centos 6.2, elle n'a pas accès directement à internet et passe par une autre machine elle aussi en centos 6.2 avec un proxy squid 3.1.10

La configuration du squid est très basique, je n'ai presque rien changé, la voici :

acl manager proto cache_objectacl localhost src 127.0.0.1/32 ::1acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1acl localnet src 10.0.0.0/8     # RFC1918 possible internal networkacl localnet src 172.16.0.0/12  # RFC1918 possible internal networkacl localnet src 192.168.0.0/16 # RFC1918 possible internal networkacl localnet src fc00::/7       # RFC 4193 local private network rangeacl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machinesacl SSL_ports port 443acl Safe_ports port 80          # httpacl Safe_ports port 21          # ftpacl Safe_ports port 443         # httpsacl Safe_ports port 70          # gopheracl Safe_ports port 210         # waisacl Safe_ports port 1025-65535  # unregistered portsacl Safe_ports port 280         # http-mgmtacl Safe_ports port 488         # gss-httpacl Safe_ports port 591         # filemakeracl Safe_ports port 777         # multiling httpacl CONNECT method CONNECThttp_access allow manager localhosthttp_access deny managerhttp_access deny !Safe_portshttp_access deny CONNECT !SSL_portshttp_access allow localnethttp_access allow localhosthttp_access deny allhttp_port 3128hierarchy_stoplist cgi-bin ?coredump_dir /var/spool/squidvisible_hostname squidrefresh_pattern ^ftp:           1440    20%     10080refresh_pattern ^gopher:        1440    0%      1440refresh_pattern -i (/cgi-bin/|\?) 0     0%      0refresh_pattern .               0       20%     4320

J'ai ajouté l'information sur le proxy dans yum.conf. Ca fonctionne bien pour les repo de base, mais dès que j'ajoute les repo EPEL, yum ne fonctionne plus, cela affiche une erreur :

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

Dans la log squid access.log j'ai la ligne suivante qui s'affiche :

1328819727.679 42204 192.168.10.2 TCP_MISS/200 0 CONNECT mirrors.fedoraproject.org:443 - DIRECT/80.239.156.215 -

Sur mon PC qui lui a accès directement à internet, je n'ai aucun soucis avec le repo EPEL.

Je pense que j'ai un problème au niveau du https, vu que les autres repo ne l'utilisent pas et qu'ils fonctionnent.

J'ai cherché des infos sur l'erreur renvoyé par yum, mais sans succès.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...