Jump to content

[Résolu]Activation de laccél. graphique impossible


Recommended Posts

Voilà, je n'arrive pas à activer DRI avec ma Debian 64 bits alors que cela a toujours fonctionné à merveilles avec les distributions 32 bits.

Le module fglrx semble pourtant se lancer correctement.

J'ai essayé l'installation par le paquetage .run et par .deb.

Voici mon xorg.conf :

Section "ServerLayout"

Identifier "aticonfig Layout"

Screen 0 "aticonfig-Screen[0]-0" 0 0

InputDevice "Touchpad"

EndSection

Section "Files"

EndSection

Section "Module"

Load "bitmap"

Load "dbe"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "record"

Load "type1"

Load "vbe"

Load "synaptics"

Load "GLCore"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "be"

EndSection

Section "InputDevice"

Identifier "Touchpad"

Driver "synaptics"

Option "CorePointer"

Option "Protocol" "auto-dev"

Option "Device" "/dev/psaux"

Option "VertScrollDelta" "100"

Option "AccelFactor" "0.0030"

Option "RightEdge" "5400"

Option "MaxTapTime" "180"

Option "TopEdge" "1900"

Option "SHMConfig" "on"

Option "FingerLow" "25"

Option "LeftEdge" "1900"

Option "MaxTapMove" "220"

Option "MinSpeed" "0.02"

Option "FingerHigh" "30"

Option "MaxSpeed" "0.18"

Option "BottomEdge" "4000"

Option "SendCoreEvents" "true"

EndSection

Section "Monitor"

Identifier "aticonfig-Monitor[0]-0"

Option "VendorName" "ATI Proprietary Driver"

Option "ModelName" "Generic Autodetecting Monitor"

Option "DPMS" "true"

EndSection

Section "Device"

Identifier "aticonfig-Device[0]-0"

Driver "fglrx"

BusID "PCI:1:0:0"

EndSection

Section "Screen"

Identifier "aticonfig-Screen[0]-0"

Device "aticonfig-Device[0]-0"

Monitor "aticonfig-Monitor[0]-0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

EndSubSection

EndSection

Section "DRI"

Mode 0666

EndSection

Et le log de xorg :

mustang@debian:~$ cat /var/log/Xorg.0.log |grep WW

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

(WW) Warning, couldn't open module type1

(WW) Warning, couldn't open module glcore

(WW) fglrx(0): Failed to open DRM connection

(WW) fglrx(0): board is an unknown third party board, chipset is supported

(WW) fglrx(0): Only one display is connnected,so single mode is enabled

(WW) fglrx(0): No DRM connection for driver fglrx.

(WW) fglrx(0): ***********************************************

(WW) fglrx(0): * DRI initialization failed! *

(WW) fglrx(0): * (maybe driver kernel module missing or bad) *

(WW) fglrx(0): * 2D acceleraton available (MMIO) *

(WW) fglrx(0): * no 3D acceleration available *

(WW) fglrx(0): ********************************************* *

(WW) fglrx(0): Textured Video not supported without DRI enabled.

(WW) fglrx(0): Option "VendorName" is not used

(WW) fglrx(0): Option "ModelName" is not used

(WW) <default pointer>: No Device specified, looking for one...

Je ne comprend pas, quelqu'un aurait une idée du problème?

Link to comment
Share on other sites

J'ai vérifié les logs de l'installateur au cas où et :

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
Assuming default VMAP API
Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.26-1-amd64/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
 CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_GetInitKerPte’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2744: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2744: error: (Each undeclared identifier is reported only once
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2744: error: for each function it appears in.)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_GetPte’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2782: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_GetPageTableByVirtAddr’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2845: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_TestAndClearPageDirtyFlag’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2972: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_GetDmaPhysAddr’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3016: error: ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4177: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4177: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4195: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4195: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4202: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4202: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4209: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4209: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4216: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4216: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4223: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4223: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4230: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4230: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4239: error: unknown field ‘nopage’ specified in initializer
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4239: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6768: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6794: warning: initialization from incompatible pointer type
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Erreur 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.26-1-amd64 »
make: *** [kmod_build] Erreur 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

Ca explique pourquoi le module fglrx n'est pas là. Merci l'installateur d'Ati de me dire que l'installation s'est bien passée. :transpi:

Après une recherche rapide sur Google, ça semble être un problème récurrent sur les noyaux 2.6.26. Je verrai si j'ai plus de chance avec l'ancien 2.6.24. :/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...