Jump to content

[XP] Windows Update n'installe pas les MAJ


Recommended Posts

Bonjour,

Je viens d'assembler un nouveau PC et d'y installer Windows XP Pro (donc installation 'vierge'). Malheureusement, Windows Update ne fonctionne pas - enfin, il ne marche qu'à moitié. Il arrive bien à télécharger les MAJ, mais quand il essaye de les installer il quitte le processus presque aussitôt, et affiche un message 'ces mises à jour ne peuvent pas être installés' avec la liste des MAJ qu'il vient de télécharger. Si je note les numéros (KB123456) et cherche les MAJ moi-même, j'arrive à les installer sans souci, mais ça enlève un peu l'intérêt du mécanisme qui les cherche et les installe automatiquement !

Quelqu'un d'autre a-t-il (ou elle) déjà rencontré de tels soucis ? J'ai déplacé 'My Documents and Settings' du C: vers D: en utilisant le tuto de Dohier (très bien fait, d'ailleurs), mais le souci ne vient pas de là - Windows Update se comportait de la même façon avant le déplacement !

Merci !

Link to comment
Share on other sites

Version de XP Pro d'origine ? ça serait pas une version modifiée genre titanium ou cocinelle ?

Oui, un XP Pro d'origine qui a déjà parfaitement fonctionné sur mon ancien PC, côté Windows Update. Je me demande également où Windows stocke les MAJ quand il les télécharge - à défaut de pouvoir régler le problème, je pourrais au moins aller récupérer les fichiers qu'il a téléchargé pour les installer, plutôt que d'aller les télécharger une deuxième fois manuellement...

Link to comment
Share on other sites

C:\Windows\SoftwareDistribution\Download, et rentrer dans chaque sous-dossier pour lancer le "update.exe" :D

Merci - au moins comme ça je pourrais récupérer les MAJ. Par contre, quelqu'un a des idées quant à pourquoi Windows n'arrive pas à les installer ? Ce serait sympa s'il le faisait tout seul !

Link to comment
Share on other sites

Salut,

Tu es bien administrateur du PC ?

As tu essayer de lancer un windows Update depuis le vrai compte Administrateur ?

Pour te connecter avec le compte administrateur, tu fermes ta session, et quand tu es sur l'écran d'accueil, tu tapes 2 fois Ctrl+Alt+Supp.

Tu auras un écran de login, où tu pourras entrer Administrateur comme nom d'utilisateur.

Essayes sous ce compte là pour voir.

:D

Link to comment
Share on other sites

OK, merci. Il n'y a pas de compte 'Administrator' sur cette machine - enfin, pas sous ce nom - le compte Administrator est le mien (crée lors de l'install). C'était pareil sur mon ancien PC, et Windows Update marchait très bien là-dessus. Je vais essayer de le re-installer, histoire de voir.

Link to comment
Share on other sites

Salut, est ce que Windows est activé ?

Est ce que tu as d'abord cherché a mettre à jour le module de mise à jour de XP pro ?

Ne passe pas par la mise à jour automatique de windows.

Va sur le site windows update via IExplorer et fait la mise a jour de ce module.

Bye

Link to comment
Share on other sites

Salut, est ce que Windows est activé ?

Est ce que tu as d'abord cherché a mettre à jour le module de mise à jour de XP pro ?

Ne passe pas par la mise à jour automatique de windows.

Va sur le site windows update via IExplorer et fait la mise a jour de ce module.

Bye

Oui, Windows est activé, et passe la validation pour les MAJ quand c'est nécessaire. Suite à l'installation je suis passé par IE pour faire un 'Update' (la version que j'ai installé est un SP2, donc il a été MAJ en SP3). Ca s'est bien déroulé, mais c'est ensuite qu'il a commencé à déconner. Ce matin encore il a voulu que j'installé la MAJ 'Malicious software removal tool' - téléchargement OK, mais installation KO par la suite. Je suis donc allé chercher le 'Update.exe' pour le lancer à la main, et ensuite (à mon grand étonnement) quand Update voulait l'installer à son tour il a fini par dire 'OK, MAJ terminé'. Je ne sais pas s'il est allé tout simplement regarder que la MAJ était déjà présent, mais auparavant je n'avais même pas le message pour dire que la MAJ était appliqué quand je l'avais installé à la main et Update voulait l'installer à son tour, donc il y a du progrès ! Bref, ce n'est pas très gênant puisque je peux contourner la MAJ automatique, je vais continuer de creuser...

Merci !

Link to comment
Share on other sites

Salut,

J'ai eu le soucis il y a peu.

Pour résoudre le problème:

commande executer: Services.msc

tu cherches la ligne "Mises a jour automatique" tu désactives le service et tu relances.

après cela devrait fonctionner :transpi:

Sur ce bonnes mises à jour ^^

Link to comment
Share on other sites

  • 2 weeks later...

Salut,

Je me permet de reposter puisque j'ai réinstallé un pc cette semaine et le problème est resurvenu

Donc j'ai essayé en arrêtant directement les services mais cela ne fonctionnait pas :/

Je ne sais plus comment j'avais fait la première fois mais j'étais tombé sur un site qui faisait cela via la cmd

Ce matin j'ai essayé avec le Dial-a Fix que Snooky a passé et cela fonctionne niquel :francais:

Donc voila

Sur ce @ bientôt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...