Jump to content

[Résolue] ATI, écran 1080p et résolution 1920x1080


Recommended Posts

Bon je suis de retour sur mandriva linux, possiblement pour un bon bout si je fini par faire marcher mon écran de pc. Je l'avias retiré par manque d'Espace dure (vue que l'écran marchais mal) mais maintenant que j'ai 1.1 to de disque dur.... je peux le ré-instaler.

j'ai choisit mandriva 2008 (cooker). Contrairement à la 2007 et 2007.1 (beta) il reconnais mon écran comme une écran plug'n'play il trouve même que mon écran a une résolution native de 1920x1080, sauf que quand je choisit se mode, l'écran tombe bien en mode 1920x1080 60hz (le modeline du xorg.conf a bien les bon parametre de timiming) mais l'écran reste noir 3-4 sec et après deviens hors sync. c'est déja mieux que avant car l'écran n'étais jamais en sync en 1920x1080 sous linux.

si ça peut-aidé voici mon xorg.conf (moi je le trouve correct) sinon je suis vraiement embêté sur le pourquoi du parce que :( et je serais vraiement heureux de trouver le problême.

p.s. j'utilise les drivers fglrx (propio 8.40.1 pris du plf) une carte graphique Radeon x1800gto et une écran samsung 1080p de 42 pouces.(+/- 100cm) et je suis connecté en VGA

mon xorg.conf:

# File generated by XFdrake (rev 227259)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "ca"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "evdev"
Option "product" "0xc01e"
Option "vendor" "0x046d"
Option "HWheelRelativeAxisButtons" "7 6"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "SAMSUNG"
HorizSync 30-80
VertRefresh 56-75

# Monitor preferred modeline (59.9 Hz vsync, 66.6 kHz hsync, ratio 16/9)
ModeLine "1920x1080" 138.5 1920 1968 2000 2080 1080 1083 1088 1111 -hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"	 50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"	 63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon X1300 - X1950"
Driver "fglrx"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 15
	Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 16
	Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 24
	Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"
Screen "screen1"
EndSection

Link to comment
Share on other sites

c'est un problème de résolution, tu arrives à le faire marcher à une résolution plus basse ?

Si tu vires les modlines et que tu rajoutes un mode "1920x1080" dans la section Displya 24bits, ça met toujours un out of range ?

oui en résolution plus basse soit 1280x1024 ou 1280x960 ça marche très bien ( quoi que pas mal floue et de bruit de resempling)

j'essaie ton idée et je te redonne des news

EDIT:

WOW, tu viens de faire ma journée et même tout mon mois.... c'est vraiement beau kde en 1920x1080.... je te remerci 1000 fois

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...