Jump to content

[VISTA] [RESOLU] Pagefile.sys


mE44

Recommended Posts

Salut

Bon je viens de passer de Windows XP à Windows Vista Home Basic (eh oui j'ai pas la bourse a Rotchield :francais: ). On va pas

dire c'est un bon OS, a part qu'il pompe un peu plus en perf. J'ai installé Battlefield 2, tout marche bien mais quand je

charge une map à la fin le chargement des données client s'éternise (presque 1mn30) alor qu'il ne durait que

10 secondes même pas sur XP :transpi: . J'ai regardé dans le gestionnaire des taches et je me suis appercu que le problème

venait du fichier d'echange pagefile.sys. C'est lui qui fait litéralement ramer mon pauvre DD....

Je voudrais savoire si le fait de supprimer ce fichier aura des conséquences funestes pour windows vista ou si

au contraire il marchera pareil.

J'espere que vous pourrez m'éclairer sur ce sujet.

merci d'avance

Link to comment
Share on other sites

Salut,

Normalement (je connais pas vista) le pagefile.sys, c'est le fichier de swap de windows.

Donc tu ne pourras pas le supprimer.

Si tu utilises la swap, c'est que tu n'as pas assez de mémoire virtuelle, donc win utilise le disque dur.

Généralement, le fait de sapper fait ralentir la bécane, d'où ta minute 30.

Dans le gestionnaire des tâches, regarde un peu l'état de la mémoire.

:transpi:

Link to comment
Share on other sites

bonjour ,

je confirme , si tu vires ce fichier , tu vas au devant de problémes , xp et vista sont pas si loin .....

et +1 pour la ram car le swap est là en cas de saturation , donc pour toi voir ajout de ram ,

ou alors dans MSCONFIG voir les fichier de démarrage , ca eput aider un peux + 1 défraque .

tu as aussi des utilitaires pour débloquer la mémoire je sais plus les noms c'est loin ....genre RAMBOOST un truc du genre , ca

peux aider aussi , mais bon ce n'est que des amplatres donc...

Link to comment
Share on other sites

Bof bien sur que si que l'on peu le supprimer le fichier pagefile.sys ! suffit de faire apparaitre les fichiers cachés et les fichiers protégés de windows dans options des dossiers puis de mettre le swap à zéro (vous savez comment) , redémarrer puis re mettre le swap a zéro (bien qu'il y soit déjà... windows marche comme ça c'est tout) puis redémarrer puis unlocker sur le fichier pagefile.sys situé dans C:\ et le supprimer .... si cela ne marche pas installer tuneup utilities et supprimer le ficher grace à tuneup shredder en DOD 1 passe et voila ! ;)

moi je fonction 24h/24 sans swap ni page file et que d'espace disque de gagné (je suis sous vista 64 ulimate) et no probleme aucun :francais:

... je vous vois venir, oui j'ai 4go de ram mais ce n'est que récent et avec 2go cela reste parfais ! O oui il faut aussi entrer une valeur dans le registre pour forcer windows à n'utiliser que la ram au lieu du swap :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

- Valeur DisablePagingExecutive : mettez la valeur 1

redémarrez

Link to comment
Share on other sites

Merci de vos réponses ! et desolé du retard pour celle ci ^^

Alors j'avais oublié de préciser que quand je swappe lors des "données client" de Battlefield 2

mon utilisation mémoire est a 1.8 Go, donc j'ai encore un peu de place !(voire ma signature pour la config).

Normallement je ne devrais pas swapper ! Alors comment ca se fait ? :zarb:

Je précise que sur S.T.A.L.K.E.R. ca swappe aussi (je monte a 1.9Go utilisés). Et c'est absolument injouable

(2 FPS en moyenne avec FRAPS test 60s) pendant 5 à 6 mn.

Par contre depuis j'ai fait une manip (création de partiton et deplacement du fichier pagefile.sys dans celle ci)

ca swappe un peu moins mais ca swappe encore :craint: . Point-ne comprend-je ..........

Mais subsiste un probleme que je ne vous avais pas soumis qui est que

le programme svchost.exe fait ramer mon DD comme un rat mort. Je ne sais pas pourquoi, quand je ne fait rien

sous vista ou sous un jeu, il se met a trafiquer je ne sais quoi sur un fichier X comme par exemple

CommonClient.dll (relatif à Oblivion). Le transfert monte alors à plus de 70Mo/s !!!!!! :zarb:

Ca me fait mal de voire le boucant que fait le pauvre DD et la petite LED bleue s'allumer sans cesse ! :yes:

Pouvez vous m'expliquer ?? (je sais ca fait beaucoups de question désolé :transpi: )

Comment se fait il que Vista trouve toujours un moyen pour faire travailler intensément mon DD !! :pleure:

PS : je précise que dans ma tentative pour supprimer pagefile.sys ou pour le redimentionner = Blue screen of death ....

Link to comment
Share on other sites

Juste comme ça , vu que tu as 2Go de mémoire vive , diminue la taille de la mémoire virtuelle , je l'ai fixé à 512Mo .De toute façon , si pour toi ce n'est pas assez , tu auras une message d'alerte .Tu n'auras qu'a l'augmenter !

Pour info , a part le placer sur un DD plus rapide , tu n'en tireras aucun avantage !

Et vu que tu n'as qu'un seul disque dans ta signature !

Tu as bien installer les derniers pilotes de ta CG :

http://www.nvidia.fr/object/winvista_x86_162.22_fr.html

Il faut que tu récupéres de la "ressource" . Avec "msconfig" ferme tout les programes qui s'active au démarrage .

Link to comment
Share on other sites

Salut ^^

En fait, quand j'essayait de redimentionner le pagefile.sys afin de le diminuer j'avais systématiquement

un blue screen (même quand je le redimentionnait à la même taille ...)

De plus, en effet je n'ai qu'un seul DD mais le fait de changer la partition pour pagefile.sys

a automatiquement dininué ce dernier. Il est maintenant a 759Mo (2439Mo a l'origine ....).

Sinon pour le driver j'ai le dernier, le 163.44 beta (il marche mieux que le 162.22 qui faisait

planter vista...) et supprimer les programmes de demarrages inutiles c'est ce que je fais en

premier quand j'installe vista (apres avoir retiré l'indexation bien sur ^^ :win: ).

J'ai même retiré un certain nombre de services qui étaient inutiles comme "acquisition

d'images windows (WIA)" ou autres du même genre.

Peut être devrais je essayer de désactiver le prefetch :chinois:

merci de vos réponses !! :fumer:

Link to comment
Share on other sites

resalut ^^

Alors j'ai essayé de redimentionner le pagefile.sys comme tu me l'as dit mon cher snooky et

je me retrouve comme d'habitude avec un blue screen. :eeek2:

Mon antivirus est Kaspersky Internet Security 6.0 (non craké ^^ :francais: )

Link to comment
Share on other sites

Bon, Kaspersky désinstallé. :eeek2:

Voici le rapport Hijackthis :

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 14:39:35, on 06/09/2007

Platform: Windows Vista (WinNT 6.00.1904)

MSIE: Internet Explorer v7.00 (7.00.6000.16512)

Boot mode: Normal

Running processes:

C:\Windows\system32\taskeng.exe

C:\Windows\system32\Dwm.exe

C:\Windows\Explorer.EXE

C:\Program Files\Windows Defender\MSASCui.exe

C:\Windows\RtHDVCpl.exe

C:\Windows\System32\rundll32.exe

C:\Program Files\Windows Sidebar\sidebar.exe

C:\Windows\System32\rundll32.exe

C:\Program Files\Common Files\Ahead\Lib\NMBgMonitor.exe

C:\Program Files\Windows Media Player\wmpnscfg.exe

C:\Program Files\Common Files\Ahead\Lib\NMIndexStoreSvr.exe

C:\Program Files\Windows Sidebar\sidebar.exe

C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

C:\Program Files\Logitech\SetPoint\SetPoint.exe

C:\Program Files\Common Files\Logitech\KhalShared\KHALMNPR.EXE

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.fr/

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [RtHDVCpl] RtHDVCpl.exe

O4 - HKLM\..\Run: [skytel] Skytel.exe

O4 - HKLM\..\Run: [JMB36X IDE Setup] C:\Windows\JM\JMInsIDE.exe

O4 - HKLM\..\Run: [NvSvc] RUNDLL32.EXE C:\Windows\system32\nvsvc.dll,nvsvcStart

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\Windows\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\Windows\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [Kernel and Hardware Abstraction Layer] KHALMNPR.EXE

O4 - HKLM\..\Run: [NeroFilterCheck] C:\Program Files\Common Files\Ahead\Lib\NeroCheck.exe

O4 - HKCU\..\Run: [sidebar] C:\Program Files\Windows Sidebar\sidebar.exe /autoRun

O4 - HKCU\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter

O4 - HKCU\..\Run: [MsnMsgr] "C:\Program Files\MSN Messenger\MsnMsgr.Exe" /background

O4 - HKCU\..\Run: [bgMonitor_{79662E04-7C6C-4d9f-84C7-88D8A56B10AA}] "C:\Program Files\Common Files\Ahead\Lib\NMBgMonitor.exe"

O4 - HKCU\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'SERVICE LOCAL')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'SERVICE LOCAL')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'SERVICE RÉSEAU')

O4 - Global Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\SetPoint.exe

O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O13 - Gopher Prefix:

O16 - DPF: {5D6F45B3-9043-443D-A792-115447494D24} (UnoCtrl Class) - http://messenger.zone.msn.com/FR-FR/a-UNO1/GAME_UNO1.cab

O16 - DPF: {C3F79A2B-B9B4-4A66-B012-3EE46475B072} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/Messe...nt.cab56907.cab

O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shoc...ash/swflash.cab

O16 - DPF: {F5A7706B-B9C0-4C89-A715-7A0C6B05DD48} (Minesweeper Flags Class) - http://messenger.zone.msn.com/binary/MineS...er.cab56986.cab

O17 - HKLM\System\CCS\Services\Tcpip\..\{18078424-C19A-43DA-A486-64E1582C1F4D}: NameServer = 212.27.54.252,212.27.53.252

O17 - HKLM\System\CS8\Services\Tcpip\..\{18078424-C19A-43DA-A486-64E1582C1F4D}: NameServer = 212.27.54.252,212.27.53.252

O17 - HKLM\System\CS9\Services\Tcpip\..\{18078424-C19A-43DA-A486-64E1582C1F4D}: NameServer = 212.27.54.252,212.27.53.252

O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL

O23 - Service: Ad-Aware 2007 Service (aawservice) - Lavasoft AB - C:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe

O23 - Service: NBService - Nero AG - C:\Program Files\Nero\Nero 7\Nero BackItUp\NBService.exe

O23 - Service: NMIndexingService - Nero AG - C:\Program Files\Common Files\Ahead\Lib\NMIndexingService.exe

O23 - Service: PnkBstrA - Unknown owner - C:\Windows\system32\PnkBstrA.exe

--

End of file - 5212 bytes

Je précise qu'il m'as envoyé deux messages d'erreurs lors du scan (erreur 5) :francais: .

J'ai des fichiers .dmp dans Windows\Minidump mais j'avoue que je sais pas comment les uploader.

Si vous pouvez me dire comment faire je me ferai une joie de les envoyer ^^

merci encore pour vos réponses !

Link to comment
Share on other sites

Si ton hdd gratte tout le temps alors fait ceci :

tape regedit dans executer puis va dans hkeylocalmachine/system/currentcontrolset/control/session manager/memory management/prefetchparameter et met la valeur du enableprefetcher à 1 et celle du enable superfetch à 0 :-D

n'as tu pas pris en compte ma remarque plus haut ? :chinois:

Link to comment
Share on other sites

C'est l'usage du fichier qui est important, pas sa taille. Un usage égal à 0 pendant plusieurs jours, même si le fichier change de taille implique que tu as assez de ram. La taille qui change ne veux rien dire, cela implique surtout une réservation.

Link to comment
Share on other sites

Entiérement d'accord avec toi XZombi !

Essaye 900Mo !

snooky , dés que l'on a 2Go de mémoire vive , il n'est plus besoin qu'il soit grand en taille !

C'est vrai que maintenant , vous avez des "gros" disques durs , ce n'est pas mon cas !

Mais il faut que tu résolves cette surconsommation de ressource !

Pour ton info , mon vista édition familliale premium , au départ consomme un peu plus de 500Mo de mémoire !

Et vous ?

Link to comment
Share on other sites

Salut ^^

Bon j'ai envoyé les .dmp mais comme ils demandaient un "recipient e-mail" j'ai mis celui de snooky,

désolé pour les autres... :censored: .

J'ai fait ta manip Squallix et je dois admettre que ca rame UN PEU moin. Ca rame encore...

Sinon pour info mon Vista consomme environ 700mo de ram.

Link to comment
Share on other sites

Suffisait de copier le lien de téléchargement de Yousendit :

http://www.yousendit.com/transfer.php?acti...5ef051a01711f60

Erreurs sur nvlddmkm.sys lié aux pilotes de la carte garphique :

http://www.clubic.com/forum/microsoft-wind...5598-page2.html

Erreur sur Ecache.sys :

http://www.microsoft.com/technet/technetma...ult.aspx?loc=fr

Erreur sur CLASSPNP.SYS :

http://support.microsoft.com/default.aspx?...b%3Bfr%3B326122

:censored:

Désactive Windows defender et désinstalle Ad-aware.

Laisse Vista gérer la mémoire.

Vérifie tes barrettes avec Memtest86 ou l'utilitaire au boot de Vista .

Change les pilotes de ta carte grahique.

Link to comment
Share on other sites

re Salut ^^

Windows Defender désactivé et Ad Aware désinstallé.

J'ai testé mes barettes pendant 45mn et 0 erreurs :chinois: .

Par contre les pilotes de la carte graphique je prend lesquels ?

j'ai les 163.44 bêta mais les 162.22 font bugger vista (redemarrage intempestif)

je doit prendre des pilotes antérieurs ?

PS : désolé pour les fichiers .dmp, des fois je suis un boulet...

qui a dit tout le temps ??? :byebye:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...