Jump to content

Archived

This topic is now archived and is closed to further replies.

H3dy

[Résolu] OpenBSD 4.1 (radeon mobility X700)

Recommended Posts

madko,

je comprends mieux pourquoi j'ai un écran noir , mon fichier xorg.conf est vide! :-D

#X -configure /etc/X11/xorg.conf
(écran noir!)

#vi /etc/X11/xorg.conf
(fichier vide!)

ce n'est pas /ext/ mais belle et bien /etc/

une idée peut être pour me faciliter la tâche?

Share this post


Link to post
Share on other sites
madko,

je comprends mieux pourquoi j'ai un écran noir , mon fichier xorg.conf est vide! :francais:

#X -config /ect/X11/xorg.conf
(écran noir!)

#vi /ect/X11/xorg.conf
(fichier vide!)

EDIT (correctif):

ce n'est pas /ext/ mais belle et bien /ect/

une idée peut être pour me faciliter la tâche?

euh c'est etc! /etc/X11/xorg.conf c'est peut etre pour ça qu'il est vide, si tu met /ect/

(utilise la touche tab pour completer les chemines)

Share this post


Link to post
Share on other sites

je confirme, mon fichier xorg.conf est vide!

en revanche si je fais:

#vi /root/xorg.conf.new

j'ai toutes les données du fichier!

dans:

Driver "ati" faut il le remplacer par "radeon"? puisque le pilote radeon correspond bien à ma carte graphique Ati radeon mobility x700

vu dans:

#vi /var/log/Xorg.0.log

j'ai tenté de modifier xorg.config.new mais lors du saving (:q) celà ne fonctionne pas, je suis forcer à faire (:q!) pour quitter vi en mode root (discarding)

Share this post


Link to post
Share on other sites
je confirme, mon fichier xorg.conf est vide!

en revanche si je fais:

#vi /root/xorg.config.new

j'ai toutes les données du fichier!

dans:

Driver "ati" faut il le remplacer par "radeon"? puisque le pilote radeon correspond bien à ma carte graphique Ati radeon mobility x700

vu dans:

#vi /var/log/Xorg.0.log

j'ai tenté de le modifier mais lors du saving (:q) celà ne fonctionne pas, je suis forcer à faire (:q!) pour quitter vi en mode root (discarding)

"ati' ou "radeon" marchent tout aussi bien... pour expliquer vite fait, "ati" est le driver générique qui contient tous les drivers libres pour les cartes ati (le driver radeon, mais aussi les drivers pour les cartes pré-radeon)... donc, ça devrait le faire...

Sinon, pour l'instant, tu peux faire sans le xorg.conf de /etc/X11... fait juste un X -configure /root/xorg.config.new... si tu as toujours un écran noir, fait ce qu'ils te disent sur le lien que je t'ai donné: trifouille la résolution, les fréquences de rafraîchissement et la profondeur des couleurs...

Après, une fois que tu auras une mire en lieu et place d'un écran noir, fais un "cp /root/xorg.config.new /etc/X11/xorg.conf" et un bête startx (si tu veux lancer fluxbox au démarrage de X, il faudra peut-être trifouiler le ~/.xinitrc... m'enfin, déjà, essaie d'avoir la mire...)...

Edit : openbox, je ne le connais pas du tout... par contre fluxbox est sympathoche... m'enfin, bien trop lourd et pas assez configurable par rapport à FVWM :mad2: (cependant beaucoup plus compliqué à configurer, certes, certes...)...

Share this post


Link to post
Share on other sites

Aefron,

pourrais-tu faire un screen de ton FVWM? que cela puisse me donner un aperçu, je recherche justement un gestionnaire de fenêtre rapide et efficace avec qu'en même quelques effets d'ombres, de tranparence, de couleurs et agréable à regarder mais il y en a tellement que cela n'est pas évident, je ne veux pas d'environnement graphique de bureau (kde,gnome & xfce) (beaucoup trop lourd et me sera d'aucune utiliter!)...

Aperçu d'openbox:

http://www.box-look.org/index.php?xcontentmode=7402

Si tu me dis que fluxbox (c++) est beaucoup trop lourd je vais utiliser son fork Openbox ( c )! :mad2:

Share this post


Link to post
Share on other sites

alors....

par contre la commande "cp xorg.conf.new /ect/X11/xorg.conf" ne fonctionne pas! A croire que je n'ai pas de fichier à /ect/X11/xorg.conf puisque qu'en je fais "vi /ect/X11/xorg.conf" le fichier est vide donc:

#cp xorg.conf.new /ect/X11/xorg.conf
ou
#cp /root/xorg.config.new /etc/X11/xorg.conf
cp: /ect/X11/xorg.conf: No such file or directory

Que faire?

Ce n'est pas "xorg.config.new" "=>" "xorg.conf.new"

Share this post


Link to post
Share on other sites

sous vi pour sauvegarder les modif c'est pas :q (qui sert a quitter) mais :w

:wq si tu veux quiter (ou :x c'est plus rapide, voire meme <esc>+ZZ)

si tu fais un ls /etc tu vois bien le rep X11? t'as installer le packager Xetc41 lors de l'install?

euh sinon que ton WM soit codé en C ou en C++ ne changera rien a sa lourdeur

Share this post


Link to post
Share on other sites

madko,

j'ai réussi à modifier quelques données dans le fichier /root/xorg.conf.new par la command :q suivi de write;

bref, j'en conclu que le server X ne sait pas détecter l'écran de mon ordinateur portable mais est capable de détecter ma carte graphique...

(Il existe des conséquences sur la sécurité. Plusieurs plates-formes requièrent le pilote d'aperture xf86(4) qui offre un accès à la mémoire et aux ports d'entrée/sortie de la carte VGA ainsi qu'aux registres de configuration PCI nécessaires.)

Ayant à ma disposition un autre écran, j'ai tester startx en mode root et je suis directement propulser à xterm,

comment faire fonctionner fluxbox qui est déjà installer sachant qu'il n'est pas connecté au serveur X?

# exec fluxbox
Error: Couldn't connect to XServer

Bug des Core 2 Duo:

"Intel publie une liste avec les bugs et les problèmes connus de ses processeurs. Tous les modèles sont touchés, même si la liste des problèmes des Core 2 Duo est particulièrement longue. La première chose à savoir, c’est qu’une partie des bugs est corrigée par les différentes révisions des processeurs et qu’une autre partie est corrigée par les BIOS des cartes mères et le microcode du processeur. Le problème relevé par Theo de Raadt vient essentiellement des différences d’implémentation de la MMU (Memory Management Unit) dans les Core 2 Duo (par rapport aux autres processeurs Intel), qui seraient une entrée pour des attaques de très bas niveau. Selon lui, une partie des OS actuels seraient vulnérables."

http://www.presence-pc.com/actualite/bug-core-2-duo-24135/

j'ai un pentium M serie 7 :D

Share this post


Link to post
Share on other sites

Pour FVWM, c'était une boutade... fluxbox est déjà du genre léger... c'est juste que FVWM l'est encore plus (après, ce sont des batailles de clocher... à toi de choisir le tien :craint: )...

Pour la config, je suis en plein remaniement de mon bureau, des apps dockées et des couleurs (je suis en train de tester un switch d'une majorité d'apps gtk à une majorité en qt... raz-le-bol complet de firefox et lenteur générale de gtk en causes)... donc, ce n'est pas très montrable :transpi: ... mais tu trouveras une pèletée de screens sur FVWM Lair (le fofo FVWM)... virtuellement, ça peut être très moche (la config par défaut) ou très beau (si tu es prêt à suer sang et eau sur un fichier de conf :fumer: ... l'avantage étant la versatilité extrême du bouzin, en plus de sa légèreté... ça se compile en deux coups de cuiller à pot...)... en tout cas, il respecte pleinement (ou presque) ICCCM et n'a éventuellement des problèmes (genre focus ou déplacement) qu'avec les apps qui ne le respectent pas (genre audacious qui est aussi une raison de vouloir switcher de gtk à qt pour moi)...

Sinon, si tu n'arrives pas à copier dans /etc/X11, c'est peut-être comme l'a sous-entendu Madko qu'il n'existe pas... dans ce cas fait un ls /etc | grep X11, et si tu n'as rien... bah... mkdir /etc/X11/ ... puis ré-essaye de copier...

Pour ta question sur la détection du GPU mais pas de l'écran, oui, ça doit être ça... commence par la profondeur des couleurs et la résolution (c'est souvent ça qui coince)... et commente le rafraîchissement (ou mieux, va voir les informations DCC dans le /var/log/Xorg.0.log... il y a fort à parier que les modes de rafraîchissement et les résolutions supportées par ton écran y soient listées... c'est toujours là que je vais voir quand j'ai un nouvel écran)...

Sinon, pour lancer le window manager de ton choix au lancement de X, va jeter un oeil sur google à propos du fichier .xinitrc... normalement, on le met à la racine du /home de l'utilisateur qui va lancer X (si on veut faire du cas par cas), et on y met quelque chose du genre "exec fluxbox" ou "exec fvwm"... ça doit alors lancer le window manager (et ce que tu veux exécuter au démarrage de X) quand tu fais startx... bon, après, il doit y avoir un xinitrc "system wide", mais je ne me souviens plus d'où c'est sur OpenBSD...

Autrement, juste quelques commandes de base pour vi (que je déteste, mais que je suis bien forcé d'utiliser des fois, notamment sur les images par défaut non compilées par moi-même d'OpenWRT... grrrr... je préfère nano, pour éditer en shell... et si je veux du psychédélique, y a emacs que je préfère de loin...)... : tu passes en mode de commande du logiciel en faisant Echap et en mode édition en faisant Inser (les touches)... en mode de commande, commence tes instructions par : (deux points), et, basiquement, tu peux faire q! pour quitter sans confirmation et sans enregistrer, w pour sauver ton fichier ou wq pour sauver et quitter... et dire qu'il y en a qui le trouvent plus simple qu'emacs :roll::D:transpi::troll:

Share this post


Link to post
Share on other sites

Par contre si t'as pas /etc/X11 jpense que c'est plutot genant, surement un package oublié lors de l'install

tu peux le rajouter en le telechargeant depuis un ftp d'openbsd, c'est surement le package xetc41.tgz (vu son nom)

bon sinon jle recolle la, t'a bien ça dans le fichier xorg.conf que tu utilise?

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Option "MonitorLayout" "LVDS, NONE"
EndSection

Share this post


Link to post
Share on other sites

Juste pour préciser... a priori, VendorName et BoardName, c'est du cosmétique, et on peut très bien s'en passer (ou à la limite, pour marquer des choses rigolotes dans les logs)...

Pour MonitorLayout, ça n'a vraiment de sens que si on utilise du DVI numérique (le DVI analogique envoie la même chose que le VGA, et si un seul écran est branché et qu'on est en analogique, il y a la même chose sur les deux sorties), ou qu'on fait du multi-screen (et qu'on veut gérer en soft plutôt que de changer les branchements)...

Les sections obligatoires de base se limitent à Identifier et Driver (et pour le coup "ati" ou "radeon", ça revient exactement au même)...

Si H3dy n'utilise pas de DVI numérique (les LCD supportent a priori numérique et analogique sur le DVI? Je ne sais pas... Enfin, le standard DVI et les ports DVI sur les GPU, si, ils supportent les deux... mais les écrans, et en l'occurence, le sien, je ne sais pas... je n'ai qu'un vieux LCD en VGA... sinon, en numérique, j'ai un cathodique HDMI qui n'accepte que le numérique... donc, je ne saurais trop dire), le problème est, par ordre de probabilité décroissante: profondeur de couleurs, rafraîchissement et résolution... je ne dis pas ça que par expérience, mais aussi parce que c'est ce qui est marqué dans la doc que j'ai linkée plus haut (m'enfin, en général, ce sont les réglages de base problématiques)...

... bon, après, s'il manque du paquet contenant des fichiers de conf, c'est encore un autre problème...

Share this post


Link to post
Share on other sites

Aefron,

si tu en as marre de firefox je te conseille opera qui est celui que j'utilise par défaut.

Pourtant lors de l'installation de base j'ai tout installer (all) (ect41.tgz inclus)

Share this post


Link to post
Share on other sites
si tu en as marre de firefox je te conseille opera qui est celui que j'utilise par défaut.

:censored: pas libre opera, pas libre... j'essaie de me faire à Konqueror, bien plus performant que firefox (epiphany, je n'y arrive pas... trop gnomeux)... il me manque encore des choses, mais de là à aller dans le proprio, non quand même pas...

Et sinon, en créant le répertoire X11 dans /etc, une fois que tu auras un xorg.conf qui marche avec "X -configure", ça pourrait tout de même le faire... m'enfin, déjà, chaque chose en son temps... essaye d'obtenir la mire en jouant (principalement) des trois paramètres que je t'ai conseillé de trifouiller (genre profondeur des couleurs à 24 bits, fréquences de rafraîchissement commentées, et résolution native de ton LCD comme résolution par défaut)...

Share this post


Link to post
Share on other sites

[...]
Section "Monitor"
			 Identifier  "Monitor0"
			 VendorName "MonitorVendor"
			 ModelName "Monitor Model"
[...] (c'est tout ce que j'ai dans cette section)
j'ai rajouter dans ce même fichier 2indices suivant la documentation:
[...]
Section "Screen":
DefaultDepth  24
[...]
SubSection "Display"
Modes "1280x1024"
[...]
sinon  madko ma carte graphique est détecté par le driver "ATI" (xgl) et non "radeon"

dans la documentation il précise que si l'écran ne fonctionne pas il serait préférable d'en essayer un autre, ce qui est mon cas, car en essayant un autre écran (branchement d'un autre écran par la prise vga de ma carte graphique de mon pc portable), startx fonctionne mais même si celui ci fonctionne je peux pas rajouter "exec fluxbox" dans le fichier .xinitrc puisqu'il n'existe pas ou il est vide.

ce qui me dérange c'est la dépendance d'un autre écran pour pouvoir faire fonctionner X11!

Aefron,

Sinon connais-tu le browser Lynx , ELinks ou W3M ? en terme de rapidité je connais pas mieux.

(j'ai les nerfs à bloc les gas!) :censored:

Share this post


Link to post
Share on other sites

le fichier .xinitrc n'existe pas c'est normal

c'est un fichier de personnalisation, donc c'est a toi de le créer

par contre si tu continue a utiliser /ect et non /etc moi jlaisse tomber. parceque quand jvois mkdir /ect/X11 c'est normal que ça passe pas

donc j'espere que c'est juste une faute de frappe sur le forum et que tu tape bien mkdir /etc/X11 (en tant que root bien sur)

Share this post


Link to post
Share on other sites

Bon, déjà, plussoyage de Madko... fais quand même gaffe à ce que tu écris... ect n'est pas etc...

Normal que "mkdir /ect/X11" ne marche pas... mkdir n'est pas récursif de base, donc si /ect n'existe pas, il refusera d'y créer X11... et tant mieux... ça évite de propage trop de conneries...

Pour le .xinitrc (note bien le "point" devant xinitrc), il faut le mettre à la racine du /home de ton utilisateur (par exemple, dans /home/H3dy/)... m'enfin, on te l'a dit, tant que tu n'as pas de mire en faisant "X -configure", ça ne sert pas à grand chose: ce n'est pas ça qui fera marcher ton clickodrome... ça lancera juste le bon window manager quand tu feras startx... une fois que ton clickodrome fonctionnera avec l'écran que tu veux utiliser dessus, mais pas avant...

... mais tant que ton xorg.conf (celui dans /etc/X11) n'existe pas et n'est pas configuré comme il faut, j'aurais tendance à dire que tu mets la charue avant les boeufs...

Sinon, dans ta section screen, il faut que tu aies quelque chose du genre :

DefaultDepth 24

SubSection "Display"

Depth 24

Modes "1280x1024"

EndSubSectio

Parce que si tu demandes une profondeurs par défaut de 24bits et que tu n'as pas de sous-section display dans laquelle c'est déclaré, on ne va pas aller loin...

Si ça ne marche pas, il va falloir trifouiller les fréquences de rafraîchissement... Google Is Your Friend... et le /var/log/Xorg.0.log aussi... et jette aussi un oeil sur ce dont Madko te parlait au sujet de MonitorLayout... c'est rare qu'on en ait besoin, mais bon...

Sinon, un petit "man radeon" (au pire dans google, si la page de manuel n'est pas installée sur ton OpenBSD) n'a jamais tué personne...

Sinon, links, w3m et cie, je connais... bon, je suis barbu, il m'arrive de m'en servir de temps en temps, mais quand même ;)

Ah oui... une question... tu n'as jamais configuré de X.org tout seul? Parce que là, tu as déjà l'air de patauger dans des trucs de bases *nix* (/etc et les fichiers commençant par un point dans le /home/utilisateur, c'est quand même très basique... si tu as déjà du mal avec ça, tu vas souffrir)... tu devrais peut-être commencer avec quelque chose de plus encadré qu'une OpenBSD, si tu es grand débutant et que tu veux quand même mettre les mains dans le camboui (m'est avis que Gentoo est géniale pour ça, et que c'est la distro de très loin la mieux documentée, par laquelle tout libriste bidouilleur devrait passer)... ce n'est pas contre toi que je dis ça, mais l'utilisation d'OpenBSD suppose quand même d'avoir les bases d'administration *nix si on ne veut pas finir les nerfs à bloc...

Share this post


Link to post
Share on other sites

madko,

mille excuse! effectivement si les erreurs se sont générer c'est belle et bien de mes fautes d'orthographes dont il s'agissait!

/etc et non /ect ni /ext ;)

j'ai rajouter une ligne dans le fichier .xinitrc puisque j'utilise fluxbox (bientôt openbox!)

vi xinitrc
exec fluxbox
:w
:q

j'ai modifier et tester les drivers "ati" ou "radeon", sans succès! dans vi /etc/X11/xorg.conf (card0)

le seul qui me propulse jusqu'a mon gestionnaire de fenêtre est le driver "vesa" suivi d'un startx!

merçi de votre contribution! madko & Aefron! :transpi:

Share this post


Link to post
Share on other sites

Aefron,

j'ai notamment rajouter dans xorg.conf:

HorizSync 31.5 - 48.5

VertRefresh 50.0 - 90.0

En utilisant le driver ati de base:

j'ai une erreur après le lancement de startx:

failed to read: session.screen0....

Aefron c'est rare qu'en je bloque sur de la fignolle (genre les ect, ext & etc), mais là, je dois dire que je m'étonne tout seul. Et j'en suis même content car je m'en souviendrais

Share this post


Link to post
Share on other sites

Tu peux nous poster ton xorg.conf complet (passe par une clé usb si tu n'arrives pas à accéder à ta partoche OpenBSD à partir de ton livecd...)...?

Sinon, tu as essaye le MonitorLayout (si tu passes par du DVI numérique, ça peut se révéler tout à fait utile)?

Edit: "failed to read: session.screen0" ... ça me fait plus penser à une erreur de configuration fluxbox qu'à une erreur X.org...

Share this post


Link to post
Share on other sites

je redémarre:

vi /etc/X11/xorg.conf

(j'écris tout à la main sur une feuille de papier et je récris les données sur le forum)

je commence...(puisque j'avais déjà commencer!)

Section "ServerLayout"

Identifier "X.org Configured"

Sreen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "keyboard0" "CoreKeyboard"

EndSection

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

ModulePath "/usr/X11R6/lib/modules"

FontPath "/usr/X11R6/lib/X11/fonts/misc/"

FontPath "/usr/X11R6/lib/X11/fonts/TTF/"

FontPath "/usr/X11R6/lib/X11/fonts/Type1/"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection

Section "module"

Load "dbe"

Load "extmod"

Load "glx"

Load "record"

Load "xtrap"

Load "freetype"

Load "type1"

EndSection

Section "InputDevice"

Identifier "mouse0"

Driver "mouse"

Option "Protocol" "wsmouse"

Option "Device" "/dev/wsmouse"

Option "ZaxisMapping" "4 5 6 7"

EndSection

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Model"

HorizSync 31.5 - 48.5

VertRefresh 50.0 - 90.0

EndSection

Section "Device"

###Available Driver option are :-

###Values: <i>: integer, <f> : float, <bool> "true"/"false":

###<string>: "String", <freq>: " <f> Hz/Khz/Mhz"

###[arg]: arg optionnal

#Option "NoAccel" #[<bool>]

#Option "SWcursor" #[<bool>]

#Option "Dac6bit" #[<bool>]

#Option "Dac8bit" #[<bool>]

#Option "PanelOff" #[<bool>]

#Option "DDCMode" #[<bool>]

#Option "MonitorLayout" #[<str>]

#Option "IgnoreEDID" #[<bool>]

#Option "UseFBDev" #[<bool>]

#Option "MergedFB" #[<bool>]

#Option "CRT2HSync" #[<str>]

#Option "CRT2VRefresh" #[<str>]

#Option "MetaModes" #[<str>]

#Option "MergedDPI" #[<str>]

#Option "MergedXinerama" #[<str>]

#Option "MergedXineramaCRT2IsScreen0 #[<bool>]

#Option "MergedNonRectangular" #[<bool>]

#Option "MergedMouseRestriction #[<bool>]

#Option "DisplayPriority" #[<str>]

#Option "PanelSize" #[<str>]

#Option "Force Min Dot Clock" #[<freq>]

#Option "ColorTiling" #[<bool>]

#Option "Videokey" #[<i>]

#Option "RageTheatreCrystal" #[<i>]

#Option "RageTheatreTunerPort #[<i>]

#Option "RageTheatreCompositePort #[<i>]

#Option "RageTheatreSvideoPort #[<i>]

#Option "RageTheatreTunerType #[<i>]

#Option "RageTheatreMicroPath #[<str>]

#Option "RageTheatreType #[<str>]

#Option "RageTheatreRenderAccel #[<bool>]

#Option "RageTheatreSubPixelOrder #[<str>]

#Option "RageTheatreShowCache #[<bool>]

#Option "RageTheatreDynamicClocks #[<bool>]

#Option "RageTheatreBIOSHotKeys #[<bool>]

#Option "RageTheatreVGAAcess #[<bool>]

#Option "RageTheatreReverseDDC #[<bool>]

#Option "RageTheatreAccelMethod #[<bool>]

Identifier "Card0"

Driver "vesa"

VendorName "ATI Technologies Inc"

BoardName "Radeon Mobility X700 (PCIE)"

Bus "PCI :1:0:0"

EndSection

Section "Screen"

Identifier "Screen0"

Device "Card0"

Monitor "Monitor0"

DefaultDepth 24

[...]

Subsection "Display"

Viewport 0 0

Depth 24

Modes "1280x1024"

EndSubSection

EndSection

le faite de changer de version "X11R7.3" peut il changer quelque chose sachant que j'utilise "X11R6"?

http://xorg.freedesktop.org/archive/X11R7.3/doc/RELNOTES.txt

Share this post


Link to post
Share on other sites

 redhat_base-8.0p9.tgz (Linux compatibility package based on RedHat 8.0) ou fedora_base-4.0p2.tgz (Linux compatibility package based on Fedora Core 4)?

A faire fonctionner des applications dédier normalement pour fedora ou redhat !

Dans mon exemple si je veux utiliser Opera je dois utiliser (emulators/fedora/base) + le packetage d'Opera .

Required to run:
[emulators/fedora/base]
Required to build:
[archivers/bzip2]

Share this post


Link to post
Share on other sites

Ah ouais... quand même... tu n'étais pas obligé de copier les lignes commentées (celles qui commencent par #) :francais: ...

Bon, a priori, j'aurais tendance à dire: rien de choquant...

Alors, pour commencer, tu es sûr que ce sont les bonnes fréquences de rafraîchissement? Comme je te l'ai dit, tu peux vérifier les modes supportés dans le /var/log/Xorg.log.0 (c'est un peu le bordel, mais bon... au pire, tu peux aussi voir les éventuelles raisons de pourquoi ça plante dans ce fichier... éventuellement lancer X.org avec le logging en temps réel, mais je ne me souviens plus de comment on fait... faut dire que ça fait longtemps que je n'ai pas eu de hard-lock de X.org... enfin, toi, ça n'a pas l'air d'être du hard-lock, mais juste un affichage noir, donc, bon, pas forcément pertinent de tester le log en temps-réel)... j'aurais tendance à dire que X.org essaye d'envoyer un modeline non supporté si ça marche avec un autre écran... c'est très probable...

Autre question: pour le Bus "PCI :1:0:0", c'est le bon id PCI (a priori oui, si ça marche au moins avec le driver vesa)? Tu devrais pouvoir vérifier avec lspci (je crois que c'est ça aussi sous OpenBSD, mais ça fait longtemps... pardon si c'est une autre commande, mais l'idée est là)...

Sinon, jette un coup d'oeil ici: man radeon ...

Tu peux éventuellement commenter les fréquences de rafraîchissement et rajouter Option "DDCMode" "true" dans la section device... ça forcera X.org à utiliser les modelines supportés par ton écran en fonction de la résolution demandée (si elle est supportée, bien sûr)...

Sinon, tu peux essayer différentes combinaisons de Option "MonitorLayout" (m'enfin, en mono-écran, je n'en ai jamais eu besoin)...

Après, pour la question sur X.org 6.x ... euh... tu es sûr que tu utilises une série 6 de X.org? Ca date pas mal, maintenant, quand même... après, si tu dis ça parce que tu as des répertoires /usr/X11R6, ne t'inquiète pas, ça n'a pas forcément de rapport avec ta version de X.org... il y a plein de distro dans lesquelles les répertoires ont toujours cette forme alors qu'elles ont des X.org 7... c'est juste pour ne pas casser les fichiers de config à l'upgrade de la 6 à la 7... compatibilité ascendante, quoi...

Autrement, de toute façon, pour les radeons, pas d'intérêt à passer à X.org 7.3 aussi vite que possible: en effet, le driver radeon stable de la release n'a pas été mis à jour pour la 7.3... plein de boulot sur le driver avivo oblige... donc, a priori, tant que tu as une version 7 de X.org (fût-ce la 7.2), pas vraiment d'intérêt à t'emmerder à passer à la 7.3 si les paquets stables ne sont pas encore dispos (ce qui serait étonnant vu la fraîcheur du truc)...

Ah oui, juste un truc... si tu veux simplifier ta section ServerLayout, vu que tu n'utilises qu'un écran (et qu'une seule section screen), tu peux remplacer :

 Sreen 0 "Screen0" 0 0

par :

 Sreen "Screen0"

Le "Viewport 0 0" de la sous-section Display est aussi facultatif...

Share this post


Link to post
Share on other sites

Aefron,

si j'en suis mon raisonnement pour l'exemple d'Opera je peux peut être donc installer en mode root:

#sh ati-driver-installer-8.40.4-x86.x86_64.run

par une base fedora ou redhat, ca devrait fonctionnait sans compiler

ton avis m'intéresse?

Share this post


Link to post
Share on other sites

Oui mais non... le driver ati en question (fglrx), c'est un module qui ne marche que pour certaines versions bien particulières du noyau Linux, dont il est un module... même en restant sous linux, un simple changement d'API du noyau le casse...

... la couche de compatibilité OpenBSD, c'est pour les programmes userland (et encore... genre, à l'époque où j'avais essayé, je voulais essayer d'installer un node freenet, ce qui suppose d'avoir du java... impossible à faire fonctionner... bon, il paraît que ça a progressé depuis, ceci dit)... pas pour les bouts de kernels en modules en plein kernelland... rien qu'au niveau de l'API, le kernel OpenBSD ne saurait pas bien quoi en faire...

En plus, les drivers proprios sous OpenBSD :francais: ... ne rêve pas non plus... ni les fabriquants, ni les devs OpenBSD ne feront le plus petit strict moindre effort pour que ça arrive, même dans un autre multivers (ou alors, foutrement vicié, l'autre multivers)...

Franchement, pour moi, ton problème est un problème de modeline non supporté par ton écran (vu que tu as dit que le driver libre marchait avec un autre écran)... ou éventuellement de sortie numérique vers ton écran (auquel cas, MonitorLayout devrait résoudre le problème)...

Share this post


Link to post
Share on other sites

×
×
  • Create New...