Jump to content

[LOGICIEL] Player flash fait planter Opera


Rakkeur

Recommended Posts

Bonjour, voila, ca fait bien 15 jours que dès que je lance une annimation Flash, ca plante :

erreur%20opera.gif

Le fichier NPSWF32.dll incriminé correspond au plugin flash.

Donc après moult desinstallation/installation du flash player et installation/reparation/desinstallation d'Opera 9.01 entrecouper de nettoyage de la base de registre, je déprime et me tourne vers les connaisseurs qui sauront surment me conseiller.

J'ai aussi essayer de remplacer le fichier NPSWF32.dll par des versions plus ancienne, mais je l'ai fait que pour le plugin de Opera.

Autrechose: pour les pubs et meme sur http://www.sports.fr, ca marche sans problème, je crois. Les problèmes apparaisent pour les sites du type daylimotion, youtube, google video et tv.yahoo ( quand il y a du flash ) et uniquement lorsque je veux les visualiser directement.

Config : Windows XP SP2 , Opera 9.01, Adobe Flash Player 9.0.16 , Firefox, Thunderbird, . . . sur un pc portable avec CG ATI 9100 IGP :s

PS: je sais qu'il y a une centralisation Opera :chinois: mais je pense que ca concerne plus Flash que Opera, vu que personne n'en parle nullepart, sur les forums d'opera.

Link to comment
Share on other sites

:francais: Merci mais en fait, le problème est ailleurs.

Avant de poster, j'avais fait un scan avec Ad ware qui n'avait rien desceler de particulier.

Depuis j'ai fait un scan avec Spybot qui m'a trouver entre autre la saloprie qui s'appelle "Magic control" réputé comme étant responsable de crash de flash.

Donc je l'ai virer, mais il parait que c'est tenance.

Donc je suis en cours de desintoxication: il n'apparaiçait plus dans le scan Spybot mais j'ai quand meme un doute vu que Opera a planté depuis.

Je m'en vais re desinstaller/installer Flash.

PS: je garde la build sous le coude. On sais jamais. Merci.

Et ca marche sous FF et IE, du moins à chaque fois que j'ai essayé.

Link to comment
Share on other sites

Ah, ca a lair de marcher !

Google video et Youtube n'ont pas fait planter Opera!

Reste Dailymotion, mais là il faut windows media player ou Quiktime, d'après la FAQ. N'empeche que c'est toujours le meme fichier qui est en cause.

Ca doit être une farce d'Opera, ou un mauvais réglage.

Je vais me renseigner pour savoir comment regler ces plugins .

PS: MAJ de windows en cours, juste les logiciels facultatifs comme Framework. Y a un truc qui s'appèle Windows media connect 2.0. Ca vient peut êtr de là.

Et pour ceux qui aurait le meme problème, j'ai aussi fait un scan par Ewido en mode sans echec.

Link to comment
Share on other sites

J'ai crier Victoire trop tot. :D

En fait, je crois que le problème est plus profond : j'ai la mule qui plante aussi ( la finale 0.47b est sortit :D ) Avant je croyais que c'était parce que c'était une beta, mais non !

Je doit avoir un problème dans les dll. ntdll ou kernel32 voir plus loin.

J'ai bien essayer de remettre un ntdll.dll trouvé sur le net. Mais j'ai eu bien du mal vu que c'est un fichier utiliser en permanence.

Donc je pense à reparer

Edit : Scan sfc /scannow en cours.

Vous avez des astuces sur la réparation windows autre que ici.

Link to comment
Share on other sites

J'ai dega fait et interprété par moi meme grace à une page web qui explique.

RAS. :ouioui:

Spybot ne trouve rien non plus.

Le sfc n'a rien changer, sauf détruire mon thème Vista Inspirate.

Edit: j'ai bien une saloperie encore : j'ai lancer IE pour faire un scan Hijackthis en ligne et la , une boite de dialogue pour me m'inviter à installer WinAntiSpyware :non:

Je deteste ces saloperies ! :transpi:

Link to comment
Share on other sites

fait.

Il me semble que SmitfraudFix n'a rien trouvé et corrigé.

Le Host est restauré.

Je n'est plus les boites de dialogue qui m'invite à installer WinAntiSpyware Pro 2006, mais j'ai toujours des pubs de temps en temps ( avec IE uniquement ). Casino, sites de ventes, voir des choses plus affriolantes.

Le titre de la fenètre commence toujours par un ~ puis http://

Autre chose : Kerio me signale que quelqu'un essaye de se connecter à mon PC via avast. :s En général, c'est une ip francaise.

De toute manière, je vais faire un formatage un de ces jours, pour remettre tout ca en état.

Question : J'ai 3 partitions ( hors Linux)

une pour windows et quelques données sur le bureau

une pour les programmes ( Program files)

une pour les données

Si je veux me débarraser de ces trucs, es ce que formater la première suffit, ou il est préférable de supprimer les 2 suivantes ?

Link to comment
Share on other sites

Merci

Enfin, je sais pas si je dois dire merci :yes:

J'ai fait ce que t'as dit pour HijackThis et Clean 1.4

Mais tu pourrais prevenir pour Clean1.4 : il m'a virer bien 7 Go d'archive , fichiers iso, srt, . . irrécupérable.

En plus, il a virer un certain NTDRL, je crois, ce qui fait que windows ne pouvait plus redémarrer.

( là j'ai été con, j'aurais du utiliser la console de recup )

J'ai reinstaller par dessus, récupérer ce que j'ai pu.

là, je vais sauver ce que je peux et formater. ( heureusement, qu'il y a un log )

Au moins j'aurais une installation propre, mais plus un fichiers de configuration. :byebye:

Voilà, fin du problème :transpi:

Link to comment
Share on other sites

Pourtant c'est le cas.

Je sais pas comment ca marche :

J'ai pas fait exactement comme tu as dit :

je l'ai mis dans les racines de C: et E: et je l'ai exécuté sur les 2.

Ce log était sur E:

http://www.yousendit.com/transfer.php?acti...1B262F6768C1517

Windows était installé sur C: Après passage de Clean, le dossier windows pessait dans les 200 Mo.

Edit: je viens de repenser a un truc ( c'est plus très clair dans ce que j'ai fait )

Je crois que j'ai fait un " clean /? " pour savoir les options qui était possible.

Peut être que le /x permet de spécifier le type de fichiers à supprimer. ce qui m'a fait uns suppression totale.

J'ai pas trouvr de mode d'emploi sur le net.

Link to comment
Share on other sites

Sans doute un problème matériel qui a fait disjoncté Clean ... :zarb:

ligne017 Fichier supprim‚ - C:\$tmp$.tm$ >>> pas normal cette ligne .

Je préviens FRUiT , il passera voir ça .

C'est là : http://www.ratiatum.com/forum/index.php?showtopic=50474

Peut être que le /x permet de spécifier le type de fichiers à supprimer. ce qui m'a fait uns suppression totale.

Tu as tapé clean /x ou clean /ini dans la console ?

Link to comment
Share on other sites

Ouais, pour ma part, je serai pas dispo trop souvent, car voyage à Paname + rentrée + reinstalle de windows.

Donc, voilà, vous impatienté pas pour que je réponde. :s

Désolé de m'etre un peu enervé. J'avais pas réaliser que ca pouvais être un bug ou autre chose.

:zarb:

Edit : pour C: j'avais fait

clean /?

qui m'a retourner je ne sais plus quoi

et ensuite, si il n'a pas fait le nettoyage, j'ai fait clean /ini

( je me souviens plus trop: je regardais le grand prix a la tv en meme temps et depuis, j'ai fais plein de truc :byebye: )

Jamais de clean /x, c'était pour l'exemple.

J'ai vu le mode d'emploi depuis que j'ai tapé ca. Je pense pas que ca ait pu causé quoi que ce soit.

Link to comment
Share on other sites

C'est une erreur exceptionnelle qui se produit dans clean.cmd... C'est la deuxième fois que ça arrive...

Désolé pour ton disque, sincèrement...

JE vais étudier ce problème de près mais j'ai peu de pistes...

Saurais-tu me dire si tu sollicitais ton disque de manière particulière ou soutenue pendant que tu as exécuté clean ? par exemple des transferts de fichiers ou une finalisation importante emule... Je sais bien que c'est pas facile de se souvenir, c'est loin, et t'es surement fâché mais si tu vois la moindre piste ça pourrait aider... Et si tu pouvais également préciser un peu les caractéristiques techniques du disque en question, genre si c'est un SATA, la marque, son age, si c'est un disque compressé ou partitionné, etc...

:(

Link to comment
Share on other sites

Salut, je vais la faire courte car je suis pas chez moi.

En tout cas, c'est pas trop grave en fait : c'est surtout des données peu importantes. Ce qui m'ebète le plus c'est la configuration des programmes. Sinon, comme tu peux le lire plus haut, j'avais l'intention de formater . C'est chose faite.

Niveau config :

sur un pc portable 60 GO marque samsung, partitionner en 4 partitions, C: est en NTFS .

J'ai aussi Linux d'installé. j'avais aussi un fichier appelé $tmp$.tm$ sur E:

Niveau activité : il se peut que j'était en train de manipuler des fichiers à la racine, soit pour les transferer vers d'autres partitions soit les supprimer ( pas les mettre à la corbeille, suppression directe ), mais je sais plus trop.

Voilà, sinon je viens de m'appercevoir que j'ai contaminer le pc avec lequel j'ecris, avec ma clé USB. Et d'ailleurs, il se peut que ce soit ma clé qui ai amener ca sur mon pc.

Comment je m'en débarrase ? :D Analyse antivirus sur la clé n'a rien donnée.

Link to comment
Share on other sites

C'est pas bien dur de remettre grub... :chinois:

Au cas où tu n'aurais pas trouvé mais j'en doute...

Suffit que tu prennes une distrib live CD avec grub-install (knoppix, *ubuntu, ...).

Tu montes ta partoche avec /boot/.

Et un coup de :

grub-install --root-directory=<là_où_est_monté_/boot> /dev/<tondd_hda_hdb_sda_sdb...>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...