Jump to content

Probleme De Filesystem Et D'encodage


Recommended Posts

Bonjour,

J'ai un souci, j'ai suivi les explications indiquées ici :

http://doc.ubuntu-fr.org/installation/partitions_windows

Malheureusement, ma partition windows a des fichiers avec accents. Ces fichiers sont reconnus avec des bons accents sous windows XP.

Mais sous linux, sous Konsole en UTF-8 pour l'affichage, ces accents sont remplacés par des "?". Si je créé un repertoire nommé "gérard", un ls l'affichera tel quel "g?rard".

Sous konqueror, dans les options Polices > encodage, j'ai mis utf8. Je vois les accents de mes dossiers créé avec mkdir. Par contre, je ne vois qu'un carré blanc a la place des accents des repertoires créé sous windows.

Mais un ls sous la console (tty1) ou sous Konsole m'affiche des ? a la place des accents.

Mes variables d'env sont telles quelle :

$LANG=fr_FR.UTF-8

$LANGUAGE=fr

S'il vous plait, pas de solutions : pas d'accents dans les noms de fichiers ou de repertoires. Merci.

Je ne peux pas faire autrement, ces fichiers ne sont pas a moi et je dois bosser dessus. Aucune envie de tout renommer a la main.

tuXXX m'avait indiqué une commande pouvant faire ca automatiquement (passer les noms de fichier d'un encodage a un autre (ivconv je crois)). Seulement, apres les accents snt lisible sous linux, mais plus sous windows.

Bref je voudrais connaitre l'option de mount kivabien pour que les partoches windows fat32 soient visibles correctement avec les accents, et qu'on puisse créer des fichiers avec accent aussi. Et bien sur, que ces fichiers et repertoire soient visibles sous windows sans modifications.

Une idée quelqu'un ?

Link to comment
Share on other sites

Windows utilise l'iso-8159-1 si mes souvenir sont bons, donc essaye de mettre cet encodage sur ta konsole .

Et aussi sur tes variables d'environnement a la place de UTF-8.

Salut,

j'ai eut le meme problème avec des partitions en fat32 à mes débuts. Dans mon cas c'était juste un problème sur la définition du point de montage. Dans le tuto que tu as donné, ils en parlent aussi : iocharset=utf8 . Par exemple :

/dev/hdb1 /media/documents vfat rw,user,auto,exec,gid=100,uid=1000,umask=002,iocharset=utf8,codepage=850

Fais bien attention, certaines options en annulent d'autres, pour plus de détails: man mount

Link to comment
Share on other sites

Windows utilise l'iso-8159-1 si mes souvenir sont bons, donc essaye de mettre cet encodage sur ta konsole .

Et aussi sur tes variables d'environnement a la place de UTF-8.

Le but de ma manoeuvre c'est déviter ce genre de manip. Je souhaite que mon environnement linux reste en UTF-8 mais puisse lire les partoches fat qui sont en iso.

De meme mon windows, je peux pas le modifier, et donc il restera en iso-8859-1.

Styx2, j'ai essayé ce qui y'avait marqué dans le tuto, mais ca ne fonctionne pas chez moi. Et j'avais déjà assez bien regardé le man de mount auparavant.

Si jamais chez toi ca marche impec, tu peux me détailler ta config ? (genre LANG, LANGUAGE, config d'encodage de ta console/explo, fstab, etc)

Merci

Link to comment
Share on other sites

Désolé, c'est les vacances et j'ai pas mon pc.

De tête c'est configuré comme un pc français (locales-fr, clavier français...), je n'ai rien touché d'autre que mon fstab (du moins pour ce problème).

Les options doivent ressembler à quelque chose comme : user,noauto,exec,iocharset=utf8

(attention à ne pas mettre de s à la fin de user :censored: )

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...