Jump to content

Archived

This topic is now archived and is closed to further replies.

Mephisto

deb sarge

Recommended Posts

Bonjour

toujours pour sarge, une petite question existentielle :

je tente d'installer le wifi sur mon acer aspire 5002

je le fais donc via un howto, et il me demande de télécharger les headers (bon, c'est un howto ubuntu, alots c'est apt-get install linux-headers-[version], mais sous deb, je suppose que c'est apt-get install kernel-headers-[version])

quand je tape uname -r, j'ai 2.6.8-2-386, et quand je fais apt-cache search kernel-headers, je me retrouve avec plusieurs versions, mais pas la mienne (la plus proche serait la 2.6.8-3)

y a-t-il donc une mise à jour que je n'ai pas faite ? (apt-get update ou upgrade me renvoient que ma version est à jour) que puis-je faire ?

et pendant que j'y suis, sachant que je ne trouve pas de howto pour l'installation du wifi sous deb avec un aspire 5002, quel howto (autre distrib et/ou PC) me conseilleriez-vous de suivre ?

Merci :keskidit:

Share this post


Link to post
Share on other sites

Salut

pour mettre un kernel a jour :

apt-get dist-upgrade :)

a+

Share this post


Link to post
Share on other sites

nan, il ne me fait rien

(et d'ailleurs, dist-upgrade, c'est pas uniquement pour les changements genre sarge -> etch ?)

Share this post


Link to post
Share on other sites
nan, il ne me fait rien

(et d'ailleurs, dist-upgrade, c'est pas uniquement pour les changements genre sarge -> etch ?)

Salut

Non c'est aussi pour les mise a jours critiques .

On va pas mettre a jour un kernel comme ça a l'arache :) .

Meme si ça se passe generallement bien :) .

a+

Share this post


Link to post
Share on other sites

dist-upgrade c'est exactement comme upgrade sauf que les paquets ne sont pas forcément installés dans l'ordre donné (et qu'il peut supprimer des paquets si il le faut)...

Sinon j'ai rarement vu un couple noyau+headers avec la même version sous debian, y'a toujours un problème... :D

Share this post


Link to post
Share on other sites

Pour avoir les headers de version récentes, il faut faire apt-get install linux-headers. :D

Share this post


Link to post
Share on other sites
dist-upgrade c'est exactement comme upgrade sauf que les paquets ne sont pas forcément installés dans l'ordre donné (et qu'il peut supprimer des paquets si il le faut)...

Sinon j'ai rarement vu un couple noyau+headers avec la même version sous debian, y'a toujours un problème... :transpi:

Salut

Non, non, tu peux tres bien mettre a jour ta distrib avec apt-get update et ne pas mettre a jour ton kernel .

il y quelques paquets qui nécessite de faire apt-get dist-upgrade .

Sinon pour les headers et les versions, tu es un peu mauvaise langue :) .

Moi ça a toujour marché .

a+

Share this post


Link to post
Share on other sites

je tente d'installer le wifi sur mon acer aspire 5002

je le fais donc via un howto, et il me demande de télécharger les headers (bon, c'est un howto ubuntu, alots c'est apt-get install linux-headers-[version], mais sous deb, je suppose que c'est apt-get install kernel-headers-[version])

quand je tape uname -r, j'ai 2.6.8-2-386, et quand je fais apt-cache search kernel-headers, je me retrouve avec plusieurs versions, mais pas la mienne (la plus proche serait la 2.6.8-3)

bonsoir,

dans un premier temps, tu peux suivre ce tutorial :

http://www.erlepereira.com/node/11

regarde là aussi

http://people.via.ecp.fr/~alexis/formation-linux/

je pense que ça peut t'aider :)

pour la 2.6.8-2-386, tu peux faire ceci :

apt-get install kernel-image-2.6.8-2-386

apt-get install kernel-headers-2.6.8-2-386

apt-get install kernel-source-2.6.8

bon courage :p

sunfun ;)

Share this post


Link to post
Share on other sites

Salut

sauf que le ipw2200 c'est pour le centrino pas pour le broadcom .

a+

Share this post


Link to post
Share on other sites

Salut

sauf que le ipw2200 c'est pour le centrino pas pour le broadcom .

a+

+1 pour zoto :keskidit:

ipw2200 est uniquement pour le centrino

sunfun :gne:

Share this post


Link to post
Share on other sites

ok....

Etch tournje avec quel noyau ?

ce noyau me permettrait-il de régler mon problème ?

et, y a-t-il un moyen de passer sous Etch sans planter le système comme à ma dernière tentative en changeant les sources de l'apt-get ?

Share this post


Link to post
Share on other sites

Salut

La j'ai 2.6.16 et ça marche bien :) .

Donc fait comme tu le sent, mais il tourne bien aussi :).

a+

Share this post


Link to post
Share on other sites

pour les versions de noyau, evite les numéros impairs...

passe en etch, franchement ca vaut le coup, tu sera pas coincé!

j'ai passé 3 jours à essayer d'installer ma carte wifi sous sarge...

il m'a fallu 1h en etch...

fonce!

Share this post


Link to post
Share on other sites

j'ai déjà tenté un passage sous Etch

en modifiant la liste des sources, j'ai tout planté (impossible de démarrer le système après la mise à jour)

en intallant avec la NetInstall, j'ai pas tenu 20mns (grub et lilo ne pouvaient pas s'installer, ils ne trouvaient pas le secteur d'amorçage ou un truc du genre)

donc, pour passer à Etch, sachant que la méthode la plus simple soit quand même un petit apt-get, qu'est-ce que j'ai mal fait, pour ruiner le Kernel et me retrouver avec une distribution hybride incapable de booter ?

je vais déjà me chercher un tuto sur gogole...

Share this post


Link to post
Share on other sites

×
×
  • Create New...