Jump to content

[LOGICIEL] [Resolu] Formule excel ..


titi26

Recommended Posts

Bonjour a tous !!

Voila un utilisateur de me boite veut faire document excel ( jusque la ok ) en faisant une somme de telle sorte que :

1+2+3+4 = 4 et pas 10 .. ( vous comprenez ? )

Alors j'ai cru que cette formule fonctionnerai mais non ça marche pas ..

=SOMME(SI(B12:B21="2";1;SI(B12:B21="3";1;SI(B12:B21="4";1;B12:B21))))

Des idées ?

Merci d'avance,

Link to comment
Share on other sites

T as essaye la fonction max ??

Non je n'ai pas essayé ..

En fait j'ai trouvé !

je fais avec une fonction SOMMEPROD ( que je ne connaissais pas .. )

= SOMMEPROD((B12:B21>"")+(B12:B21>0))

j'ai bidouillé et ça fonctionne ..

Merci d'avoir repondu :transpi:

EDIT: Arf .. Merci Noisette c'est exactement ça !! j'ai recherché sur google mais pas sur pci je pensais pas que le probleme avait deja etait evoqué .. :transpi:

=NBVAL(B12:B21) c'est bien plus simple !!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...