Jump to content

[RESOLU]probleme original avec bind


Recommended Posts

Bonsoir la communauté. J'ai un légé, mais curieux probleme avec bind sur mon serveur Arch : tant que mon serveur ne connaitera pas l'équivalence IP d'un serveur (que je peux résoudre via ping), aucun client ne poura faire résoudre.par exmple :

->le client fais ping www.google.fr, pas de résolution

->le serveur ping www.googl.fr, ca résoud

->le client retente, et la ca fonctionne......

une idée ?

Link to comment
Share on other sites

bonjour,

peut-être fallait il au client un peu de temps pour dialoguer avec le serveur dns

et que ce dernier fasse la résolution dns correctement

l'informatique est parfois bizarre comme tu peux le voir :cartonrouge:

sunfun :cartonrouge:

Link to comment
Share on other sites

bonjour,

peut-être fallait il au client un peu de temps pour dialoguer avec le serveur dns

et que ce dernier fasse la résolution dns correctement

l'informatique est parfois bizarre comme tu peux le voir ;)

sunfun :D

non ca métonnerai beaucoup, rien ne fonctionne, ni ping, ni firefox, et jai bo retester c'est pareille

Link to comment
Share on other sites

:byebye:;):chinois:

qui est le serveur DNS de tes clients? Ton serveur?

:chinois::chinois::chinois:

Ben actuellement c'est le serveur de wanadoo, vu que ca ne fonctionne pas, mais sinon mon but est que ca soit a nouveau mon serveur qui soit en serveur DNS.

A signaler que pour la résolution en interne, c'est paramétré nikel, juste le root.hint qui foire, et il foire bizarement. Tant que le serveur DNS n'aura pas résolut lui meme les adresses voulu par le client, ca ne fonctionnera pas...

Link to comment
Share on other sites

bonsoir,

peux-tu nous montrer le contenu de ton fichier /etc/resolv.conf ?

ainsi que le contenu du fichier /etc/bind/named.conf et tous les fichiers de zone que tu as pu créer pour faire ton serveur dns ?

est-ce que ton processus dns est bien démarré ?

peux-tu faire un ps -ef | grep bind ? pour voir si c'est bien démarré ?

bon courage

sunfun :byebye:

Link to comment
Share on other sites

peux-tu nous montrer le contenu de ton fichier /etc/resolv.conf ?

ainsi que le contenu du fichier /etc/bind/named.conf et tous les fichiers de zone que tu as pu créer pour faire ton serveur dns ?

+1
est-ce que ton processus dns est bien démarré ?

peux-tu faire un ps -ef | grep bind ? pour voir si c'est bien démarré ?

Puisque qu'après avoir résolu le DNS directement sur le serveur, ça marche aussi sur les clients, il est lancé.

Il y a surement un truc dans les fichiers de zone ou dans la configuration.

Que donne nslookup avec un client avant et après l'avoir fait sur le serveur ? Que donne le nslookup sur le serveur ?

Link to comment
Share on other sites

peux-tu nous montrer le contenu de ton fichier /etc/resolv.conf ?

ainsi que le contenu du fichier /etc/bind/named.conf et tous les fichiers de zone que tu as pu créer pour faire ton serveur dns ?

+1
est-ce que ton processus dns est bien démarré ?

peux-tu faire un ps -ef | grep bind ? pour voir si c'est bien démarré ?

Puisque qu'après avoir résolu le DNS directement sur le serveur, ça marche aussi sur les clients, il est lancé.

Il y a surement un truc dans les fichiers de zone ou dans la configuration.

Que donne nslookup avec un client avant et après l'avoir fait sur le serveur ? Que donne le nslookup sur le serveur ?

tout a fais je pense aussi que ca vient d'un parametre a la con qui doit trainer.

je vous balance les quelques fichiers de config (je présise que j'ai essayer d'utiliser les fichiers de config d'origine de ArchLinux)

[root@serveur ~]# cat /etc/named.conf

//

// /etc/named.conf

//

options {

directory "/var/named";

pid-file "/var/run/named/named.pid";

auth-nxdomain yes;

datasize default;

allow-recursion { 127.0.0.1; };

};

zone "localhost" IN {

type master;

file "localhost.zone";

allow-update { none; };

allow-transfer { any; };

};

zone "0.0.127.in-addr.arpa" IN {

type master;

file "127.0.0.zone";

allow-update { none; };

allow-transfer { any; };

};

zone "." IN {

type hint;

file "root.hint";

};

zone "casalinux.net" IN {

type master;

file "db.casalinux.net";

};

zone "0.168.192.in-addr.arpa" {

type master;

file "db.192.168.0";

};

logging {

channel xfer-log {

file "/var/log/named.log";

print-category yes;

print-severity yes;

print-time yes;

severity info;

};

category xfer-in { xfer-log; };

category xfer-out { xfer-log; };

category notify { xfer-log; };

};

[root@serveur ~]# cat /var/named/root.hint

; Fichier de zone des serveurs root

; A vérifier et à maintenir réguliérement

. 6D IN NS A.ROOT-SERVERS.NET.

. 6D IN NS B.ROOT-SERVERS.NET.

. 6D IN NS C.ROOT.SERVERS.NET.

. 6D IN NS D.ROOT-SERVERS.NET.

. 6D IN NS E.ROOT-SERVERS.NET.

. 6D IN NS F.ROOT.SERVERS.NET.

. 6D IN NS G.ROOT-SERVERS.NET.

. 6D IN NS H.ROOT-SERVERS.NET.

. 6D IN NS I.ROOT.SERVERS.NET.

. 6D IN NS J.ROOT-SERVERS.NET.

. 6D IN NS K.ROOT-SERVERS.NET.

. 6D IN NS L.ROOT.SERVERS.NET.

. 6D IN NS M.ROOT.SERVERS.NET.

A.ROOT-SERVERS.NET. 5w6d16h IN A 80.10.246.3

B.ROOT-SERVERS.NET. 5w6d16h IN A 128.9.0.107

C.ROOT-SERVERS.NET. 5w6d16h IN A 192.33.4.12

D.ROOT-SERVERS.NET. 5w6d16h IN A 128.8.10.90

E.ROOT-SERVERS.NET. 5w6d16h IN A 192.203.230.10

F.ROOT-SERVERS.NET. 5w6d16h IN A 192.5.5.241

G.ROOT-SERVERS.NET. 5w6d16h IN A 192.112.36.4

H.ROOT-SERVERS.NET. 5w6d16h IN A 128.63.2.53

I.ROOT-SERVERS.NET. 5w6d16h IN A 192.36.148.17

J.ROOT-SERVERS.NET. 5w6d16h IN A 198.41.0.10

K.ROOT-SERVERS.NET. 5w6d16h IN A 193.0.14.129

L.ROOT-SERVERS.NET. 5w6d16h IN A 198.32.64.12

M.ROOT-SERVERS.NET. 5w6d16h IN A 202.12.27.33

le reste je pense pas que ce soit interessant mais dans le doute

[root@serveur ~]# cat /var/named/db.192.168.0

$TTL 864000

@ IN SOA casalinux.net. root.casalinux.net. (

20000

3600

900

1209600

44200

);

@ IN NS dns.casalinux.net.

@ IN MX 10 dns.casalinux.net.

chat IN A 192.168.0.1

serveur IN A 192.168.0.1

arenib.ath.cx. IN A 192.168.0.1

damunix-port IN A 192.168.0.2

chantal IN A 192.168.0.3

damunix-fice IN A 192.168.0.6

olivier IN A 192.168.0.5

si vous en voulez dotre je vous les fournirai

Link to comment
Share on other sites

ou ca ? sur le client ou sur le serveur ?

bonsoir,

les nslookup, tu peux les faire aussi du serveur que du client

le but est de vérifier que ton serveur dns répond bien aux requetes dns que tu lui envoies :yes:

question : peux-tu nous envoyer ton fichier /etc/bind/db.casalinux.net stp ??? ;)

je crois que tu te trompes de fichier

quand tu fais un cat /etc/bind/db.192.168.0, tu dois normalement avoir des résolutions inverse dans le fichier

c'est à dire que des adresses IP correspondent à des noms

là visiblement tu nous montres le contraire, et le fichier que tu nous envoies doit normalement être /etc/bind/db.casalinux.net

et puis dans ton fichier /etc/bind/db.192.168.0, pour les résolutions inverses, tu dois juste avoir le dernier bit de ton adresse ip mentionné ainsi que le nom dns associé

par exemple

1	 IN	 A	 www.casalinux.net

essaies de changer ça et tiens nous au courant

bon courage :byebye:

sunfun :oops:

Link to comment
Share on other sites

ou ca ? sur le client ou sur le serveur ?

les nslookup, tu peux les faire aussi du serveur que du client

Et je rajouterai même aussi bien sur du Linux que sur du Windows.

Sinon relis mon post, je t'ai bien dis de faire les deux... :oops:

je crois que tu te trompes de fichier

quand tu fais un cat /etc/bind/db.192.168.0, tu dois normalement avoir des résolutions inverse dans le fichier

c'est à dire que des adresses IP correspondent à des noms

[...]

et puis dans ton fichier /etc/bind/db.192.168.0, pour les résolutions inverses, tu dois juste avoir le dernier bit de ton adresse ip mentionné ainsi que le nom dns associé

Houla, mouerf... Effectivement il y a un petit soucis... ;)

Sinon, il ne faut pas mettre n'importe quoi non plus en inverse... Si tu mets juste le dernier bit, il faut mettre avant :

$ORIGIN 0.168.192.in-addr.arpa.

et là effectivement tu devras juste mettre le dernier bit de l'ip.

D'ailleurs, c'est

1      IN      PTR      www.casalinux.net

qu'il faut mettre normalement non ?

Link to comment
Share on other sites

:yes:

Bon s'en est où sinon ? :transpi:

Si ça ne marche toujours pas mieux, as-tu tenté les nslookup comme demandé ? :transpi: :transpi:

oui bien sur, je te copie ca de suite.

Voila mes résultats :::

Sur le client

[damunix@damien-port ~]$ nslookup

> google.fr

;; connection timed out; no servers could be reached

> google.fr

Server: 192.168.0.1

Address: 192.168.0.1#53

Non-authoritative answer:

*** Can't find google.fr: No answer

> serveur

Server: 192.168.0.1

Address: 192.168.0.1#53

Name: serveur.casalinux.net

Address: 192.168.0.1

> damunix

Server: 192.168.0.1

Address: 192.168.0.1#53

Non-authoritative answer:

*** Can't find damunix: No answer

> damunix.casalinux.net

Server: 192.168.0.1

Address: 192.168.0.1#53

sur le serveur ::::

[root@serveur ~]# nslookup

> google.fr

Server: 80.10.246.130

Address: 80.10.246.130#53

Non-authoritative answer:

Name: google.fr

Address: 216.239.59.104

Name: google.fr

Address: 216.239.39.104

Name: google.fr

Address: 216.239.57.104

> damunix

Server: 127.0.0.1

Address: 127.0.0.1#53

** server can't find damunix: NXDOMAIN

> damunix.casalinux.net

Server: 127.0.0.1

Address: 127.0.0.1#53

** server can't find damunix.casalinux.net: NXDOMAIN

> serveur

Server: 127.0.0.1

Address: 127.0.0.1#53

en meme temps heureusement que le serveur peut résoudre, vu que nimporte comment il intéroge le serveur DNS de wanadoo

Link to comment
Share on other sites

//
// /etc/named.conf
//

options {
	directory "/var/named";
	pid-file "/var/run/named/named.pid";
//		auth-nxdomain yes;
//		datasize default;
//		allow-recursion { 127.0.0.1; };
	forwarders {
			80.10.246.2;
			80.10.246.129;
	};
};


/******* Configuration des zones. *******/
// Zone locale.
zone "localhost" {
	type master;
	file "localhost.zone";
	allow-update { none; };
	allow-transfer { any; };
};
// Zone locale inverse.
zone "0.0.127.in-addr.arpa" {
	type master;
	file "127.0.0.zone";
	allow-update { none; };
	allow-transfer { any; };
};


// Zone internet.
zone "." {
	type hint;
	file "root.hint";
};


// Zone réseau.
zone "casalinux.net" {
	type master;
	file "db.casalinux.net";
};
// Zone réseau inverse.
zone "0.168.192.in-addr.arpa" {
	type master;
	file "db.192.168.0";
};




/******* Configuration des logs. *******/
logging {
	channel xfer-log {
			file "/var/log/named.log";
			print-category yes;
			print-severity yes;
			print-time yes;
			severity info;
	};
	category xfer-in { xfer-log; };
	category xfer-out { xfer-log; };
	category notify { xfer-log; };
};

Tente comme ça. J'ai juste rajouté les forwarders (qui correspondent à deux DNS Orange™) et commenté trois lignes dans options - elles n'y sont pas dans ma configuration.

Par contre, j'ai aussi :

key "key" {
	algorithm	   hmac-md5;
	secret
"blahhhhhblahhhhhhmacléblahhhhblahhhhhhh";
};

controls {
	inet 127.0.0.1 allow { localhost; } keys { key; };
};

au début, je ne sais pas si ça change grand chose...

Link to comment
Share on other sites

D'ailleurs, c'est

1	  IN	  PTR	  www.casalinux.net

qu'il faut mettre normalement non ?

bonjour cedricpc,

j'arrive un peu tard sur le post :mdr:

il a été résolu, tant mieux :-D

mais en effet c'est bien le dernier bit de l'adresse IP suivi de IN, puis PTR puisque c'est une résolution inverse qui va pointer sur le nom DNS à renseigner dans la barre d'adresses du navigateur ou juste en faisant un ping

:yes:

sunfun :fou:

C'est bon !!! a mon avis cela venais du reroutage via loption fowarders....

merci les gars !!!

bonjour damunix,

qu'est-ce que tu as changé exactement avec l'option forwarders ?

peux-tu nous en dire plus? ça m'intéresse de voir comment tu as fait :yes:

sunfun :-D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...