Jump to content

[LOGICIEL] Mon batch ne fonctionne plus...


.BöD.

Recommended Posts

Hello,

Alors voila, j'ai un batch pour faire mes tests de ping, il ressemble a ca :

@echo off
cls
echo Ping sur le routeur :
ping 192.168.0.1
pause
cls
echo Ping sur Google.fr :
ping www.google.fr
pause
cls
echo Ping sur PC-INpact.com :
ping www.pcinpact.com
pause
exit

Le truc c'est que j'ai formatté et depuis il ne fonctionne plus... J'ai "Ping sur le routeur :" qui boucle sur lui même... :transpi:

C'est windows qui fait n'imp encore... mais comment régler ce prob ?

Link to comment
Share on other sites

Marche bien ...

@echo off

cls

echo Ping sur le routeur :

ping 192.168.0.1

pause

cls

echo Ping sur Google.fr :

ping www.google.fr

pause

cls

echo Ping sur PCInpcat :

ping www.pcinpact.fr

pause

cls

echo Ping sur Free.fr :

ping www.free.fr

pause

exit

Link to comment
Share on other sites

Ce qui est surtout bizarre c'est que si tu fais un drag and drop du batch dans une DOS box, il fonctionne parfaitement.

C'est uniquement si tu le lances depuis une fenêtre Windows qu'il déconne.

Ha ouai, j'avais pas essayé... :roule: Trop bizarre... :reflechis:

Mais bon je vais pas le lancer comme ca chaque fois... :fumer:

Faut trouver d'ou ca viens ce problème. Donc ca marche pas chez moi ni chez K-Lee mais ca marche chez snooky...

Chez moi la config est : XP Pro SP2 à jour, Zone Alarm et Avast...

Mais ca viens forcément de Windows car quand je le lance en double-cliquant dessus, le ping.exe ne demande même pas a se connecter au net...

Quelle est votre config ? :arrow:

Et snooky : Ton code ne se lance pas non plus chez moi...

Link to comment
Share on other sites

Sur le Windows 2000 duquel je vous parle j'ai le même problème que .BöD., en double cliquant sur le batch, il tourne en boucle, on ne voit rien du tout dans la fenêtre de dialogue, si je fais un copier/coller du batch dans la boîte de dialogue il fonctionne correctement, bizarre, j'avais jamais vu ça...

Link to comment
Share on other sites

Ping.exe ???

Renomme le en Ping.bat

Nan... :arrow:

En fait ce que je voulais dire c'est que quand je lance le .bat, normalement il y a Zone Alarm qui me dit "ping.exe veut se connecter au net" et ca je l'ai même pas quand je double-clic sur le .bat... ca veut dire que le code ne va même pas jusque la ligne ping www...

K-Lee : Moi aussi, je sais pas ce qui c'est passé, ca doit provenir des MAJ de microsoft ou je sais pas... :reflechis:

Link to comment
Share on other sites

Oui je les ai bien, si dans l'invite de commande je tape ping pcinpact.com, ping.exe se lance et fait son boulot...

Si dans l'invite de commande je tape le chemin du .bat et que je fais entrée, il fonctionne nickel...

Quand je double-clic sur le .bat, il boucle sur la première instruction... ;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...