Jump to content

démarrer plusieurs clients X avec gdm....


Recommended Posts

Coucou :cap:

ca fait un bail que cet idée est en plan et que j'ai pas trop de temps à y consacrer, donc je viens voir si vous pourriez pas me filer un coup de main

l'idée c'est de démarer en premier un client mono screen sous fluxbox à l'aide de gdm

puis de lancer automatiquement un autre x avec xfce4.4 qui sera en fait mon x courant....

je suis en train de faire quelques tests, mais c'est pas très convainquant, je sais notament pas ou indiquer le lancement du deuxième serveur ( avec /usr/X11R6/bin/X -layout Xinerama :1 ) et comment signifier qu'il doit utuliser xfce 4.4....

un extrait de mon xorg.conf pour comprendre


# **********************************************************************
# ServerLayout sections.
# **********************************************************************

Section "ServerLayout"
Identifier  "Mono"
Screen "Screen 3"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "false"
EndSection

Section "ServerLayout"
Identifier  "Xinerama"
Screen 0 "Screen 1" Absolute 0 0
Screen 1 "Screen 2" Rightof "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "true"
EndSection

si vous avez de idées... :D

Link to comment
Share on other sites

donc je démarre comme il faut flux sur le tty7 en 1280 à partir de gdm

j'arrive aussi à lancer x sur tty8 en xinerama, avec "/usr/X11R6/bin/X -layout Xinerama :1", mais j'ai la croix sur fond gris...

si j'utilise ta commande, ca lance bien xfce mais malgré le :1, ca le lance sur le tty7 :(

et si je mettais un exec startxfce4 dans mon .xinitrc ?.... je teste :D

edit : hmmm, si je lance de tty7 ca déconne mais si je lance de tty1-6, ca marche....

bon reste plus qu'à ce que tout se fasse automatiquement....

edit 2 : si je mets "startxfce4 -- :1" dans mon ./fluxbox/startup, ca me le lance dans tty7 8)

je vois pas comment le lancer automatiquement, juste après le démarrage de ma session flux, de manière à ce qu'il arrive dans le bon tty (8!)

spas pratique tout ca :grrr:

Link to comment
Share on other sites

donc je démarre comme il faut flux sur le tty7 en 1280 à partir de gdm

[...]

si j'utilise ta commande, ca lance bien xfce mais malgré le :1, ca le lance sur le tty7 :(

Heu :chinois:

Tu dis que xfce t'explose ton gdm ?

Il est encore vivant gdm après ?

Link to comment
Share on other sites

ben si je lance à partir d'un terminal dans tty7, ca me met tout par dessus flux sur le tty7, si j'arrète xfce par ctrl^c, je récupére flux qui était visiblement resté en dessous.... et du coup j'explose pas gdm...

si je lance à pertir de tty1 tout marche très bien, mais c'est pas très pratique de se logguer à chaque fois juste pour lancer xfce dans tty8, j'aurai préféré juste avoir à rajouter une ligne à mon .fluxbox/startup pour que ca se fasse automatiquement :chinois:

demain j'essayerai de coller le message d'erreur lors du chargement de xfce, là je peux pas tester OOo compile dans tty8 (je devrai vraiment faire comme lorinc et toujours lancer mes compil en mode texte.... mais j'y pense jamais :transpi: )

Link to comment
Share on other sites

/mode grobill on

tu démarre ton X avec xdmcp activé

(je sais pas faire avec gdm, mais avec kdm, il faut virer le -nolisten et Allow=true dans la rubrique [Xdmcp])

sur le tty8 tu fais un X -query 127.0.0.1 ...

depuis un PC distant sur que ça marche

depuis le localhost, humhum ...

/mode grobill off

certains drivers (ATI :yes: ) prennent mal 2 X ouverts simultanément ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...