Jump to content

[bugS] Ajout de commentaires aux niouses


FiP_

Recommended Posts

Premier bug:

Dans un commentaire de news, j'ai voulu rajouter du faux code html, du genre "<blague></blague>". Afin de ne pas avoir de problèmes d'affichage, j'ai écrit non pas "<" et ">" mais "<" et ">"

Mais malheur! une fois le commentaire affiché, je vois, dans le corps de mon commentaire : "<blague>"... :ouioui: Ni unes ni deux, j'édite mon commentaire, mais dans la zone de texte, le message apparait alors bien: "<blague>" :mdr2: Sans rien changer, je le sauvegarde alors, et seulement à ce moment, j'ai les caractéres < et > qui apparaissent correctement...

:-D

Deuxieme "fonctionalité non documentée":

Toujours dans les commentaires des news, il arrivent que certains répondent à deux, voire trois messages précendants, dans un meme post, ce qui nous donne:

[machin a dit: (...)]

reponse 1

[machin2 a dit: (...)]

reponse 2

[machin a dit: (...)]

reponse 3

Maintenant, si je clique sur "citer" (car je veux répondre à la "réponse 1" du gars, la zone de texte qui apparait alors contient seulement:

[truc a dit: reponse 3] :-D

Link to comment
Share on other sites

"Afin de ne pas avoir de problèmes d'affichage, j'ai écrit non pas "<" et ">" mais "<" et ">""

Qui t'as demandé de faire ça ? On t'as pas demandé de tapper du code html que je sache ! :p

Alors si tu veux écrire "<blague></blague>", tu écris "<blague></blague>" et ça passera très bien. C'est assez logique non ?

Pas trop compris pour les citations, donne un exemple

Link to comment
Share on other sites

Pour les commentaires, pourquoi ne pas commenter la première réponse si c'est à ce post que tu veux réagir.

En gros il veut répondre à ça :

blabla
bleble
blibli

Et il obtient ça :

blibli
son commentaire

Mais bon dans la mesure où la colonne de commentaires n'est pas très large, on peut difficilement se permettre de conserver l'arbre de commentaires avec l'indentation qui va avec...

Link to comment
Share on other sites

truc 1

reponse au truc/

truc 2

reponse au truc 2

truc 3

reponse au truc 3

Maintant quand vous citer dans les commentaire des news vous avez que la réponse du quote3 alors qu'il voulait la réponse du quote1 pour le citer, sa me le fait aussi

Link to comment
Share on other sites

"Afin de ne pas avoir de problèmes d'affichage, j'ai écrit non pas "<" et ">" mais "<" et ">""

Qui t'as demandé de faire ça ? On t'as pas demandé de tapper du code html que je sache ! :mdr:

Alors si tu veux écrire "<blague></blague>", tu écris "<blague></blague>" et ça passera très bien. C'est assez logique non ?

Mea culpa :transpi: J'ai l'habitude des forums mal faits, ou les caracteres speciaux ne sont pas echappés... ^^''

MAIS, le comportement que j'ai observé n'est pas correct: ce que je vois dans le message, les < je devrais les voir dans la zone de texte quand je les édite! Il y a donc bien un moment où la conversion, avec htmlspecialchar() par exemple, n'est pas faite.

Maintant quand vous citer dans les commentaire des news vous avez que la réponse du quote3 alors qu'il voulait la réponse du quote1 pour le citer, sa me le fait aussi

Oui voila c'est ca le "probléme". Ce n'est pas vraiment un bug, je sais bien que c fait pour éviter de se retrouver avec des citations de citations de citations, mais bon. ^^

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...