Jump to content

shorewall rules


Recommended Posts

Bonjour,

J'ai installé et configuré shorewall 2.2.3 sur ma debian 2.6.8 qui sert de passerelle avec 2 interfaces réseau.

Sans lancer shorewall, j'arrive à pinger et me connecter à ma passerelle via ssh depuis le lan et le net sans problème.

Par contre, une fois shorewall démarré : j'ai internet sur le réseau mais je n'arrive plus à accéder à ma passerelle via ssh, ni à la pinger.

Pourtant, j'ai fait plusieurs tests et j'ai l'impression que les règles n'ont pas l'air de fonctionner.

Dans voici la config dans /etc/shorewall, j'y ai mis le strict minimum :

zones:

net Net Internet

loc Local Local Networks

interfaces :

net eth0 detect dhcp,routefilter,norfc1918,tcpflags

loc eth1 detect tcpflags

policy:

loc net ACCEPT

fw net ACCEPT

net all DROP info

all all REJECT info

rules:

ACCEPT loc fw tcp 22

ACCEPT net fw tcp 22

ACCEPT loc fw icmp 8

ACCEPT net fw icmp 8

ACCEPT fw loc icmp

ACCEPT fw net icmp

masq:

eth0 eth1

routedstopped:

eth1 -

Ca doit être quelque chose de bête mais je n'arrive pas à trouver...

Merci pour votre aide....

DibZou.

Link to comment
Share on other sites

Merci pour la proposition TheNastyBoy ... mais j'aimerai comprendre précisement qu'est-ce qui cloche dans la config parce qu'il n'y a pas beaucoup de ligne de config et ca ne marche toujours pas :(

DibZou

Link to comment
Share on other sites

Regarde tes logs, est-ce que tu as les messages de connexion bloquées dans /var/log/messages ?

Essaye d'ajouter la policy suivante:

loc fw ACCEPT

Et regarde dans la conf si il définit bien la zone fw tout seul (c'est une option dans le shorewall.conf il me semble)

Link to comment
Share on other sites

[PROBLEME RESOLU] Merci à toi gauret,

J'ai rajouté les lignes que tu as spécifié et c'est en scrutant les logs que j'ai pu trouver mon erreur : Shorewall:rfc1918:DROP

Donc j'ai enlever l'option dans le fichier interfaces et ça marche !

DibZou

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...