Jump to content

[LOGICIEL] [contourné]Problème de boot: impossible virer lilo


poitou

Recommended Posts

Bonjour à tous

Je m'adresse à vous après plusieurs heures de tentatives infructueuses pour virer lilo.

Au départ, j'avais Grub, et je voudrais revenir à un simple boot windows, avec tout mon dd en ntfs. :p

Mon DD se décompose ainsi :

  • partition 1 : windows NTFS (XP personal)
  • partition 2 : windows FAT32 (données)
  • partition 3 : linux Ext (2 ou 3) (Mandrake 10.0)
  • partition 4 : Swap

J'ai lu les topics consacrés à ce sujet, et j'ai dû essayer tout ce que j'ai trouvé, mais rien ne fonctionne... :dd:

Si je passe par le CD Recovery Windows, puis "réparer", fixboot, fixmbr, je n'ai plus accès à windows...

Si je lance mandrake pour virer lilo, que je fais "lilo -u", j'ai une erreur. Avec "lilo -U", au reboot, lilo se lance ( :p ) et en prime, si je choisis windows, j'ai une groooosse erreur : un tiret qui clignote, tout seul...

J'ai vérifié mon boot.ini, j'avais fait une bêtise hier, en passant par "bootcfg", j'avais ajouté le même une autre fois, mais j'ai corrigé ça, et mon boot.ini est nickel maintenant.

Avec le CD de Mandrake, j'ai tenté "linux rescue", puis j'ai choisi "Restore windows boot loader", et là, c'est pire que tout... il lit quelques bricoles (pas eu le temps de noter...), puis reboote, et continuerait si je ne l'arrêtais pas... :cali:

Des idées ? :sucre:

Merci d'avance à qui pourra m'aider. :francais:

Edit : Je viens de retenter "fixmbr C:" puis "fixboot C:".... j'ai toujours lilo avec cette manip ! Je vais tenter une réinstall propre de Mandrake, et voir où se niche lilo...

Link to comment
Share on other sites

Merci de l'aide. :ouioui:

Ce qu'il y a, c'est que c'est un des premiers sujets que j'avais lus sur la question... :|

J'ai retenté plein de choses cet après-midi : j'ai réessayé "fixboot" et "fixmbr" avec différentes extensions (les /quelquechosederrière, je sais pas quel nom ça porte...) :mad2:

Pis ben, finalement, un petit coup de "System Rescue CD", et j'ai réduit la partition "ext3" avec qtparted... pis j'ai réinstallé mandrake avec grub, et agrandi ma fat32...

Là, je transfère les données sur un dd externe, et je vais repasser la fat32 en ntfs... :fou:

Du coup, tant pis, mais c'est rageant quand même de ne pas pouvoir récupérer les 5 Go dévolus à Linux... Je tenterai de les réduire le week-end prochain. :roll:

EDIT : lilo est dans /dev/hda

Link to comment
Share on other sites

  • 2 weeks later...

si tu a un cd de mandriva sous la main, tu l'insere au boot, tu fait echap ou F1 je sias plus au premier menu du CD ( ne pas faire entrée ce qui lance l'installation ).

Normalement tu a un prompt tu tappe repair puis entrée.

Et dans le menu repair tu peux restaurer soit le boot windows ou l'inverse restauré lilo si windows la ecrasé.

Link to comment
Share on other sites

J'ai déjà testé ça avec le CD d'install de Mandrake... il ne répare pas le boot de Windows...

Je tente un paramétrage de Grub ! (j'ai viré Lilo, déjà...)

______________________________________________________________________________________________

EDIT quelques mois après : finalement j'ai installé Suse et réinstallé et paramétré Lilo... impossible de revenir à windows seul...

M'en vais formater tout ça dès que j'aurai le nouveau PC. :p

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...