Jump to content

[GENTOO] Emerge - general protection fault


Recommended Posts

Bien le bonjour.

Après avoir chercher sur le net, je n'ai pas vraiment réussi à trouver ce que je cherchais, donc je viens ici chercher conseils.

Le problème semble survenir après qu'une compilation ait plantée.

Par la suite, dès que je fais une demande à emerge, il me balance ça :

Feb 18 13:38:58 ko-bahn-gentoo Code: 49 8b 84 24 f0 00 00 00 48 85 c0 0f 84 f2 02 00 00 48 83 78 
Feb 18 13:38:58 ko-bahn-gentoo RIP <ffffffff8017cc55>{__link_path_walk+2181} RSP <ffff81003c815d18>
Feb 18 13:39:16 ko-bahn-gentoo <0>general protection fault: 0000 [3] 
Feb 18 13:39:16 ko-bahn-gentoo CPU 0 
Feb 18 13:39:16 ko-bahn-gentoo Modules linked in: sk98lin tuner tda9887 bttv video_buf firmware_class i2c_algo_bit v4l2_common btcx_risc tveeprom videodev forcedeth i2c_nforce2 eth1394 ata_piix sata_vsc sata_sis sata_sx4 sata_nv sata_via sata_svw sata_sil sata_promise libata sbp2 ohci1394 ieee1394 ohci_hcd uhci_hcd usb_storage ehci_hcd
Feb 18 13:39:16 ko-bahn-gentoo Pid: 17208, comm: emerge Not tainted 2.6.15-gentoo-r5 #1
Feb 18 13:39:16 ko-bahn-gentoo RIP: 0010:[<ffffffff8017cc55>] <ffffffff8017cc55>{__link_path_walk+2181}
Feb 18 13:39:16 ko-bahn-gentoo RSP: 0018:ffff81003c815d18  EFLAGS: 00010202
Feb 18 13:39:16 ko-bahn-gentoo RAX: 0000000000000001 RBX: 0000000000000000 RCX: 0000000000000000
Feb 18 13:39:16 ko-bahn-gentoo RDX: 0000000000013d4c RSI: ffff81002e93d810 RDI: ffff81003c815d38
Feb 18 13:39:16 ko-bahn-gentoo RBP: ffff81000846c019 R08: 0000000000000000 R09: 0000000000000001
Feb 18 13:39:16 ko-bahn-gentoo R10: 000000000000000b R11: 0000000000000000 R12: 00ff81002e93f320
Feb 18 13:39:16 ko-bahn-gentoo R13: ffff81003c815e68 R14: 00000000005af260 R15: ffff81003c815d38
Feb 18 13:39:16 ko-bahn-gentoo FS:  0000000000501ae0(0063) GS:ffffffff8051c800(0000) knlGS:0000000000000000
Feb 18 13:39:16 ko-bahn-gentoo CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 18 13:39:16 ko-bahn-gentoo CR2: 00002aaaadab5008 CR3: 000000001b327000 CR4: 00000000000006e0
Feb 18 13:39:16 ko-bahn-gentoo Process emerge (pid: 17208, threadinfo ffff81003c814000, task ffff81003df34400)
Feb 18 13:39:16 ko-bahn-gentoo Stack: 000000007f0d4100 00000001abb61000 00000004019cffb4 ffff81000846c015 
Feb 18 13:39:16 ko-bahn-gentoo ffff81003e9eacc0 ffff81002e93d810 ffff81002e8ce5c8 ffff81003c815e68 
Feb 18 13:39:16 ko-bahn-gentoo ffff81000846c000 ffff81000846c000 
Feb 18 13:39:16 ko-bahn-gentoo Call Trace:<ffffffff8017d13a>{link_path_walk+186} <ffffffff8017d39c>{path_lookup+380}
Feb 18 13:39:16 ko-bahn-gentoo <ffffffff8017d7be>{__user_walk+62} <ffffffff80177d49>{vfs_stat+41}
Feb 18 13:39:16 ko-bahn-gentoo <ffffffff8017819f>{sys_newstat+31} <ffffffff8010e906>{system_call+126}

Le truc du tainted kernel, de ce que j'en ai lu, ça viendrait d'un pb de licence, donc j'ai commencé à virer les drivers ati (façon j'ai pas encore d'affichage). Mais pas de progrès avec ça.

J'avais aussi vu une histoire où le MAKEOPTS à -j1, mais ça n'a rien fait non plus.

Je pencherais finalement pour un pb de kernel, donc je le recompilerais sans doute ce soir avant de sortir, sauf si le problème se résoud d'ici là (pas mon trip de recompiler le noyau à la recherche du truc qui déconne).

Si quelqu'un pouvait m'aiguiller sur une autre piste, je lui en serais reconnaissant.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...