Jump to content

Archived

This topic is now archived and is closed to further replies.

Footix

Impossible d'installer KDE sur Debian

Recommended Posts

Il a installé xfree 4.3 si je me souviens bien, mùais comment on vérifie en mode commande (le gros écran noir :francais: ) ?

Share this post


Link to post
Share on other sites

dpkg -l | grep free

Et tu as tout bien d'installé ? xfs ? les fonts ? etc ...

Share this post


Link to post
Share on other sites
dpkg -l | grep free

Et tu as tout bien d'installé ? xfs ? les fonts ? etc ...

Alors j'ai bien xfree4.3

Quant à ta question rem, aucune idée !!!

J'ai suivi le tuto de Sentinel pour installer une Debian :francais:

Share this post


Link to post
Share on other sites

moi ce que j'avais aussi installé c'est x-window-system & x-window-system-core et aussi xfonts-100dpi xfonts-100dpi-transcoded xfonts-75dpi xfonts-75dpi-transcoded xlibs et quelques autres mais si mes souvenirs sont bons ce sera dans les dépendances

PS: tu peux aussi connaitre la version que tu as installé ou non d'un package avec apt-cache policy nom_du_package

Share this post


Link to post
Share on other sites

Bon j'ai tout réinstaller le début en suivant pas-a-pas le tuto de Sentienl qui est ici

J'ai donc mis le fichier sources.list qu'il préconise. (en remplaçant pour KDE 3.1.2 par 3.2.2)

Et au moment de faire "aptitude install kde" il me répond "Depends: *(*=kcoloredit, ktimer, kedit...) but it is not installable"

Est-ce que cela peut venir de la configuration de xserver où lors de certaines options je suis pas sûr de ce qu'il faut mettre. J'ai bien xfree 4.3

Merci

Share this post


Link to post
Share on other sites

tu dois etre en unstable, et il y a peut etre un broken package.

Sinon, rester en testing, et effectivement :

apt-get install xfonts-100dpi xfonts-base xfs

Share this post


Link to post
Share on other sites
tu dois etre en unstable, et il y a peut etre un broken package.

C'est à dire ? :keskidit:

J'ai effectivement vue un broken machin trainé y a pas longtemps...

Share this post


Link to post
Share on other sites

Rem, si il a suivi le tuto et qu'il a pris le source.list, il est en stable.

Footix, je ne comprends toujours pas pourquoi ça ne marche pas. Avec mon source.list, j'ai un KDE 3.2.2. De plus, si tu lisais un fois le ReadMe ici tu verrais qu'il te faut les backports. Pour KDE 3.2.2, il te faut un XFree 4.3. Bon, puisque ça ne va pas, mais une fois cette ligne

deb http://www.backports.org/debian stable kernel-2.6 grub samba xfree86

en

comme je l'avais déjà dit et après essaie en faisant un

apt-get install kdebase

Share this post


Link to post
Share on other sites

Erreur quand je rajoute le lien vers blackports :

W : Couldn't stat source package list http://.www.backports.org stable/all Package (/var/lib/apt/www.blackports.org_debian_dists_stable_all_binary-i386_Packages) - stat (2 No such file directory)

W : You may want to update the package lists to correcct these missing files

apt-get install kdebase me donne un broken package

Share this post


Link to post
Share on other sites

vu que c'est un copier/coller je suppose, c'est quoi ce . entre http:// et www.

ça ne sert à rien de faire un apt-get install kdebase si ton apt-get update retourne une erreur...

Share this post


Link to post
Share on other sites

vous feriez mieux de prendre les soucres en testing pour le sources.list, et ensuite de mettre l'ensemble du systeme a jour. C'est une fois de plus une installation salopée à utiliser 1000 sources différentes, avec des sources officieuses bien évidemment, sans aucune connaissance de /etc/apt/preferences .

C'est pour cela que je ne reponds meme plus aux problemes d'apt sur debian, alors que je maitrise parfaitement ce domaine, trop dégouté. C'etait le coup de gueule du jour.

Share this post


Link to post
Share on other sites

:fichegueule: C'est un erreur de frappe bien sûr qu'il y a pas de . après // j'sui pas débile non plus.

Je suis sur Windows car allez sur un forum avec Linux en mode console il me semble que c'est assez balaise donc pas de copier/coller... :modoreussi:

apt-get update marche très bien

Quand à rem je vois pas pourquoi tu t'exites. J'ai suivi le tuto point. Ca marche pas alors j'essaie ce que certains proposent. Alors plutôt que de gueuler sur eux donne ta version de solution possible et le .list qui marche.

Qaund aux installations, elles ne marchent pas donc elles salopent rien :)

Est-ce que ca peut-être un pb de pilotes nvidia (TNT2) ?

Share this post


Link to post
Share on other sites

Tu ne connais pas la priorité que donne apt aux sources, ce n'est pas forcément évident à connaitre au début. Du coup, en multipliant les sources, qui ne sont pas des sources officielles, tu as des packages qui diffèrent de ceux d'origine et on ne sait plus d'ou vient quel package, sa version etc...

Donc, c'est un bordel noir, dans lequel je n'ai pas ernvie de mettre les pattes car je passe mon temps a répeter de rester sur les mirroirs testing officiels, faut pas oublier qu'ils sont fait pas les developpeurs officiels debian, vérifiées avant d'etre rendu public, et qu'ils fonctionnent tres bien sauf parfois pour la Sid qui est un cas particulier.

Faudrait que je reprenne le tuto de sentinel et que je le re-parvours, pour voir s'il n'y a pas de probleme a ce sujet sur son tuto.

Share this post


Link to post
Share on other sites

En supprimant mon sources.list et en faisant apt-setup j'ai réussi à installer kde2.2.2 à partir d'un serveur sur easynet. Mais pas de kde 3.2.2 :transpi:

Share this post


Link to post
Share on other sites

×
×
  • Create New...