Jump to content

Probleme de flan...euh... son avec Alsa sous Linux


Recommended Posts

Bah voilà, j'explique le problème, j'ai compilé les bons drivers en dur dans le kernel, j'ai install alsa-base, j'ai modifié les droits sur /dev/dsp et /dev/mixer et j'ai ajouté mon user dans le groupe audio, mais lorsque j'utilise cet user, le son persiste à ne pas fonctionner... Que faire ? Car lorsque je suis en root, celà fonctionne trés bien ;(.

Si quelqun à une solution, je suis preneur.

Merci beaucoup :)

Edit : je suis sous Debian

Link to post
Share on other sites

extrait de la documentation gentoo

Vérification des fichiers de périphériques

Si vous utilisez DevFS (qui est le défaut d'une installation Gentoo), assurez-vous que le fichier /etc/devfsd.conf possède bien les bonnes permissions pour les périphériques ALSA :

Exemple de code 3.3 : /etc/devfsd.conf

# ALSA/OSS stuff

# Comment/change these if you want to change the permissions on

# the audio devices

LOOKUP          snd          MODLOAD ACTION snd

LOOKUP          dsp          MODLOAD

LOOKUP          mixer        MODLOAD

LOOKUP          midi        MODLOAD

REGISTER        sound/.*    PERMISSIONS root.audio 660

REGISTER        snd/.*      PERMISSIONS root.audio 660

regarde toujours de ce côté :craint:

Link to post
Share on other sites

faut ajouter l'utilisateur standard a utiliser le son... c'est tout !

Pai-mei:~# adduser rem audio
Adding user rem to group audio...
Done.
Pai-mei:~# 

C'est ca qui est genial sous debian, on fait tout tout seul et du coup on comprends comment ca marche ! Regarde un peu le fonctionnement des groupes unix... :francais:

Link to post
Share on other sites
et j'ai ajouté mon user dans le groupe audio,

J'ai déja fait ça. Mais là je pense avoir résolu en partie le problème, j'ai arrété le systeme de son de kde ( je crois que c'est arts qui fout la merde ) et je laisse les applications gérer elles mêmes le son.

Pour récapituler :

- apt-get remove alsa-basa

- apt-get clean ( ouais, bon, on sait jamais ;-) )

- apt-get install alsa-base

- sh /usr/share/alsa-base/snddevices ( ca m'a refait les nodes et tout ;-) )

- amixer set Master 60 unmute

- amixer set PCM 15 unmute

- amixer set Headphone 15 unmute ( important, car j'avais les hauts parleurs branchés sur le portable mais j'entendais rien en sortie alors qu'une fois débranchés, ça crachait )

- chmod 755 /dev/dsp

- chmod 755 /dev/mixer

et je crois que c'est tout :)

Maintenant, ça marche tout bien, sauf que 2 applications ne peuvent pas emettre de son en même temps ( ex : bip de amsn + mp3 de xmms ). Mais bon, je suis quand même super content.

Merci pour vos réponses ;-)

Link to post
Share on other sites

2 applications ne peuvent pas emettre de son en même temps

J'ai deja fait le test en lisant 13 videos simultanement, tout marchait nickel au niveau du son. C'est bizarre que ca ne fonctionne pas, puisque pour moi ton systeme fonctionne partiellement. En totu cas, si ca t'es suffisant, c'est tres bien ainsi et je suis content que ton pb soit resolu.

Link to post
Share on other sites
faut ajouter l'utilisateur standard a utiliser le son... c'est tout !

CODE

Pai-mei:~# adduser rem audio

Adding user rem to group audio...

Done.

Pai-mei:~#

C'est ca qui est genial sous debian, on fait tout tout seul et du coup on comprends comment ca marche ! Regarde un peu le fonctionnement des groupes unix...

Moi c'est le genre de truc qui m'énerverait ....

excuse moi Remy ... :mdr:

Link to post
Share on other sites

l'audio multi-sources ne marchait pas chez moi avec mandrake (noyau 2.4, OSS)

mais avec ma gentoo (2.6, alsa) ... ça marche très bien...

(sauf certaines vielles applis...)

EDIT : je me rapelle aussi que avant j'avais une SB128 et que maintenant c'est l'AC97 de ma CM

Link to post
Share on other sites

ptet parce que c'était 13 divx ?

Non du son, c'est du son. Que ca soit divx, mp3, cda etc... ca doit fonctionner, tant que tu satures pas ton processeur audio ! Ceci etant dit, c'est dur de suivre 13 episodes de friends VO a la fois, mais d'un autre cote, en 1h tu as vu une saison complete ! :iloveyou: ( en fait c'est juste a titre de test )

si chez toi ca marche, pk pas chez moi ?!? ;-)

On est d'accord. Moi je dirais meme : "pourquoi ca ne marcherait pas" quand j'aborde un pb sous linux. Sous windaube, je connais la reponse ! :transpi:

Plus serieusement, moi j'ai un emu10k1 en carte son, avec un alsa propre, pas d'arts ni autres sal... du genre. Peut etre que ca aide ( j'en suis sur ), faudrait voir aussi avec ton chip son ce que ca donne !

Link to post
Share on other sites

J'ai un portable Dell Inspiron 5150, le chipset c'est un "Intel Corps. 82801DB AC'97", la configuration du Kernel ( 2.6.7 ) n'est pas en cause car j'ai pris le .config de quelqun qui a le même portable que moi et dont le son fonctionne trés bien.

J'ai essayé de virer ARTS, mais du coup apt-get veut aussi me virer KDE, ca serait un peu génant tout de même ...

Link to post
Share on other sites

J'ai essayé de virer ARTS, mais du coup apt-get veut aussi me virer KDE, ca serait un peu génant tout de même ...

Il est vraiment genial cet apt ! Ca ne serait pas genant, mais genial ! :francais:

C'est bizarre tout de meme qu'il veuille virer KDE... tu peux me mailer le msg de apt et ta commande stp ? merci

Link to post
Share on other sites
bidule:/usr/src/linux# apt-get remove arts

Reading Package Lists... Done

Building Dependency Tree... Done

The following packages will be REMOVED:

arts kde kde-amusements kde-core

0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.

Need to get 0B of archives.

After unpacking 57.3kB disk space will be freed.

Do you want to continue? [Y/n] n

Abort.

bidule:/usr/src/linux#

Voilà ske ça me dit si je veux supprimer arts.

Link to post
Share on other sites

arts kde kde-amusements kde-core

C'est loin de faire 53,7ko tout ca.... et un ptit conseil, pour etre plus propre, apt-get remove --purge

Mais tuxxx a certainement raison concernant arts, desactive le au profit d'alsa ! ( et moi j'ai raison en disant que kde c'est :ouioui: )

Link to post
Share on other sites

Bah, je sais pas trop comment le désactiver, là j'ai désactivé dans les options du KDE Control Center " Enable The Sound System ". Aprés, je ne sais que voir de plus.

Bon, sinon, je passerai sous gnome, mais qu'en est il de toutes les appz que j'ai installé ?

Tout continuera à fonctionner sans réinstallation ?

Link to post
Share on other sites

bien sur, les librairies sont toujours la. Pendant un temps je faisais tourner "Konsole" sous fluxbox sans avoir installer KDE, j'avais juste installer les librairies indispensables et ca tournait. C'est comme k3b... De temps en temps y a un ti plantage, genre doctor je ne sais quoi qui veut se lancer, une saloperie KDe du style compagnon office je suppose, et j'ai pas trouve comment le chinter, a part modifier le code source de k3b.

Link to post
Share on other sites

je sais que par exemple, dans xine et xmms ( les deux que j'utilise pour lire respectivement tout ce qui est multimedia excepte mp3 et le second pour les mp3 ) tu peux choisir le systeme de gestion du son ( oss, alsa etc... ) . D'apres ce que j'ai lu sur les posts precedents, par defaut il y aurait arts a la place de alsa ( je n'en suis pas sur du tout, je specule ) il suffirait donc de preciser aux applis qu'il faut utiliser alsa plutot que arts.

Pas besoin de changer KDE pour Gnome pour autant, sauf si tu veux essayer ou que tu as d'autres raisons. Sous linux, quand ca ne fontionne pas, on resoud le pb, on ne le contourne pas par l'utilisation d'autre chose, ca c'est bon pour les kros$oftiens !

Link to post
Share on other sites

Bah, je me suis pas encore fait d'idée sur gnome, alors, au lieu de ne connaitre que kde, je prefere tester plusieurs trucs, pis si ça peut résoudre mes problemes par la mm occasion, je dit pk pas :)

Link to post
Share on other sites

Bon, j'avance petit à petit. Apparement, dans les pilotes ALSA y'a un plugin du nom de dmixer qui permet de multiplexer le son et ainsi ne pas avoir à utiliser ARTS ou ESD.

La configuration du multiplexage peut se faire soit avec un fichier .asoundrc placé dans le repertoire personnel ou bien par un asound.conf placé dans /etc/ .

Pour savoir que mettre dans ce fichier, allez voir sur http://www.alsa-project.org/alsa-doc/ et choisissez votre chipset audio.

Ps : j'ai pas réussi à faire marcher le tout, mais ca à l'air de fonctionner chez pas mal de gens ;-))

Link to post
Share on other sites

Euh ... ? Alsamixer et alsamixergui ne sont que des outils qui permettent de régler le son alors que dmixer permet de le multiplexer ... Ainsi, prendre plusieurs sources sonores et n'en faire qu'une

Link to post
Share on other sites

d'accord.. je connaissais pas dmixer et pensais que tu voulais juste un reglage du volume.... autant pour moi, :birthday:

mais ce que je sais, c'est que alsa c'est :birthday: et restes dans alsa a tout prix !

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...