Jump to content

Archived

This topic is now archived and is closed to further replies.

Arowan

ipv6 proxmox hôte

Recommended Posts

Je rencontre quelques soucis sur l'ipv6 sur mon hôte proxmox, mais je n'y arrive vraiment pas, j'y étais arrivé à l'époque sur proxmox 2.4 mais là en 3.4 j'y arrive plus.

Voici mon bloc 2001:41D0:B:04aa::/64

Ici la config ipv6 de mon hôte, je vois pas ce qui coince, quand je ping n'importe quelle adresse j'ai droit à un "Destination unreachable: Address unreachable"

iface vmbr0 inet6 static        address 2001:41D0:B:04aa::1        netmask 64        post-up /sbin/ip -f inet6 route add 2001:41D0:B:04ff:ff:ff:ff:ff dev vmbr0        post-up /sbin/ip -f inet6 route add default via 2001:41D0:B:04ff:ff:ff:ff:ff        pre-down /sbin/ip -f inet6 route del default via 2001:41D0:B:04ff:ff:ff:ff:ff        pre-down /sbin/ip -f inet6 route del 2001:41D0:B:04ff:ff:ff:ff:ff dev vmbr0

 

ping6 2001:41D0:B:04aa::1 => ok donc la pile ipv6 fonctionne

ping6 2001:41D0:B:04ff:ff:ff:ff:ff => ko =>  Destination unreachable: Address unreachable

root@master:~# traceroute ipv6.google.com
traceroute to ipv6.google.com (2a00:1450:4007:808::1009), 30 hops max, 80 byte p                                 ackets
 1  2001:41d0:b:4aa::1 (2001:41d0:b:4aa::1)  3000.713 ms !H  3000.716 ms !H  3000.714 ms !H


Table de routage IPv6 du noyauDestination                    Next Hop                   Flag Met Ref Use If2001:41d0:b:4aa::/64           ::                         U    256 0     0 vmbr02001:41d0:b:4ff:ff:ff:ff:ff/128 ::                         U    1024 0     1 vmbr0fe80::1/128                    ::                         U    256 0     0 venet0fe80::/64                      ::                         U    256 0     0 dummy0fe80::/64                      ::                         U    256 0     0 vmbr1fe80::/64                      ::                         U    256 0     0 vmbr0fe80::/64                      ::                         U    256 0     0 eth0fe80::/64                      ::                         U    256 0     0 venet0fe80::/64                      ::                         U    256 0     0 tap101i0fe80::/64                      ::                         U    256 0     0 tap104i0fe80::/64                      ::                         U    256 0     0 tap100i0::/0                           2001:41d0:b:4ff:ff:ff:ff:ff UG   1024 0  1178 vmbr0::/0                           ::                         !n   -1  1  1185 lo::1/128                        ::                         Un   0   1    18 lo2001:41d0:b:4aa::/128          ::                         Un   0   1     0 lo2001:41d0:b:4aa::1/128         ::                         Un   0   1  2544 lofe80::/128                     ::                         Un   0   1     0 lofe80::/128                     ::                         Un   0   1     0 lofe80::/128                     ::                         Un   0   1     0 lofe80::/128                     ::                         Un   0   1     0 lofe80::/128                     ::                         Un   0   1     0 lofe80::/128                     ::                         Un   0   1     0 lofe80::1/128                    ::                         Un   0   1     0 lofe80::4c66:c8ff:fe69:7dc5/128  ::                         Un   0   1     0 lofe80::76d0:2bff:fe26:bdb3/128  ::                         Un   0   1     0 lofe80::a8b6:12ff:fe3d:44fd/128  ::                         Un   0   1     0 lofe80::b431:66ff:feca:cdf2/128  ::                         Un   0   1     0 lofe80::c4af:14ff:fed4:9206/128  ::                         Un   0   1     0 lofe80::c4af:14ff:fed4:9206/128  ::                         Un   0   1     0 loff00::/8                       ::                         U    256 0     0 dummy0ff00::/8                       ::                         U    256 0     0 vmbr1ff00::/8                       ::                         U    256 0     0 vmbr0ff00::/8                       ::                         U    256 0     0 eth0ff00::/8                       ::                         U    256 0     0 venet0ff00::/8                       ::                         U    256 0     0 tap101i0ff00::/8                       ::                         U    256 0     0 tap104i0ff00::/8                       ::                         U    256 0     0 tap100i0::/0                           ::                         !n   -1  1  1185 lo

 

5: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 74:d0:2b:26:bd:b3 brd ff:ff:ff:ff:ff:ff
    inet 37.187.56.xx/24 brd 37.187.56.255 scope global vmbr0
    inet6 2001:41d0:b:4aa::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::76d0:2bff:fe26:bdb3/64 scope link
       valid_lft forever preferred_lft forever

Quelqu'un aurait une idée, parce que là je sèche? :/

D'avance merci

Share this post


Link to post
Share on other sites

Bon, vu que t'as pas trop de réponse je vais m'aventurer, mais j'y connais pas grand chose en ipv6.

 

Alors pour commencer, pourquoi tu as 2 adresses ipv6 ?

Share this post


Link to post
Share on other sites

Tu as toujours 2 ipv6 dans un système

 

la fe80 c'est le link-local et l'autre 2001:x c'est l'ipv6 unicast

 

Je désespérais d'avoir une réponse :D

Share this post


Link to post
Share on other sites

Ok, ok. Bon du coup je viens de mettre mon serveur en ipv6, et j'ai eu aucun problème.

 

Tu commences par "# ip addr add 2001:41D0:B:04aa::1/64 dev vmbr0".

 

Et  puis tu fais les 2 commandes là :

 

# ip route add 2001:41D0:B:04ff:ff:ff:ff:ff dev vmbr0

# ip route add default via 2001:41D0:B:04ff:ff:ff:ff:ff

 

Normalement ça devrait pinguer sur ipv6.google.com. Dit moi ce que ça donne ^^

Share this post


Link to post
Share on other sites

Vu que les ips sont déjà déclarée dans mon fichier interfaces il me retourne que ces ips sont y sont déjà existante :/


Je double post

 

j'ai supprimé les ip et je les ais rajouté manuellement pour la dernière il me dit "RTNETLINK answers: File exists" mais toujours pas de connectivité en ipv6 :/

Share this post


Link to post
Share on other sites

2001:41d0:b:4aa::/64 dev vmbr0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

2001:41d0:b:4ff:ff:ff:ff:ff dev vmbr0 metric 1024 mtu 1500 advmss 1440 hoplimit 0

fe80::1 dev venet0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev dummy0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev vmbr1 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev vmbr0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev vmbr2 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev eth0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev venet0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev tap100i0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev tap101i0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

fe80::/64 dev tap104i0 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 0

default via 2001:41d0:b:4ff:ff:ff:ff:ff dev vmbr0 metric 1024 mtu 1500 advmss 1440 hoplimit 0

Share this post


Link to post
Share on other sites

Ouais... Et pourquoi vmbr0 plûtot que eth0 ?

 

Edit : ok, c'est le mode de fonctionnement de proxmox

 

Il faudrait regarder du côté d'iptables maintenant, parce-que pour moi de ce côté c'est bon...

Share this post


Link to post
Share on other sites

J'ai vérifié que la gw était correcte, mais c'est pas ça je comprends pas d'où ça peut venir ...

Share this post


Link to post
Share on other sites

Le truc c'est qu'un ami qui à aussi un serveur chez ovh sous proxmox à part que sont serveur c'est un sys, mais chez lui ça fonctionne sans soucis avec la même configuration que la mienne.

Share this post


Link to post
Share on other sites

Et dans le manager ovh, tout est bien configurer ? Il n'y a pas d'erreur dans l'adresse ip ou dans la passerelle ? Sinon ouvre un ticket avec eux...

Share this post


Link to post
Share on other sites

Bin ya rien à configurer dans le manager si?

 

Le support ovh -_- si c'est pour avoir une réponse sous 3 semaines en me disant ça vient de votre serveur ... on peut rien faire

Share this post


Link to post
Share on other sites

Tu crois qu'en rescue je pourrais tester si la connectivité ipv6 peut fonctionner?

Share this post


Link to post
Share on other sites

Bah oui. Sinon, tu n'as pas le choix de plusieurs kernels avec proxmox ? Si ça ce trouve tu n'as qu'un kernel ipv4...

Share this post


Link to post
Share on other sites
root@master:~# lsmod |grep ipv6
ipv6                  341203  51 ib_addr,ip6table_mangle,ip6t_REJECT,vzcpt,vzrst

Non, l'ipv6 est bien activé dans le noyal. (je ne fais que passer malheureusement, j'ai pas bcp de temps libre). Et le bloc v6 est bien celui mentionné, d'où l'étonnement que ça ne fonctionne pas (on ne parle même pas des machines virtuelles pour l'instant).

 

Oui pour info on est deux sur la machine, mais j'ai pas réussi à faire mieux :/

Share this post


Link to post
Share on other sites

Tu veux rire? j'ai essayé l'ipv6 sur l'hote  sans succès, j'ai essayé sur mes 2 vm debian, sans succès et j'ai essayé avec la dernière vm (windows server 2008) et la l'ipv6 fonctionne mais par intermittence, je pense bien que c'est un soucis chez ovh, j'ai contacté le support hier mais sans réponse encore :D

Share this post


Link to post
Share on other sites

Pour être sûr il faudrait essayer avec eth0 déjà, c'est peut-être un problème de bridge.

Share this post


Link to post
Share on other sites

Juste pour remonter le sujet, j'ai enfin décidé d'investiguer avec le support ovh il semblerait que ça soit bien un problème de config coté ovh et pour l'instant le support ne sait pas quoi faire ils n'ont jamais vu ça. Ils doivent voir plus haut. Wait & See

Share this post


Link to post
Share on other sites

×
×
  • Create New...