Jump to content

Reherche la bonne formule Excel


Recommended Posts

Bonjour,

 

j'ai besoin de votre aide pour construire la bonne formule Excel (V 2007).

 

J'ai une liste de bien avec des coûts et une liste de composants.

Les biens dans un feuillet et les coûts avec le bien correspondant dans un autre.

Je maîtrise le RechercheV (je crois) et j'arrive à les associer sans souci entre les deux feuillets (vérif faite à la mano, c'est bon).

 

Bien A ---- Coût A

Bien B ---- Coût B

Bien C ---- Coût C

Bien D ---- Coût D

 

Les composants

Compo A

Compo B

Compo C

Compo D

Compo E

Compo F

 

La combinaison donne ceci :

ColonneA-- Colonne B

Bien A ---- Compo A

Bien B ---- Compo B

Bien C ---- Compo C

Bien D ---- Compo D

Bien A ---- Compo E

Bien B ---- Compo F

 

Un même bien peut donc avoir plusieurs composants différents.

Je voudrais calculer le coût de la composition ci-dessus. Mais bien entendu sans avoir les doublons ( 2 x le Coût A et le Coût B).

 

-----------Ca ne doit pas donner  ------------------ Mais ça doit donner

ColonneA-- ColonneB    Rech V direct --------- Colonne D

Bien A ---- Compo A ---- Coût A ------------------ Coût A

Bien B ---- Compo B ---- Coût B ------------------ Coût B

Bien C ---- Compo C ---- Coût C ------------------ Coût C

Bien D ---- Compo D ---- Coût D ----------------- Coût D

Bien A ---- Compo E ---- Coût A ------------------  rien

Bien B ---- Compo F ---- Coût B ------------------  rien

Total ------------------------ Erroné ------------------- Correct

 

Ceci n'est qu'un exemple limité puisqu'il s'agit en fait de + de 300 lignes avec bien d'autres composants et biens.

Et comme il y a du tableau croisé dynamique là derrière, il me faut automatiser tout ça.

 

Une idée de formule "magique" :zarb:  SVP, je dois finir ça ce week-end.... :gne:

Link to comment
Share on other sites

Salut,

 

Je t ai fait un fichier excel 97/2003 ou tu peux voir une solution à ton pb :

https://drive.google.com/file/d/0B4jxeDUqwJYXV2JCamFvQnBLem8/view?usp=sharing

 

Je pars de ta colonne Rech V direct pour obtenir Colonne D

J'ai pas géré les cas d'erreur ( par exemple si tu as un Coût ZZZ qui n'existe pas ) retiens juste le principe pour bâtir ta formule :

=SIERREUR(RECHERCHEV(RECHERCHEV(A15;$A$2:$B$7;2;FAUX);$B$9:$C14;2;FAUX);RECHERCHEV(A15;$A$2:$B$7;2;FAUX))

Bon courage :p

 

N.B. : je suis pas un excel guru donc si y a des avis plus éclairés n’hésitez pas ;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...