Jump to content

Archived

This topic is now archived and is closed to further replies.

Krapace

Debian Connection refusée

Recommended Posts

Bonjour,

 

Ce matin en me levant j'ai decouvert que j'avait put acces a Webmin sur mon serveur.

 

Pas grave je le reboot (hooooo) mais ca change rien.

 

Je tente une connection ssh et la c'est le drame. Connection refusé

 

 

krapace@krapace-pc:~$ ssh -v -p 443 krapace@debian

OpenSSH_6.0p1 Debian-4+deb7u2, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to debian [192.168.1.254] port 443.
debug1: connect to address 192.168.1.254 port 443: Connection refused
ssh: connect to host debian port 443: Connection refused

 

 

Pourtant j'ai rien changé les ports sont bien sur 443...

 

Ce qui est bizarre c'est que le réseau passe bien (j'ai essayé avec un aptitude update/upgrade) je ping les autres machines mais pas moyen d'avoir une page webmin ou apache et rien ne passe en ssh ni telnet :craint:

 

Mon serveur veut bien faire du ssh vers mon pc mais le contraire ne fonctionne pas...

Share this post


Link to post
Share on other sites

T'as bien vérifié que les différents ports sont bien ouverts (les services en écoute dessus surtout), et que t'as aucune IP de bannie dans un éventuel pare-feu ?

Share this post


Link to post
Share on other sites

Même si je n'avait rien fait dans iptables j'ai supprimé toutes les règles et defini ACCEPT par defaut

 

Un nmap me donne 

 

Nmap scan report for debian (192.168.1.254)

Host is up (0.0031s latency).
Not shown: 998 closed ports
PORT    STATE SERVICE     VERSION
139/tcp open  netbios-ssn Samba smbd 3.X (workgroup: WORKGROUP)
445/tcp open  netbios-ssn Samba smbd 3.X (workgroup: WORKGROUP)
 
Host script results:
|_nbstat: NetBIOS name: TECHNICOLOR, NetBIOS user: <unknown>, NetBIOS MAC: <unknown>
| smb-security-mode: 
|   Account that was used for smb scripts: guest
|   Share-level authentication (dangerous)
|   SMB Security: Challenge/response passwords supported
|_  Message signing disabled (dangerous, but default)
|_smbv2-enabled: Server doesn't support SMBv2 protocol
| smb-os-discovery: 
|   OS: Unix (Samba 3.0.37)
|   NetBIOS computer name: 
|   Workgroup: WORKGROUP
|_  System time: 2015-04-05 18:29:43 UTC+0

 

 

C'est bizarre...Tout s'est passé pendant mon sommeil. Je n'ai rien touché hier soir avant d'aller me coucher :pleure:

 

Même mes partages SAMBA déconnent.


Bon deja j'avance...J'ai un ssh sur le serveur...Mais SAMBA et Webmin ne veulent rien savoir

 

 

netstat -antu

Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat       
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:3350          0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:5433          0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:6010          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:3389            0.0.0.0:*               LISTEN     
tcp        0    180 192.168.1.3:443         192.168.1.2:39258       ESTABLISHED
tcp6       0      0 :::139                  :::*                    LISTEN     
tcp6       0      0 :::80                   :::*                    LISTEN     
tcp6       0      0 ::1:631                 :::*                    LISTEN     
tcp6       0      0 ::1:5432                :::*                    LISTEN     
tcp6       0      0 ::1:25                  :::*                    LISTEN     
tcp6       0      0 ::1:5433                :::*                    LISTEN     
tcp6       0      0 ::1:6010                :::*                    LISTEN     
tcp6       0      0 :::443                  :::*                    LISTEN     
tcp6       0      0 :::445                  :::*                    LISTEN     
tcp6       1      0 ::1:59120               ::1:631                 CLOSE_WAIT 
udp        0      0 0.0.0.0:49639           0.0.0.0:*                          
udp        0      0 0.0.0.0:631             0.0.0.0:*                          
udp        0      0 0.0.0.0:5353            0.0.0.0:*                          
udp        0      0 0.0.0.0:10000           0.0.0.0:*                          
udp        0      0 0.0.0.0:1900            0.0.0.0:*                          
udp        0      0 0.0.0.0:59616           0.0.0.0:*                          
udp        0      0 0.0.0.0:68              0.0.0.0:*                          
udp6       0      0 :::41507                :::*                               
udp6       0      0 ::1:57951               ::1:57951               ESTABLISHED
udp6       0      0 ::1:41793               ::1:41793               ESTABLISHED
udp6       0      0 :::54374                :::*                               
udp6       0      0 :::5353                 :::*

C'est mon put*** de routeur qui m'a fait une blague...

 

Faut vraiment que je me penche dessus et qu'il arrête de changer l'ip de mon serveur :mad:

Share this post


Link to post
Share on other sites

Normalement, dans un routeur, tu peux forcer l'adresse ip suivant l'adresse MAC de ta carte réseau du serveur.

Enfin, c'est comme ça depuis des années.

Par exemple, mon portable à l'adresse 192.168.1.51 :8

Share this post


Link to post
Share on other sites

C'est juste que l'interface est horrible...Du coup par telnet c'est beaucoup plus simple.

 

Et surtout j'ai plus d'options :)

 

Donc c'est reglé \o/

Share this post


Link to post
Share on other sites

Et pourquoi pas directement définir l'IP fixe sur le serveur ? (vraie question, j'ai du mal à voir l'intérêt de la réservation côté routeur pour un serveur sur lequel on a la main)

Share this post


Link to post
Share on other sites

J'ai eu des soucis avec le DHCP même si je fixait l'ip sur le serveur.

 

Faudrait que je réessaye vu que j'ai virer le network-manager.

Share this post


Link to post
Share on other sites

×
×
  • Create New...