Jump to content

Mettre à jour le moteur de rendu de Netscape 8


Recommended Posts

Netscape8grab.jpg

Bonjour tout le monde ^^

Voilà j'aimerai savoir , comme Netscape 8 utilise deux moteurs de rendu (Trident & Gecko).comment lui faire utiliser un moteur de

rendu Gecko plus récent .

Si on se réfère à l'arboresence du programme celle ci ressemble comme deux goutes d'eau à celles des Firefox 1 à 3.6.

On y retrouve 80% des dll etc.. mais je ne sais pas où est placé le moteur de rendu ..

De quels fichiers s'agit t-il ? Et pensez vous qu'il soit possible de les integrer à la place de ceux de Netscape 8/8.1 ou du moins

de les faire fonctionner. en les modifiant un peu?

J'aimerai déjà y arriver avec le moteur de rendu de la version 3.6.28. :love:

Link to comment
Share on other sites

Le moteur est un composant à part du navigateur ? Parce que si c'est le cas, ca voudrait dire qu'on mettre le moteur de rendu qu'on veut dans le navigateur qu'on souhaite.

Genre Chrome avec Gecko... Ou FF avec Blink... C'est pas aussi simple je crois.

Link to comment
Share on other sites

?

thème fusion? je ne le connais pas mais je pense qu'il est -et de loin- beaucoup plus simple de créer un thème correspondant exactement au résultat voulu que de changer le moteur d'un navigateur.

Est ce que cela n'est pas envisageable? :)

Link to comment
Share on other sites

L'explication claire et précise : le moteur de rendu est une bibliothèque qu'utilise le navigateur. Celui-ci est compilé en utilisant une certaine version de cette bibliothèque et il est peu probable que tu puisses simplement changer de dlls sans avoir à recompiler le programme entier.

Le truc c'est que comme Netscape n'est pas open source (je crois...) tu ne peux pas le recompilé puisque tu n'as pas accès aux sources.

Voilà. Après il y a peut-être une bidouille mais pour moi c'est pas possible.

Link to comment
Share on other sites

@Beankilla: Toi t'as pas encore croisé Kamui :transpi:

C'est la seule personne que je connaisse qui serait capable de naviguer sur le Web avec un ATARI :transpi:

non je ne connais pas c'est vrai :)

Après créer un thème firefox est peut être "compliqué" mais je pense que c'est vraiment la solution vers laquelle il faut se diriger dans ce cas ! :)

Link to comment
Share on other sites

Netscape est pas Opensource, mais le moteur Gecko l'est, s'il suffit de reintegrer des dll en les modifiants au niveau des versions je pense qu'elle doivent être lisible avec un reshack , le tout est juste de regarder les dépendances entre elles .

Ou alors reste la solution du thème Fusion, j'avais reussi a faire un thème IE5.5 (mac) en partie mais j'ai eu beaucoup de mal.. alors un thème Fusion

O.o , si quelqu'un peut m'aider ça serait avec joie.tous les element du thèmes sont au format jar sur netscape 8 , peut-être qu'il est possible de le rendre

compatible avec Firefox? (version 3 à 21)

Link to comment
Share on other sites

Après pour les dlls il y a toujours la solution barbare : tu les remplaces, tu lances netscape en ligne de commande et tu regardes se qui plante. Mais après on parle quand même de la version gecko utilisé dans firefox 1 ! Ça va être très dur de trouver quelque chose de compatible...

Link to comment
Share on other sites

Pourquoi ne pas déjà passer à Netscape 9 ? Ou à passer à un navigateur qui sera à jour et sécurisé ? Car même avec un bon moteur de rendu c'est une passoire que tu utilises… Et ça même la nostalgeek ne vaut pas le coup...

Link to comment
Share on other sites

Non je veux le theme fusion.

Et je le veux sur une base FF allant de la 3.6.28 à 21 au choix.

Sur netscape 9 le soucis sera le même que sur FF , et comme j'ai pas le skin Fusion, ni le moteur de rendu j'y gagne rien.

Donc soit j'arrive a mettre le moteur de rendu d'un FF plus récent sous Netscape 8 , soit j'arrive a adapter le theme fusion sur un Firefox 3.6+

NcVZLVl.png

voici l'arboresence de FF 3.6 à gauche et netscape 8 à droite, j'ai modifié pour voir le classic.jar , en important ceux du fusion.jar dedans, j'ai un

début de skin mais comme le CSS etc.. est celui de FF3 ça rend pas.

ns810.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...