Jump to content

Lecture Progressive MP4


Recommended Posts

Salut à tous :)

je galère sévèrement depuis 2 jours, je tourne en rond... alors au cas où...

j'ai mis en place une galerie Imagevue sur mon domaine, afin de partager avec mes proches des photos et des vidéos, de manière privée. je souhaite utiliser le lecteur de vidéos intégré à cette solution, qui est un lecteur du même type que jwplayer, jplayer, etc... il lit le FLV et le MP4, c'est ce dernier format qui m'intéresse.

j'ai depuis quelques années un Nokia N8. il m'est arrivé de prendre quelques vidéos avec, et c'est justement celles-ci que je souhaite partager aujourd'hui via ma galerie. ces vidéos sont nativement au format MP4, H.264 pour la vidéo et AAC LC pour l'audio. ces vidéos sont parfaitement lues par VLC par exemple, et il m'est déjà arrivé d'uploader des vidéos de mon Nokia sur Youtube sans aucun problème.

mon premier essai a été simple : upload de la vidéo, ouverture de la galerie, lecture. et là, c'est le drame. lorsque je clique sur "Play", la vidéo charge en entier sans rien afficher. une fois complètement chargée, j'appuie de nouveau sur "Play", et la vidéo est parfaitement lue.

est donc éliminé une incompatibilité éventuelle du lecteur : celui-ci fonctionne parfaitement, la vidéo aussi.

mais ce n'est pas ce que je veux... pour une vidéo de 3Mo, ça va... mais pour une vidéo de 500Mo (oui, j'en ai !), pas question de se taper un chargement complet sans rien afficher. il faut donc que lorsque le chargement débute, la vidéo commence aussi... j'ai d'ailleurs appris ce terme grâce à cela : la lecture progressive (et non le streaming, rien à voir).

bref, j'ai donc cherché un tas d'informations. j'ai trouvé des gens qui parlaient de problèmes similaires, j'ai tenté des solutions, mais rien.

par exemple :

- le header du MP4 se trouve par défaut à la fin de celui-ci, obligeant le lecteur à charger complètement la vidéo avant d'avoir accès à celui-ci. j'ai donc remuxé avec YAMB 2 beta, et effectivement ça a changé : lorsque je clique sur "Play", la première image apparait mais se fige. le chargement continue... bizarrement la vidéo aussi... et ça repart. sauf que sur une vidéo de 41 secondes en test, j'avais au final 36 secondes de lues avec ce freeze du début.

- fast start : il existe des options qui permettent de démarrer plus vite la vidéo. j'ai donc téléchargé MP4 FastStart (ou un truc du genre), il suffit de sélectionner la vidéo et de faire "make faster". le résultat est différent : la première image apparait, se fige, le chargement continue, la vidéo aussi tout en étant freezé (son également), puis une fois que la vidéo est complètement chargée, boum ça commence à lire... les 4 ou 5 secondes qui restent.

- du coup, j'ai tenté un faststart après modif du header, sans résultat.

- j'ai essayé de réencoder la vidéo avec Super, aucun résultat.

- j'ai modifié 50 options au pif pour voir ce que ça pouvait faire (genre rendre compatible Apple, apparemment ça aide... ou encore "Hint" machin truc, sans savoir ce que c'était, -size pour balancer la taille totale de la vidéo dans le header... etc), sans résultat.

je tourne donc en rond et ça me gave énormément. est-ce que quelqu'un ici connait bien ce format et sait ce qu'il faut faire pour à coup sûr rendre compatible une vidéo MP4 avec une lecture progressive ? si besoin, je fournirai une vidéo de test, sortie de mon N8...

edit : pour info, j'ai trouvé une vidéo sur le net au format MP4, et qui fonctionne absolument parfaitement avec le lecteur d'imagevue. la lecture progressive démarre peu après le début de chargement, et tout est impec'... donc je sais que ça peut fonctionner ! j'ai d'ailleurs fait un fichier PDF de comparaison entre les 2 vidéos, celle qui fonctionne et celle qui ne fonctionne pas : Fichier PDF Comparatif. je ne vois rien d'anormal de mon côté, mais je ne suis pas spécialiste non plus...

merci d'avance !

Kivlov.

Link to comment
Share on other sites

Un peu d'aide :dd:

fast start (si c'est celui que je pense) va mettre tous les chunks audio et vidéo dans l'ordre.

Ainsi, dans l'header, il n'y a plus de table de chunks.

Un chunk c'est un morceau (fixe si je ne dis pas de bêtise) d'une piste.

ATTENTION: moi j'ai fait de la vidéo, et justement en "progressive download" . Mais depuis 3-4 ans je n'arrive plus à trouver ce terme.

Je soupçonne que le type "progressive download" soit maintenant pris de façon transparente par les encoders, les protocoles, ....

De toute façon, je n'ai jamais trouvé un logiciel qui me dit si les chunks sont dans l'ordre ou pas.

Il faut coder le truc :transpi:

Et ne le prends pas mal, mais ton fichier PDF est inutile :siffle:

Il faut regarder les entrailles de ta vidéo: mediainfo ET gspot :windu:

Ton problème peut venir du nombre de keyframes et/ ou de ton profil vidéo/ audio :ane:

Link to comment
Share on other sites

MP4 FastStart, c'est ça : http://www.datagoround.com/lab/. un header de MP4 est par défaut en fin de fichier, c'est pour le mettre au début qu'il faut faire ces manipulations... les logiciels intègrent des fonctions diverses pour le faire, comme "optimiser pour le web", ce genre de chose.

je ne vois pas ce que gspot pourrait m'apporter dans ce cas de figure :zarb: toutes les infos qui nous intéressent sont présentes via mediainfo (et dans mon PDF du coup).

Link to comment
Share on other sites

Ah flûte, il y a 2 autres pages :transpi:

Sinon

  • No Stream: 12,0 Mbps, Stream: 172 Kbps max 205 Kbps
  • No Stream: 1 280x720, Stream: 480x360
  • No Stream: Variable Frame Rate, Stream: Constant Frame Rate

Il faut dans un premier temps soit partir de la vidéo qui fonctionne pour arriver à la vidéo qui ne fonctionne pas, soit l'inverse pour trouver les paramètres, ou la combinaison de paramètres qui ne passent pas

Pour cela il ne faut pas utiliser un frontend mais un vrai encoder comme ffmpeg par exemple :siffle:

Et gspot t'apporte aussi un mode visuel des frames (I, B, P) et les informations PAR, SAR, DAR qui peuvent être utiles en dernier recours.

Et effectivement, tu me rappelles (mais à vérifier) qu'Apple ou le consortium n'a pas fixé l'endroit des headers: début ou fin.

Et en cas de "progressive download" il faut qu'il soit au début

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...