Jump to content

Problème redirection ports livebox play


Recommended Posts

Bonjour !

J'ai un problème de redirection de port sur ma livebox. J'ai ouvert mes ports (règle NAT), j'ai testé tous les paramétrages possibles du firewall, mais je n'arrive pas à accéder à mon NAS à distance. Il est en IP Fixe, je n'ai jamais eu aucun soucis avec ma freebox avant, mais depuis mon changement de FAI impossible...

Est ce que quelqu'un connaîtrait une option particulière à côté de laquelle je serai passé ?

Cette box me donne envie de m'arracher les cheveux...

Y a t il un moyen de savoir quels ports sont ouverts ?

Link to comment
Share on other sites

@metro557 : à priori non, je check bien mon IP publique juste avant...

@CaseyN : Voilà, je suis passé en personnalisé. Je n'ai rajouté que les règles relatives au FTP, tout le reste était ouvert.

46ijn0.png

Le problème reste le même (j'avais déjà testé)

Link to comment
Share on other sites

Question bête mais bon on ne sait jamais. Ta nouvelle box a la même ip que l'ancienne ? Au cas où sur le NAS tu aurais forcé l'écoute du port sur l'ancienne ip.

Et je suppose que tu as bien reseter ta box pour qu'elle prenne correctement les news paramètres.

Link to comment
Share on other sites

Box redémarrée a plusieurs reprises... Port 21 dans les 2 cas. L'IP du NAS n'a pas changée.

Mais pour moi le problème vient de ma box, aucun port n'est ouvert, même en mettant une DMZ quand je teste un port c'est verrouillé.

Link to comment
Share on other sites

C'était pré rempli comme ça... Je ne sais pas trop quelle IP y mettre en fait ?

Ça doit être des IP distantes a rentrer, restreindre le port à une IP distante ? Je comprend pas la philosophie du truc de toute façon.

D'ailleurs d'après ce qui est écrit même en pâte feu faible ça laisse passer les ports redirigés...

Link to comment
Share on other sites

220 ProFTPD 1.3.3g Server (NETGEAR ReadyNAS) [192.168.1.2]USER poskay331 Password required for poskayPASS ********230 User poskay logged inFEAT211-Features: MDTM MFMT TVFS UTF8 AUTH TLS MFF modify;UNIX.group;UNIX.mode; MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*; LANG en-US* PBSZ PROT SITE MKDIR SITE RMDIR SITE UTIME SITE SYMLINK REST STREAM SIZE211 EndOPTS UTF8 ON200 UTF8 set to onPWD257 "/" is the current directoryNOOP200 NOOP command successfulSYST215 UNIX Type: L8STAT /211-Status of /:211-drwxr-xr-x   5 ftp      ftp         16384 Nov  4  2012 .211-drwxr-xr-x   5 ftp      ftp         16384 Nov  4  2012 ..211-drwxrwxrwx  17 poskay  users       16384 Jan 17 21:12 dossier1211-drwxrwxrwx   7 dossier2 nogroup     16384 Sep 29 13:02 dossier2211-drwxrwxrwx   7 dossier3 nogroup     16384 Mar 17  2013 dossier3211 End of statusCWD /250 CWD command successfulTYPE A200 Type set to APORT MONIPLOCALE,202,156200 PORT command successfulMLSD150 Opening ASCII mode data connection for MLSD220 ProFTPD 1.3.3g Server (NETGEAR ReadyNAS) [192.168.1.2]USER poskay331 Password required for poskayPASS ********230 User poskay logged inFEAT211-Features: MDTM MFMT TVFS UTF8 AUTH TLS MFF modify;UNIX.group;UNIX.mode; MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*; LANG en-US* PBSZ PROT SITE MKDIR SITE RMDIR SITE UTIME SITE SYMLINK REST STREAM SIZE211 EndOPTS UTF8 ON200 UTF8 set to onCWD /250 CWD command successfulTYPE A200 Type set to APASV227 Entering Passive Mode (*MONIPEXTERNE*,184,132).

Bon, j'ai fait une réinitialisation de la livebox, et j'ai tout remis à la main.

Il y a du mieux, mais ça bloque toujours, je vous ai mis le journal au dessus.

Link to comment
Share on other sites

Je vois 2 problèmes 1) Tu cherches à accéder sur ton adresse publique depuis cette même adresse publique. Du coup tu ne sors pas de chez toi et tape sur ton IP privée (on le voit bien dans ton Log ReadyNAS). Si tu veux je t'ouvre un accès à la maison pour avoir une autre IP publique pour tes tests.

2) Dans ton dernier screen, tu routes de rien vers rien puisque tu n'as aucune IP de renseignée. En source il faut espère que "vide" veuille dire "toute IP" mais en destination il te faut au moins l'IP privée de ton NAS.

Link to comment
Share on other sites

Pour le 1) ok. Mais le problème ne vient pas de là vu que quand tu as testé ça ne fonctionnait pas non plus...

Pour le 2) ce n'est pas la table de routage, c'est la table du pare feu en mode personnalisé. Tout est rempli tel quel à la base, donc je présume que rien renseigné signifie "toutes les IP".

Je testerai en mettant l'IP du NAS.

Link to comment
Share on other sites

Alors...

Rien ne me semblait déconnant sur ta 1ère config:

- Réservation DHCP d'une IP pour "Serveur"

- Ajout d'un NAT port 21 vers port 21 à destination de ce device.

- Firewall en mode quasi IDLE.

Par contre, le mode "personnalisé" sans aucune IP mentionnée est vachement perturbant je trouve, surtout si tu t'en trouve réduit aux déductions pour le fonctionnement du truc...

Par contre, 2 pistes très concrètes:

> Evite Cyberduck... Il est bien gentil comme client, mais il a était la source de bcp de WTF pour moi dans la gestion de mon NAS.

> Vérifie que ton serveur ton serveur n'utilise pas une plage de ports passifs spécifiques... C'est une mécanique très fréquente sur les serveurs FTP: je prends connaissance d'une demande de connection via le port 21 MAIS je fourni la réponse sur un autre port qui lui pourra rester connecté en mode passif. (Un QNAP utilise la plage 55536 - 56559 pour cela et il te faut NATté toute la plage pour que ça fonctionne...

:chinois:

Link to comment
Share on other sites

Je prends note pour cyberduck. Tu utilises quoi à la place ?

Bon, je viens de faire un test...et ça fonctionne ?! Je n'y comprends rien... Ce week-end un truc m'a mis la puce à l'oreille : j'ai remis la DMZ vers le NAS et ça m'a coupé toutes les connexions entrantes (bittorent) sur toutes les machines Y COMPRIS sur le NAS. Le NAS était réglé en IP fixe manuelle, quelque chose faisait donc que malgré que l'IP était bonne la box n'envoyait pas les IP dessus... (en écrivant ces lignes je me demande si la passerelle était bonne...j'avais peut-être oublié de la changer ?).

Bref, j'arrive à m'y connecter, c'est le principal même si j'aurai bien aimé être sur de savoir d'où vient le soucis. Je me suis connecté avec FileZilla, c'est le logiciel que j'utilise au taf. Je ne suis pas chez moi, je peux pas fouiller dans les options et comme je n'avais pas fait de capture d'écran de la page de config IP du NAS et que ça a débloqué en changeant ce paramètre je me dis que c'est par là que ça devait bloquer ?

Link to comment
Share on other sites

  • 2 weeks later...

Merci beau coup CaseyN !!!

Je ne comprenais pas pourquoi la redirection de ports ne fonctionnaient pas chez moi (Livebox Play Fibre), venant d'une Freebox cela devait être simple..

En fait c'est tout con, mais on ne peut pas tester l'ouverture de ports sur une Livebox depuis chez soi, quand on se connecte à l'ip publique la livebox détecte qu'on se connecte de chez soi et doit rediriger vers l'IP privé où les règles NAT ne sont pas appliquées (logique en même temps..).

Du coup en testant depuis mon téléphone l'accès à distance (une cam IP et un logiciel) depuis une connexion 3G tout marche !

Link to comment
Share on other sites

  • 6 months later...

Je viens d'avoir exactement ce pb....

et en fait, avec ces nouvelles box, on ne peut plus avoir accès a chez nous depuis notre ip public ... et ca, ca me gonfle bien...

par exemple, je peux pas voir sur le net les images que j'heberge chez moi... c'est génial ca non .....

quel est le con qui a viré cette possibilité de la box ???

Link to comment
Share on other sites

bon j'ai trouvé plein de bidouille de contournement du probleme.

Soluce 1 : https://lafibre.info/orange-tutoriels/loopback-livebox-play-bricolage/ -> j'ai testé.. ca avait pas l'air convaincant ... d'ou surement la solution 2

Soluce 2 : http://www.2leplace.fr/contourner-le-probleme-de-loopback-avec-la-livebox-play/ -> .. j'ai pas osé, c'est bidouille pure...

Soluce 3 : modifier le DNS de mon server pour qu'il résolve l'url a la place de la box

c'est ce que j'ai fais, ca marche pas trop mal mais du coup ca bypass les regles de routage de mon serveur.. et ca.. ca pue...

enfin bon, ca sera uniquement le temps de passer chez free

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...