Jump to content

Freebox Player et WR841N


Recommended Posts

Salut tout le monde !

Je viens vers vous car j'ai installé mon freebox player dans mon salon assez éloigné du bureau où se situe le freebox server. La liaison se fait par CPL et fonctionne très bien mais j'aimerais bien profiter de cette liaison CPL pour étendre mon réseau Wi-Fi ! J'ai un routeur WR841N qui me permet de configurer les VLAN (sous OpenWRT) mais je n'arrive pas du tout à les configurer ^^

Tant que j'y suis si je pouvais en plus ne pas avoir de DHCP sur ce routeur pour qu'il soit "transparent" ça serait super !

Merci d'avance aux courageux qui essaieront de m'aider !

ThePeach

Link to comment
Share on other sites

Tu mets ton routeur en simple switch (uniquement interface LAN sur OpenWRT liant toutes les interfaces ethernet et WiFi), tu désactive le DHCP sur cette interface, tu mets l'IP en fixe dans le même sous réseau que ta freebox et tu poses le switch entre ton CPL et la Freebox player ça marchera direct. J'ai monté ça comme ça chez mes parents mais avec une Airport Express ça marche au poil.

Link to comment
Share on other sites

Alors j'ai tout enlevé (dhcp, firewall, etc.) et j'ai juste rajouté un vlan 100 taggé sur les ports CPL et Freebox Player. J'ai maintenant le Wi-Fi qui fonctionne, le Freebox Player aussi mais les appareils en ethernet (PC, Smart TV et PS3) ne fonctionnent plus (ils ne réussissent pas à obtenir une IP) :mad2:


Après quelques tests :

- Avec le VLAN 100 : Wi-Fi & Freebox Player fonctionnent

- Sans le VLAN 100 : Wi-Fi & appareils reliés en ethernet fonctionnent

C'est problématique mais déjà une avancée ^^

Link to comment
Share on other sites

Justement la freebox ne fonctionne pas du tout sans le vlan 100...

Oui mais je vais re vérifier !

J'ai pour l'instant cette configuration :

config interface 'loopback'        option ifname 'lo'        option proto 'static'        option ipaddr '127.0.0.1'        option netmask '255.0.0.0'config interface 'lan'        option type 'bridge'        option proto 'static'        option netmask '255.255.255.0'        option _orig_ifname 'eth1 radio0.network1'        option _orig_bridge 'true'        option ipaddr '192.168.1.252'        option gateway '192.168.1.254'        option ifname 'eth0 eth1'        option stp '1'config switch        option name 'switch0'        option reset '1'        option enable_vlan '1'config switch_vlan        option device 'switch0'        option vlan '1'        option vid '1'        option ports '0 1 2 3 4'config switch_vlan        option device 'switch0'        option vlan '2'        option ports '0t 2t'        option vid '100'
Link to comment
Share on other sites

Voilà ce que j'ai sur un OpenWRT qui est uniquement en switch :

onfig interface 'loopback'	option ifname 'lo'	option proto 'static'	option ipaddr '127.0.0.1'	option netmask '255.0.0.0'config interface 'lan'	option type 'bridge'	option proto 'static'	option netmask '255.255.255.0'	option _orig_ifname 'eth1 radio0.network1'	option _orig_bridge 'true'	option ifname 'eth0 eth1'	option ipaddr '192.168.0.253'	option gateway '192.168.0.254'	option dns '192.168.0.254'config switch	option name 'switch0'	option reset '1'config switch_vlan	option device 'switch0'	option vlan '1'	option vid '1'	option ports '0 1 2 3 4'

Aucun VLAN de mis mais l'option est quand même activée sur le switch si un jour je veux changer ça.


Ton option "span tree protocol" ne gênerait elle pas ? (pour moi elle n'est pas utile)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...