Jump to content

Archived

This topic is now archived and is closed to further replies.

Manervi

Programmer le réveil/l'extinction de son pc

Recommended Posts

Bonjour,

suite à la lecture d'un récent article sur le site de Korben j'ai essayé d'utiliser la commande rtcwake sous Debian Squeeze.

Le problème c'est que chez moi elle ne semble pas fonctionner correctement. Par exemple si je tente la simple commande :

'sudo rtcwake -m mem -s 10' qui en temps normal devrait mettre l'OS en veille en le copiant dans la ram, attendre 10 secondes puis rallumer le pc, l'OS passe bien en veille mais jamais ne se rallume.

J'ai pensé que cela venait peut-être d'une option dans le BIOS de ma CM qu'il fallait activer mais je n'ai rien trouvé de concluant. Il y a bien un onglet Power dans lequel on trouve les options :

Suspend Mode avec pour valeurs Auto (par défaut), S1 (POS) only, S3 only

ACPI 2.0 Support avec pour valeurs Enabled (par défaut), Disabled

ACPI APIC support avec pour valeurs Enabled (par défaut), Disabled

ainsi qu'un sous-menu APM Configuration avec comme options :

Restore AC Power Loss -> valeurs Power Off (par défaut), Power On, Last State

Power on From S5 By PME# -> valeurs Disabled (par défaut), Enabled

Power on From S5 By Ring -> valeurs Disabled (par défaut), Enabled

Power on From S5 By RTC Alarm -> Disabled (par défaut), Enabled

... mais la configuration m'a l'air bonne.

La dernière option 'Power on From S5 By RTC Alarm' permet de programmer un réveil mais je préférerais pouvoir utiliser la commande rtcwake qui offre plus de possibilités.

Juste au cas où voici quelques informations concernant mon BIOS (flashé donc à jour) :

BIOS InformationVendor: American Megatrends Inc.Version: 0801  Release Date: 01/17/2011Address: 0xF0000Runtime Size: 64 kBROM Size: 1024 kBCharacteristics:	ISA is supported	PCI is supported	PNP is supported	APM is supported	BIOS is upgradeable	BIOS shadowing is allowed	ESCD support is available	Boot from CD is supported	Selectable boot is supported	BIOS ROM is socketed	EDD is supported	5.25"/1.2 MB floppy services are supported (int 13h)	3.5"/720 KB floppy services are supported (int 13h)	3.5"/2.88 MB floppy services are supported (int 13h)	Print screen service is supported (int 5h)	8042 keyboard services are supported (int 9h)	Serial services are supported (int 14h)	Printer services are supported (int 17h)	CGA/mono video services are supported (int 10h)	ACPI is supported	USB legacy is supported	LS-120 boot is supported	ATAPI Zip drive boot is supported	BIOS boot specification is supported	Targeted content distribution is supportedBIOS Revision: 8.15

Merci d'avance pour votre aide.

Edit : j'ai l'impression que le problème vient de la carte-mère :

http://ubuntuforums....d.php?t=1578434

http://vip.asus.com/...SLanguage=en-us

:craint:

Je vais peut-être me contenter de l'option 'Power on From S5 By RTC Alarm' du BIOS et programmer une heure de réveil à partir de là mais si jamais quelqu'un a une astuce pour faire pleinement fonctionner rtcwake sur cette CM je suis tout ouïe.

Share this post


Link to post
Share on other sites

Question bête, as tu essayé avec -m disk? et -s 10 c'est la seule valeur que tu as tenté? Essaye avec une valeur plus grande parce que si rtcwake calcule l'heure de reveil quand la commande est exécutée et que ton pc met plus de 10 seconde pour se mettre en veille... bref sa date de reveil sera déjà passée... Voilà mes idées à 2cts

Share this post


Link to post
Share on other sites

Essaye de mettre dans le bios Suspend mode à la valeur S1.

Je viens d'essayer, j'ai également tenté de faire passer l'option sur 'S3 only' en même temps que 'Power on From S5 By PME#' et 'Power on From S5 By Ring' sur 'Enabled'.

Dans les 2 cas la commande ne fonctionne pas, pire elle ne fait même plus passer l'OS en veille, du coup j'ai remis les réglages par défaut. :craint:

Question bête, as tu essayé avec -m disk? et -s 10 c'est la seule valeur que tu as tenté? Essaye avec une valeur plus grande parce que si rtcwake calcule l'heure de reveil quand la commande est exécutée et que ton pc met plus de 10 seconde pour se mettre en veille... bref sa date de reveil sera déjà passée... Voilà mes idées à 2cts

Pour la durée j'avais déjà tenté avec 60 secondes et 30 secondes sans obtenir de meilleurs résultats. De toute façon la mise en veille est rapide (quelques secondes, mais moins de 10).

Pour -m disk effectivement ça fonctionne ( :yes:), je m'étais arrêté à -m mem en pensant que si ça ne fonctionnait pas pour une simple mise en veille, a fortiori ça ne marcherait pas non plus pour une hibernation. Du coup j'ai aussi essayé avec -m off (extinction), ça ne marche pas.

Donc en résumé, la seule option qui fonctionne pour le moment c'est -m disk.

C'est quand même étrange, je vais essayer de trouver un autre pc sur lequel utiliser la commande ainsi qu'une autre distribution histoire de voir si le problème vient bien de la carte-mère.

Il me reste encore -m no (pas d'extinction mais programmation d'un redémarrage à une date qu'il faut définir) à essayer. Le problème c'est que j'ai l'impression que la date à fournir se base sur l'heure de l'horloge du bios qui doit être en UTC ou locale, enfin c'est ce que j'ai crû comprendre en lisant l'article de howtogeek sur lequel s'appuie celui de Korben :

The -l switch tells rtcwake that the hardware clock is set to local time, while the -u switch tells rtcwake that the hardware clock (in your computer’s BIOS) is set to UTC time. Linux distributions often set your hardware clock to UTC time and translate that to your local time.

Or l'heure de mon bios est de type CEST (UTC +2) si j'en crois ce que me retourne 'sudo hwclock' :

Fri 17 Aug 2012 12:15:28 AM CEST  -0.395672 seconds

Du coup je suis un peu perdu, si je veux par exemple programmer le réveil de mon pc mettons aujourd'hui à 16 heures, est-ce que je dois indiquer à rtcwake l'Heure Unix ( = date +%s -d 'today 16:00' ) telle quelle ou en ajoutant/retirant 2 heures ?

En tous les cas merci à vous deux. :chinois:

Share this post


Link to post
Share on other sites

×
×
  • Create New...