Jump to content

Archived

This topic is now archived and is closed to further replies.

Mephisto

ArchLinux - VirtualBox & problèmes de réveil matin

Recommended Posts

Bonjour !

Depuis peu, j'ai passé mon Windows en VM sur VirtualBox (host ArchLinux), pour pouvoir synchroniser mon iPhone (et ne pas bloquer un PC juste pour ça).

Je n'y ai pas fait attention sur le coup, mais l'heure du guest déconne (et pas qu'un peu).

Et puisque l'iPhone, à chaque synchro, se calle sur l'heure du Windows, mon réveille sonne donc avec +/-15 minutes de retard (je vous laisse imaginer la tête du patron quand je lui ai expliqué ça)

J'ai fait un tour sur les forums VirtualBox, le problème semble connu (et lié aux guest additions).

Mais les seuls fix proposés concernent des guests linux/unix (il faut tripatouiller les options de boot, ...)

Régler l'heure manuellement ne sert à rien, les GA s'occupant régulièrement de la mettre à jour.

Sur le principe, je preferrerai ne pas avoir a desinstaller les GA.

Mais si on ne trouve pas, j'en viendrai certainement à ça.

En attendant, quelqu'un a déjà eu ce problème ? S'en est sortie ? A une petite idée ?

Merci :censored:

Share this post


Link to post
Share on other sites

je crois que sous windows, il y a une option pour synchroniser ou non l'heure avec les serveurs internet... regarde ce qu'il en est. A partir de la, soit la synchronisation est en place et c'est ça qui pose problème, donc dans ce cas, tu décoches l'option et ça ne devrai plus toucher aux réglages de l'heure; soit c'est décoché et dans ce cas en la cochant, il devrait aller récupérer l'heure sur les serveurs internet...

C'est juste une piste comme ça, pour voir s'il est possible de résoudre ce problème d'heure via la synchronisation ou non de l'heure. En pratique j'en ai aucune idée du résultat vu que je n'ai pas le moindre windows physique ou virtuel sur mes machines, donc pas moyen de tester...

Share this post


Link to post
Share on other sites

J'ai pas la machine sous la main, mais j'imagine que l'option est décoché.

De toute façon, sur un thread que j'ai suivie, bb84 a ce même problème, avec ntpd lancé

(cf. son deuxieme post, un log dont les heures ne se suivent pas).

Et, pour avoir déjà remis l'heure à la main, je confirme que le temps de synchroniser l'iPhone, c'est déjà repartie en couille.

Le problème est que les GA remettent régulièrement (et souvent) l'heure à jour.

Ce que je cherche, c'est plus un moyen de virer la synchro du temps des GA (l'équivalent winwin de ntpfix).

edit: en reformulant la question, google me renvoit ca

je regarderai ce soir, il semblerait que je doive désactiver un service.

edit2: Côté services, j'ai jeté un oeil, je n'ai pas trouvé celui qui pourrait gérrer ça.

google m'a proposé de setter VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled a 1

passons sur VBoxManager que je ne sais pas faire marcher (je ne sais pas ce qu'il veut comme nom de VM, mais il m'envoit chier systématiquement)

je suis donc allé le faire en dur dans $VBOX/Machines/Windows/Windows.xml (dans les ExtraData)

au passage: je ne sais pas pourquoi, mais il rajoute des (j'imagine) caractères spéciaux autour de la clé et de sa valeur.

j'ai rajouté cette ligne:

<ExtraDataItem name="VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" value="1"/>

peu après, elle s'est changé en celle-ci:

<ExtraDataItem name="“VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled”" value="“1″"/>

pas le temps de tester, je vous tient au courrant.

edit3: bon ben, ça marche pas non plus

mais c'est marrant (ou pas), ça semble se stabiliser une fois qu'il à pris +/-15 minutes de retard

Share this post


Link to post
Share on other sites

petit up

bonne année à tous

"plein de bonnes choses, et moins de bug", comme dirait le chef de proj

pour en revenir au sujet, j'ai toujour le même problème

je n'ai pas eu l'occasion de chercher plus loin

si vous avez une piste, ...

Share this post


Link to post
Share on other sites

×
×
  • Create New...