Jump to content

amule en low id


Recommended Posts

Bonjour

Je suis un nouvelle utilisateur de linux, j'ai beaucoup de souci avec vista ...

donc je souhaite utiliser amule avec suse-10.3. mais je suis en low id.

normalement mes port sur mon modem-routeur C-Internet sont ouvert correctement

tcp 14000 sur 192.168.1.3

udp 14010 sur 192.168.1.3

pour être sur de ne pas être bloqué pare le routeur j'ai activé la DMZ sur le poste 192.168.1.3

je suis connecté en DHCP

infos suplémentaires:

suse@suse:~> /sbin/ifconfig

eth0 Lien encap:Ethernet HWaddr 00:03:0D:72:F9:B2

inet adr:192.168.1.3 Bcast:192.168.1.255 Masque:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:4337 errors:0 dropped:0 overruns:0 frame:0

TX packets:2767 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:1000

RX bytes:5690594 (5.4 Mb) TX bytes:242400 (236.7 Kb)

Interruption:19 Adresse de base:0xc000

amule, préférences, connexion, tcp 14000, udp 14000

je pense ne pas avoir activé le pare feu de suse, mais j'ai un doute!!! :francais:

avez vous une idée?

Link to comment
Share on other sites

tcp 14000 sur 192.168.1.3

udp 14010 sur 192.168.1.3

pour être sur de ne pas être bloqué pare le routeur j'ai activé la DMZ sur le poste 192.168.1.3

OK... sinon, il faut a priori encore un autre port, pour amule, qui serait le numéro du port TCP+3, et en UDP seulement...

je suis connecté en DHCP

DHCP statique, j'imagine...

Bon, tu arrives quand même à te connecter à des serveurs ? Parce que ça, a priori, amule n'a pas de mal... par contre, kad, c'est une autre histoire : même avec un nodes.dat bien fourni (si tu n'en prends pas un déjà bien, tu peux mettre plus de 24h à être en high-id sous kad, la première fois), il est lent comme la mort à passer en high-id...

Bref, tu n'es pas en high-id :

- en serveur ?

- sur kad ?

- tu es en low-id quand même ?

Sinon, amule, ce n'est pas génial-génial, et il n'y a pas moult choix, en client de mule... à ce niveau mldonkey est plus stable, léger, versatile (mule+torrent+...), mais plus chiant à configurer (encore que... enfin, si : pour un débutant, il est un poil plus chiant, dissociant interface et backend, qui tourne comme un service et n'a pas, lui, besoin de clickodrome pour tourner)...

Link to comment
Share on other sites

salut.

concernant Amule.

Le problème peut venir de ton routeur. Un certain nombre de port doivent être forwardés sur ton post. (4662 et/ou 4772 de memoire, j'ai la flemme ). Il faut donc que ton routeur DHCP attribue toujours la meme IP à ton poste.

De plus , dans le pare feu . Pas besoin de DMZ, ce serait plutot un trou d'ailleurs en l'occurence.

Pour le pare feu : dansYAST > Sécurité > Pare feu > services autorisés > avancé ( le bouton en bas à droite) >

tu autorises :

TCP 4662

UDP 4665 4672

Comme tu as changé les ports d'amule, il faut adapter.

Ensuite, amule peut tourner en demon, sans interface graphique, par la commande amuled. Tu peux le lancer en tache de fond par amuled & , voire en processus autonome: nohup amuled & . mais tu verras ça quand tout sera au point

Pour suse :

Ce n'est pas une très bonne idée d'avoir un utilisateur appelé suse.

Link to comment
Share on other sites

Salut !!

pour que ton routeur puisse ouvrir les communication venant sur ta machine il faudrait que après ouverture sur le routeur que tu mette ton pc en mode ip statique avec l'adresse ip fournie au routeur au moment de la configuration

Link to comment
Share on other sites

pour que ton routeur puisse ouvrir les communication venant sur ta machine il faudrait que après ouverture sur le routeur que tu mette ton pc en mode ip statique avec l'adresse ip fournie au routeur au moment de la configuration

ou que ton routeur attribue toujours la meme IP à ton poste. Ou ne pas faire du DHCP , c'est plus contraignant,mais c'est plus solide.

Link to comment
Share on other sites

merci pour vos réponses, mais en fait je me suis aperçu d'un nouveau problème :sm:

qui ne concerne pas la mule...

j'avais aussi des problème sous vista (low id) !!!

j'ai ressorti un modem routeur olitec et je l'ai config. normalement :D

en ip fixe pour windows (emule high id ok) et je n'arrive pas encore à me connecter en ip fixe sur linux

je ne pige pas bien le réseau !!!

la je suis donc sur vista,

de mémoire sur kubuntu

adresse ip: 192.168.0.249

masque de sous réseau: 255.255.255.0

passerelle pare defaut: 192.168.0.250

et la je n'arrive pas à me connecter,

je peux acceder a mon routeur en tapant dans le navigateur: 192.168.0.250

mais rien de plus

je precise tout de même que sur ce modem routeur olitec je ne peux ouvrir des port seulement quand je suis en ip fixe ;)

j'déplace un peu le problème sur le reseau,

merci à vous

Link to comment
Share on other sites

T'as rajouté les DNS, pour ton Linux en IP fixe ? S'ils ne sont pas distribués par DHCP, va bien falloir les déclarer...

... ça résoudra au moins le problème qui est que tu as l'impression que tu n'es pas connecté au net, alors que si, probablement (vu que tu arrives au moins jusqu'au routeur), le seul problème étant que tu ne peux te connecter que si tu connais ton adresse IP de destination, vu que la résolution des noms ne marche pas... ie "ping google.fr" ne marchera probablement pas, alors que "ping 216.239.59.104" marchera, les deux étant pourtant la même chose.

D'ailleurs, il est possible que maintenant, la mule marche (vu que la redirection d'IP semble ne pouvoir se faire que sur IP fixe, ie pas de DHCP statique... mais en IP fixe, si c'est bien de la bonne cible qu'il s'agit, ça devrait le faire), et pas le web avec des noms de domaine :mdr:

Link to comment
Share on other sites

attention au forwarding ! :fume:

star-t.jpg

Ca, apparemment, c'est plus le genre de trucs qu'ils utilisent pour tout casser sans se déplacer chez les gens qui font les cons avec les ondes :transpi: ...

... mais, d'ici à ce que l'industrie des ayant-droits exige de bombarder les tipiaks (hardi, matelot ! ) avec ça ;)

Un petit coup de sandboxing pour les militants de l'excellence.. :zarb:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...