Jump to content

Archived

This topic is now archived and is closed to further replies.

Daemonium

Xorg.conf et TV-Out

Recommended Posts

Bien l'bonjour à tous,

J'm'explique. Ça fait depuis deux heures que j'essaie de configurer la sortie TV.. et j'y arrive pas.

J'ai les derniers drivers nvidia et j'ai essayé twinview : l'image sur la tv est de 1) moche ; 2) c'est un bureau étiré, et j'veux pas de ça. Je voudrais soit un bureau indépendant, soit un bureau "clôné".

J'ai donc testé la méthode avec deux serveurs X, expliqué sur la doc ubuntufr. En vain. Voilà donc mon fichier xorg.conf :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 20 16:56:19 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier	 "Default Layout"
Screen 0		"Screen0"  
Screen 1		"Screen1" RightOf "Screen0"
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
InputDevice	"stylus" "SendCoreEvents"
InputDevice	"cursor" "SendCoreEvents"
InputDevice	"eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath		"/usr/share/X11/fonts/misc"
FontPath		"/usr/share/X11/fonts/cyrillic"
FontPath		"/usr/share/X11/fonts/100dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/75dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/Type1"
FontPath		"/usr/share/X11/fonts/100dpi"
FontPath		"/usr/share/X11/fonts/75dpi"
FontPath		"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load		   "i2c"
Load		   "bitmap"
Load		   "ddc"
Load		   "extmod"
Load		   "freetype"
Load		   "glx"
Load		   "int10"
Load		   "type1"
Load		   "vbe"
EndSection

Section "InputDevice"
Identifier	 "Generic Keyboard"
Driver		 "kbd"
Option		 "CoreKeyboard"
Option		 "XkbRules" "xorg"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "ch"
Option		 "XkbVariant" "fr"
EndSection

Section "InputDevice"
Identifier	 "Configured Mouse"
Driver		 "mouse"
Option		 "CorePointer"
Option		 "Device" "/dev/input/mice"
Option		 "Protocol" "ExplorerPS/2"
Option		 "ZAxisMapping" "4 5"
Option		 "Emulate3Buttons" "true"
Option		 "Buttons" "7"
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "stylus"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "stylus"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "eraser"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "eraser"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "cursor"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "cursor"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier	 "Philips 190S"
Option		 "DPMS"
EndSection

Section "Monitor"
Identifier	  "Television" #TV
HorizSync	   28.0 - 33.0
VertRefresh	 43.0 - 72.0
Option		  "DPMS"
EndSection


Section "Device"
Identifier	 "Device0"
Driver		 "nvidia"
Option		 "NoLogo" "1" 
Screen		 0
EndSection
Section "Device"
Identifier	 "Device1"
Driver		 "nvidia"
Screen		  1
Option		 "TVOutFormat" "SVIDEO"
Option		 "TVStandard" "PAL-B"
Option		 "ConnectedMonitor" "TV"
BusID		  "PCI:01:00.0"
EndSection

Section "Screen"
Identifier	 "Screen0"
Device		 "Device0"
Monitor		"Philips 190S"
DefaultDepth	24
SubSection	 "Display"
	Depth	   1
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   4
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   8
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   15
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   16
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   24
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection

EndSection

Section "Screen"
Identifier	 "Screen1"
Device		 "Device1"
Monitor		"Television"
DefaultDepth	24
Option		 "metamodes" "TV: 640x480 +0+0"
SubSection	 "Display"
	Depth	   24
	Modes	  "800x600" "640x480"
EndSubSection
EndSection

Vous auriez une idée quoi faire? :chinois:

J'ai aussi installé nvtv, mais

dae@mozaruntu:~$ nvtv
Fatal: No supported video card found.

;)

Share this post


Link to post
Share on other sites

Allez, y'a bien quelqu'un qui a une idée ?

Bonjour,

Combien de carte graphique as-tu ? 1 ou 2 ?

Si on part du principe que tu as une seule carte graphique, et que tu veux activer le mode "clone" (bureau identique sur LCD et TV), alors essaye de renseigner ton fichier xorg.conf comme ci-dessous (n'oublie pas de faire une sauvegarde de ton fichier xorg.conf) :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 20 16:56:19 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier	 "Default Layout"
Screen 0		"Screen0"  
#Screen 1		"Screen1" RightOf "Screen0"
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath		"/usr/share/X11/fonts/misc"
FontPath		"/usr/share/X11/fonts/cyrillic"
FontPath		"/usr/share/X11/fonts/100dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/75dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/Type1"
FontPath		"/usr/share/X11/fonts/100dpi"
FontPath		"/usr/share/X11/fonts/75dpi"
FontPath		"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load		   "i2c"
Load		   "bitmap"
Load		   "ddc"
Load		   "extmod"
Load		   "freetype"
Load		   "glx"
Load		   "int10"
Load		   "type1"
Load		   "vbe"
EndSection

Section "InputDevice"
Identifier	 "Generic Keyboard"
Driver		 "kbd"
Option		 "CoreKeyboard"
Option		 "XkbRules" "xorg"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "ch"
Option		 "XkbVariant" "fr"
EndSection

Section "InputDevice"
Identifier	 "Configured Mouse"
Driver		 "mouse"
Option		 "CorePointer"
Option		 "Device" "/dev/input/mice"
Option		 "Protocol" "ExplorerPS/2"
Option		 "ZAxisMapping" "4 5"
Option		 "Emulate3Buttons" "true"
Option		 "Buttons" "7"
EndSection

Section "Monitor"
Identifier	 "Philips 190S"
Option		 "DPMS"
EndSection

Section "Monitor"
Identifier	  "Television" #TV
HorizSync	   28.0 - 33.0
VertRefresh	 43.0 - 72.0
Option		  "DPMS"
EndSection

Section "Device"
Identifier	 "Device0"
Driver		 "nvidia"
Option		 "NoLogo" "1"
Option		 "TVOutFormat" "SVIDEO"
Option		 "TVStandard" "PAL-B"
Option		 "TwinView"  "1"
Option		 "SecondMonitorHorizSync"  "28-33"
Option		 "SecondMonitorVertRefresh"  "43-72"
Option		 "TwinViewOrientation"  "clone"
Option		 "MetaModes"	"800x600,640x480"
Option		 "ConnectedMonitor"	"DFP, TV"
Option		 "IgnoreDisplayDevices"  "CRT"
BusID		  "PCI:1:0:0"
EndSection

Section "Screen"
Identifier	 "Screen0"
Device		 "Device0"
Monitor		"Philips 190S"
DefaultDepth	24
SubSection	 "Display"
	Depth	   1
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   4
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   8
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   15
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   16
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   24
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection

EndSection

Sinon fait une recherche sur le forum avec "twinview" = > Twinview

Ou bien => Wiki twinview

Bon courage.

Share this post


Link to post
Share on other sites

salut

Si tu veux du clone, c'est Twinview obligatoire...

http://doc.ubuntu-fr.org/materiel/nvidia_tvout

Par contre moi j'ai remarqué que ma ATI clône tout se qui se passe (même le BIOS, grub, etc...), donc quand je laisse le Xorg de base, puis que je démarre mon PC avec le câble branché, tout marche.

On a beau ch*** sur la gueule des drivers ATI, mais sur ce coup là, rien a configuré, j'ai littéralement été bluffé !!

Essaye, je serais curieux de voir si les nvidia le font.

Share this post


Link to post
Share on other sites

Ok, alors dans ce cas, vire tout ce que tu a mis, comme si t'avait qu'un seul écran quoi, et ça va marcher :)

Share this post


Link to post
Share on other sites

Ah ben tiens justement ce soir je me suis mis en tête de brancher mon PC portable (7600Go inside) sur une des télés chez moi...

Bon premier constat (après de nombeux essais) : pas moyen de faire marcher la sortie composite.

Après avoir testé sur une carte TV d'un autre PC, la sortie Svideo a l'air de bien marcher, et coup de chance, j'ai le Svideo disponible sur une des TV (enfin plus précisément sur le lecteur DVD d'une des TV).

J'ai pu tester les films et des jeux sur la TV, c'est sympa ;)

Voici donc le xorg.conf qui marche dans mon cas (sans Twinview, donc avec 2 écrans "séparés", et sans xinerama, pour pouvoir mettre en plein écran et faire ce que je veux avec chacun) :

Section "Files"
FontPath	"/usr/share/X11/fonts/misc"
FontPath	"/usr/share/X11/fonts/cyrillic"
FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
FontPath	"/usr/share/X11/fonts/Type1"
FontPath	"/usr/share/X11/fonts/100dpi"
FontPath	"/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load	"extmod"
Load	"glx"
Load	"dbe"
EndSection

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver		"kbd"
Option		"CoreKeyboard"
Option		"XkbRules"	"xorg"
Option		"XkbModel"	"pc105"
Option		"XkbLayout"	"fr"
Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
Identifier	"Configured Mouse"
Driver		"mouse"
Option		"CorePointer"
Option		"Device"		"/dev/input/mice"
Option		"Protocol"		"ExplorerPS/2"
Option		"ZAxisMapping"		"4 5"
Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
Identifier	"Synaptics Touchpad"
Driver		"synaptics"
Option		"SendCoreEvents"	"true"
Option		"Device"		"/dev/psaux"
Option		"Protocol"		"auto-dev"
Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
Identifier	"NVIDIA device 1"
Driver		"nvidia"
BusID		"PCI:1:0:0"
Screen		0
EndSection

Section "Monitor"
Identifier	"autodetected"
Option		"DPMS"
EndSection

Section "Screen"
Identifier	"Default Screen"
Device		"NVIDIA device 1"
Monitor		"autodetected"
DefaultDepth	24
SubSection "Display"
	Depth		24
	Modes		"1600x1200" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Section "Device"
Identifier	"NVIDIA TV device"
Driver		"nvidia"
BusID		"PCI:1:0:0"
Screen		1
Option		"ConnectedMonitor" "TV"
#	Option		"TVOutFormat" "COMPOSITE"
Option		"TVStandard" "PAL-N"
Option		"UseEDID"	"false"
EndSection

Section "Monitor"
Identifier	"TVmonitor"
HorizSync	30-50
VertRefresh	60
EndSection

Section "Screen"
Identifier	"TVscreen"
Device		"NVIDIA TV device"
Monitor		"TVmonitor"
DefaultDepth	16
SubSection "Display"
	Depth		16
	Modes		"800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier	"Default Layout"
Screen		"Default Screen"
Screen		"TVscreen" rightof "Default Screen"
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
InputDevice	"Synaptics Touchpad"
EndSection

Share this post


Link to post
Share on other sites

×
×
  • Create New...