Jump to content

Karno

INpactien
  • Contenu

    4
  • Inscription

  • Dernière visite

À propos de Karno

  • Rang
    Ewok
  1. Bonsoir RaphAstronome J'ai ouvert 4 ports sur ma box 80, 21, 443, 3306 tous redirigés vers l'ip du RPI avec le même port
  2. Bonjour et merci pour ta réponse En fait le nom de mon site était couveuse et non couveuse.fr mais j'ai créé les répertoires pour couveuse.fr Le truc simple c'est que le /etc/nginx/sites-available/couveuse.fr n'existait pas, je connais un peu IIS (et encore) mais pas du tout nginx, les répertoires /srv/www/couveuse.fr/logs/ public et acces non plus c'est fait et maintenant .... tinlinlin en local cela fonctionne j'ai bien mon index.php qui s'affiche avec l'écho que j'ai rajouté. Nickel!! Mais de l'extérieur il me propose toujours de télécharger ce foutu machin. J'ai une question, ou dois je regarder dans un fichier log ou erreur ou acces ce qui se passe au niveau du serveur (pas de couveuse.fr) mais plus généralement ? car quand je tape l'@ en local et que je regarde les fichiers cat /srv/www/couveuse.fr/logs/error.log rien (normal) et le fichier acces j'ai les GET HTTP qui vont bien. Je purge le fichier access et je relance avec l'IP de ma box et là rien du tout Donc je ne sais pas ou regarder pour voir si l'ip de ma box est bien configuré sur nginx et surtout OU .... Merci et bonne fin de dimanche. Arno En fait le pb est peut être en dehors de Nginx car j'ai eu besoin d'installer un truc pour l'heure du raspberry et la commande apt-get install ntpdate plantait sur la résolution d'une adresse mirror ... J'ai tenté un ping free.fr ou ping google.fr et rien du tout alors que sur mon poste windows cela fonctionne correctement (les 2 sont derrières la free box) j'ai donc du raté quelque chose sur ton tuto !! gloups !!!
  3. Bonsoir, Bon, j'ai supprimé le 2ième routeur et ai connecté le raspberry direct derrière la freebox plus simple surtout pour un débutant Je suis allé dans l'interface de paramétrage de la box pour faire les redirections des port 80, 443, 21, 3306 vers l'ip de mon raspberry avec le même port. Coté raspberry je lui ai collé une ip fixe En revanche aucune idée pour le lookback et free, j'ai cherché mais .. voici l'extrait de mon /etc/network/interfaces auto loiface lo inet loopbackauto eth0iface eth0 inet static address 192.168.0.35 netmask 255.255.255.0 network 192.168.0.254 broadcast 192.168.1.255 gateway 192.168.1.1auto wlan0allow-hotplug wlan0iface wlan0 inet staticaddress 192.168.0.50netmask 255.255.255.0gateway 192.168.0.1wpa-ssid xxxxxxwpa-psk xxxxxx J'ai lu sur un site internet (ici) qu'il fallait mettre 254 pour les free box. bon ben ok alors !! Ensuite, j'ai vu qu'il fallait bricolé le /etc/nginx/sites-available/default pour rajouter server { #listen 80; ## listen for ipv4; this line is default and implied #listen [::]:80 default_server ipv6only=on; ## listen for ipv6 root /usr/share/nginx/www; index index.html index.htm; # Make site accessible from http://localhost/ server_name ip de ma box; Je l'ai fait et maintenant lorsque je tape l'IP de ma box depuis mon pc derrière la box j'obtiens un Welcome to nginx!, J'ai pas pu tester avec mon smartphone pour ne pas passer par le même réseau car je suis alimenté avec les corbeaux coté débit. Me reste donc à trouver comment rediriger nginx vers le site que je souhaite. J'ai trouvé entre temps, j'ai remplacé root /usr/share/nginx/www par /srv/www/couveuse/public et ai rajouté index.php pour afficher le phpinfo(); dans la foulée. Je viens de re démarrer nginx Et manque de bol lorsque je demande l'ip de ma box, il me propose de télécharger le fichier, C'est le type mime qui est pas correct ?? A plus et merci pour votre réactivité. Bonne soirée Arno
  4. Bonjour crocodudule et merci pour ton tuto très complet. Je suis débutant dans le monde du raspberry et des serveurs linux. J'ai suivi ton tuto jusqu'au bout mais je me pose une question. Je suis censé avoir un rasberry accessible de l'extérieur et ceci en tapant l'IP de ma box, mais manque de bol lorsque je tape cette ip j'obtiens la page de l'information FreeBox et non pas le phpinfo(), phpinfo qui fonctionne très bien en réseau local. Est-ce un paramétrage dans ma box ? Autre information, ma box est routeur et je suis aussi derrière un autre routeur. Peux tu éclairer ma lanterne ? Merci pour ton retour d'information Bonne continuation Arno
×