Jump to content

livebox en wifi et linux


fcyp

Recommended Posts

Bonjour a tous,

étant depuis longtemps sous windows, et ayant une grosse hausse de bug et autres trucs assez épuisants, je me suis mis en tête de voir si linux était à la hauteur de la réputation qu'on lui donne; j'ai donc, après lecture d'un bon gros tas de tutos, téléchargé le live-cd Knoppix pour tester la bête (avec, pourquoi pas, un voisinage avec avec windows plus tard ..).

Téléchargement, gravage, lancement de Knoppix se passent sans aucuns problèmes, c'est seulement quand je veux me connecter a internet que les ennuis commencent: je suis normalement connecté avec la Livebox Iventel et par Wi-fi (802.11G), mais sous linux, aucun adaptateur Wi-fi n'est reconnu, quand j'essaie d'installer les drivers (PRISMA02.inf), j'ai un message d'erreur au niveau de la commande "modprobe ndiswrapper" avec une réponse du genre "FATAL ndiswrapper not found" (ou un truc dans le genre).

Voilà, malgrés de nombreuses recherches, je n'ai rien trouvé .. (peut-être que je cherche mal :), et j'espère trouver une aide des plus précieuses ici :).

Si vous souhaitez d'autres précisions, n'hésitez pas, je ferais de mon mieux pour les apporter.

Sur-ce, merci d'avance et bonne soirée.

Link to comment
Share on other sites

Bonjour,

on peut en effet penser cela, mais:

1) les premieres commandes marchent, et elles sont aussi composées de ndiswrapper;

2) je ne sais pas comment installer ndsiwrapper ( :cartonjaune: ).

Et normalement, même sans le driver d'installé, le Wi-fi devrait s'allumer, non? (ce n'est pas le cas)

Voila, voila, merci pour ta réponse ;-)

Link to comment
Share on other sites

Tu as peut-être les ndiswrapper-utils installé mais sans "ndiswrapper-module", ça n'ira jamais.

C'est comme si tu disais sous Windows que ton Dongle ne va pas et que tu n'as pas installé le drivers...

Sinon, fais un

apt-cache search ndiswrapper

Et installe celui correspondant à ton kernel.

PS: Dis moi que c'est la Livebox FR et non la Belge, sinon, je réponds plus...

Link to comment
Share on other sites

Tyrann27, bon un café, la Trappiste te réussit pas trop là :reflechis:

Sinon, comme le monsieur l'a dit, une Livebox Inventel avec un Dongle Wifi qui utilise prisma02.inf.

Donc pour répondre, oui, obligé ndiwrapper (j'ai le même driver et pas d'autres solutions) et oui, on a des Livebox en Belgique (Mobistar ADSL, là où je bosse d'ailleurs).

Link to comment
Share on other sites

Bonjour à tous ! (et désolé pour le retard, je suis plutôt couche-tôt :),

Tout d'abord, merci beaucoup pour vos aides,

je n'avais en effet pas essayé cette comma,de j'eesaierais dès ce soir;

pour le modèle de ma carte, je n'ai pas d'autres renseignements que 802.11G USB 2.0 adaptater;

Voilà, à bientot messieurs-dames.

PS: Non, non, c'est bon j'utilise bien la Livebox Fr :reflechis:

Link to comment
Share on other sites

Bonjour,

Bon j'ai essayé d'installer le module, mais ...

Apparament quand je compile les fichiers, il trouve pas /UNIONFS/usr/scr/linux2.6.17/scripts et /UNIONFS/usr/scr/linux2.6.17.arch...

Pour y faire je ne sais quoi dedans (les fichiers a compiler sont dans /home/knoppix/ndiswrapper-1.30).

Est-ce qu'il me manque des fichiers a cause d'une mauvaise gravure? dans ce cas pourquoi il boot quand même?

Voila, merci de votre aide et de votre patience envers un vrai, pur et dur débutant. :)

Link to comment
Share on other sites

fais un

apt-cache search ndiswrapper

ne compile pas, tu le feras (si tu veux) plus tard quand tu seras grand :-p

:yes:

Je m'explique, quand j'entre cette commande, j'ai 3 propositions que je ne sais pas utiliser; j'ai donc cherché un tuto pour installer ndiswrapper, et apparament il fallait le compiler en utilisant "make" puis "make install".

Je peux aller chercher les 3 propositions si tu en a besoin, cependant c'est assez chiant de tout eteindre, de booter su linux etc .. très long :) alors je le ferais que si c'est utile. :D

Link to comment
Share on other sites

Bonjour,

Bon, la commande "apt-cache search ndiswrapper"

me répond :

-"ndiswrapper-common";

-"ndiswrapper-utils-1.7";

-"knoppix-ndiswrapper";

ce qui diffère de ce que tu m'as dis, mais peu importe, j'entrepends alors d'installer en premier "ndiswrapper-utils-1.7" (puisque c'est celui que nous avons en commun)..et la j'obtiens :" [...] est déjà la plus récente version disponible 0mis à jour 0nouvellement 0 à enlever et 0 non mis à jour" j'ai donc essayé avec les autres commandes..même réponses a chaque fois .. ([...] correspond a la commande choisie).

Est-ce que ma commande d'installation c'est pas la bonne ? (à savoir "apt-get install [...])

Voila merci de ta patience, merci d'avance et A+ !

Link to comment
Share on other sites

Bonjour,

quand j'entre ce message, il me répond:

knoppix-ndiswrapper

installé:0.1-3

candidat:0.1-3

table de version:

*** 0.1-30

/var/lib/dpkg/stats

Et sinon j'ai re-essayé d'installer le driver a partir de "configurer une passerelle domestique"

et à la fin, il me dit "driver installed, hardware present" et que, normalement, cela devrait marcher ... mais toujours rien.

Link to comment
Share on other sites

Bonjour,

le "ndiswrapper -l" me dit "PRISMA02 driver present, hardware present

donc ça apparament, c'est bon

mais quand je fais "iwconfig", jai:

lo no wireless extension

eth0 no wireless extension

sit0 no wireless extension

hum.. recompiler ..si je dois en arriver a là (peut-être en demande-je trop?) pourrais tu me guider dans les différentes étapes de cette manip ?

merci encore, a+

Link to comment
Share on other sites

Bah recompiler ndiswrapper, c'est pas réellement dur, une fois que tu as installé linux-headers-ta_version il suffit de décompresser ndiswrapper-X.X.tar.gz et d'aller dans le répertoire puis tapper

make && sudo make install

et basta; c'est fait...

Sinon, il y a un tuto pour compiler ndiswrapper et en faire un package pour une debian-like sur leur wiki.

Pour en revenir à ton problème, je présume que si tu fais un

sudo modprobe ndiswrapper

Tu as toujours ton erreur de module not found?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...