Jump to content

[Semi-Debutant] Probleme boot sur nouveau kernel


Recommended Posts

Bonjour à tous !

C'est mon 1er post sur ce forum, ça faisait quelques semaines que je ne faisais que lire vos articles et posts plutot interessants.

J'espere ne pas passer pour le boulet de service mais j'ai un problème pour compiler/booter sur un nouveau noyau.

Ca fait 1 semaine que j'essaye mais ça ne passe pas, toujours ce fichu kernel panic au boot :

Kernel panic - not syncing : VFS : Unable to mount root fs on unknown-block(0,0)

Je suis sous Ubuntu Dapper.

Je vous décris ce que j'ai fait.

j'ai téléchargé sur kernel.org les dernieres sources stables : linux-2.6.18.tar.bz2

J'ai décompressé l'archive dans /usr/src

make menuconfig

j'ai pas trop touché à la config

make-kpkg clean

make-kpkg --append-to-version=-new001 kernel_image

dpkg -i kernel-image-2.6.18-new001_10.00.Custom_i386.deb

Ensuite reboot, et... kernel panic :francais:

j'ai persévéré !

make menuconfig

j'ai configuré le noyau à l'aide de ce lien : ici

make-kpkg clean

make-kpkg --append-to-version=-new001 kernel_image

dpkg -i kernel-image-2.6.18-new001_10.00.Custom_i386.deb

Reboot...toujours kernel panic... :francais:

j'ai encore persévéré !!

j'ai pris le .config de mon noyau de base :

cp /usr/src/linux-headers-2.6.15-27-386/.config /usr/src/linux-2.6.18/

make menuconfig => quelques warnings car le .config n'allait pas à 100%

make-kpkg clean

make-kpkg --append-to-version=-new001 kernel_image

dpkg -i kernel-image-2.6.18-new001_10.00.Custom_i386.deb

Reboot... kernel panic !! :transpi:

Là je sais plus quoi faire, car bizarre que meme avec le .config de mon noyau opérationel ça boot pas...

Je vous donne quelques infos sur mon hardware :

Carte mere asus A8N-E

Carte graphique geforce 7600GT

Disque Dur Sata II

Proc AMD Dual Core

Voilà, j'espere que vous aurez une explication :francais:

Bonne soirée

Sorry

Link to comment
Share on other sites

Si tu as utilisé le fichier .config, tu as un problème alors car Ubuntu utilise un initrd.

De plus, il y a eu beaucoup de changement depuis le kernel 2.6.15 (notamment point de vue iptables).

Si tu veux, j'ai le fichier générique de Debian (aussi avec initrd) mais bon, au moins tu seras sûr du fichier.

Link to comment
Share on other sites

Kernel panic - not syncing : VFS : Unable to mount root fs on unknown-block(0,0)
Quand j'ai cette erreur, je rajoute root=/dev/sda1 (ou la partition root si ce n'est pas sda1) et ça roule.

Tu veux dire que ça viendrait pas de la compilation du noyau mais de mon loader (Grub) ?

Je vous met mon menu.lst, mais il me semble bon..

title Ubuntu, kernel 2.6.18-new001

root (hd0,0)

kernel /boot/vmlinuz-2.6.18-new001 root=/dev/sda1 ro quiet splash

savedefault

boot

title Ubuntu, kernel 2.6.18-new001 (recovery mode)

root (hd0,0)

kernel /boot/vmlinuz-2.6.18-new001 root=/dev/sda1 ro single

boot

title Ubuntu, kernel 2.6.15-27-386

root (hd0,0)

kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/sda1 ro quiet splash

initrd /boot/initrd.img-2.6.15-27-386

savedefault

boot

title Ubuntu, kernel 2.6.15-27-386 (recovery mode)

root (hd0,0)

kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/sda1 ro single

initrd /boot/initrd.img-2.6.15-27-386

boot

title Ubuntu, memtest86+

root (hd0,0)

kernel /boot/memtest86+.bin

boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian

# ones.

title Autres systemes:

root

# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sda3

title Microsoft Windows XP Professionnel

root (hd0,2)

savedefault

makeactive

chainloader +1

Comme tu peux le voir, root=/dev/sda1 y est deja :(

Link to comment
Share on other sites

J'ai refait un essais !

cd /usr/src/linux

cp ../linux-headers-2.6.15-27-386/.config .

make menuconfig (rien touché)

make-kpkg --initrd --append-to-version=-new001 kernel_image

dpkg --install ../kernel-image-2.6.18-new001_10.00.Custom_i386.deb

Reboot.. pas de kernel panic ! mais un superbe ecran noir...fausse joie :chinois:

Link to comment
Share on other sites

Mon problème vient probablement des drivers SATA...j'ai peut etre oublié une option.

Vous pouvez me dire dans quelles rubriques il y a des options SATA à imperativement mettre en dur svp :transpi:

Merci pour votre aide.

Link to comment
Share on other sites

J'ai peut etre trouvé le problème (du moins j'en ai trouvé un..), les options suivantes n'etaient pas en dur mais en module :

Device Drivers > SCSI device support > SCSI low-level drivers ==> Serial ATA (SATA) support

Device Drivers > SCSI device support > SCSI low-level drivers ==> NVIDIA SATA support

Voilà je suis en train de recompiler pour la 100ème fois en esperant que ça soit la bonne :transpi:

Link to comment
Share on other sites

J'y suis presque ! :pleure:

J'ai recompilé et reessayé avec ces dernieres options et il y a du mieux !

Plus de kernel panic, un ecran noir mais qui se termine par un message d'erreur !

Impossible de demarrer le serveur X

Fatal : Module nvidia not found

(EE) NVIDIA(0) : Failed to load the NVIDIA kernel module !

(EE) NVIDIA(0) : ** abording **

(EE) Screen(s) found, but none have a usable configuration

Ensuite j'arrive au login en mode texte, donc le probleme SATA est règlé.

Suffit maintenant que je trouve comment loader le nvidia kernel module ! :byebye:

Link to comment
Share on other sites

J'y suis presque !

J'ai recompilé, rebooté sur le nouveau kernel, et installé les pilotes nvidia en mode texte :

sh NVIDIA-Linux-x86-1.0-8774-pkg1.run

L'installation a généré quelques warnings à la fin (4 je crois) mais pas d'erreur.

Je reboot, mais toujours ecran noir, je n'ai plus la page avec marqué Ubuntu en orange et la barre de progression...

Au bout d'une minute => page de login (en mode graphique ce coup ci :bretagne: )

Je me logg, et là aussi il manque quelque chose : je n'ai pas la barre de chargement au milieu (chargement du gestionnaire de fenetre..etc..)

Sinon ça a l'air de fonctionner correctement (la preuve j'ecris ce post sur ce kernel).

Voilà reste plus que ces 2 petits problèmes à gerer et ça sera parfait :ouioui:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...