Jump to content

Dual screen Plein écran


Boo54

Recommended Posts

Hello

Je suis actuellement sur Ubuntu 6.06, j ai configurer mon dualscreen qui fonctionne mais quant je lance une appli style jeux en pleine ecran je me retrouve avec le jeux couper au milieu des 2 ecrans comment mettre le jeux en pleine ecran sur 1 seul ?

@++ :mdr:

Link to comment
Share on other sites

Chez moi j'utilise Xgame, c'est un petit prog en python je crois qui te permet de lancer un deuxième X avec un fichier de conf différent. Du coup tu peux avoir ton 1er X avec dual screen + Xgl peut-être et ton deuxieme X avec lancé ton Nexuiz ou ET en full screen mais sur un seul écran :incline:. Du coup pas de problème de dual screen, possibilité de swapper entre les deux X et meilleures perfs vu que la CG s'occupe que d'un screen... que du bon ;)

Regarde donc par ici

Enjoy ;)

Link to comment
Share on other sites

Oh ça m'interresse aussi du coup :D

Merci :up:

EDIT: c'est en Perl, mais bon c'est bien tout de même... (un troll s'est caché dans ce message, à vous de le débusquer...)

Où ça le troll? Moi je vois rien :transpi:

Et de rien de rien :sucre: . Ca fait plaisir des petits progs pratiques comme celui-ci

Petit tip... si tu crées un nouveau xorg.conf (çayçakiébien :transpi:) essaie de le laisser dans /etc/X11/ parce que sinon tu pourras pas lancer de X avec, étant donné qu'en tant que user, tu ne peux pas utiliser des fichiers de confs de n'importe où. Enfin c'est ce qui m'est arrivé à moi... Du coup après tu mets dans le champ "Xconfig file" : "xorg-2.conf" sans le chemin complet. Et ça roule... Voilà pour mon expérience personnelle :cartonrouge:

Enjoy :cartonrouge:

Link to comment
Share on other sites

Merci pour ce petit Logiciel mais :francais:

Je ai reussi a le configurer comme expliquer par le liens et recreer un Xorg_mono.conf, mais quant je lance UT2004 j ai le logo de demarage sur l ecran principal et ensuite ca revien en dual screen :(

voici mon xorg_mono.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon May 15 13:23:42 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier	 "Default Layout"
Screen		 "Default Screen" 0 0
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
InputDevice	"stylus" "SendCoreEvents"
InputDevice	"cursor" "SendCoreEvents"
InputDevice	"eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath		"/usr/share/X11/fonts/misc"
FontPath		"/usr/share/X11/fonts/cyrillic"
FontPath		"/usr/share/X11/fonts/100dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/75dpi/:unscaled"
FontPath		"/usr/share/X11/fonts/Type1"
FontPath		"/usr/share/X11/fonts/100dpi"
FontPath		"/usr/share/X11/fonts/75dpi"
FontPath		"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load		   "i2c"
Load		   "bitmap"
Load		   "ddc"
Load		   "extmod"
Load		   "freetype"
Load		   "glx"
Load		   "int10"
Load		   "type1"
Load		   "vbe"
EndSection

Section "InputDevice"
Identifier	 "Generic Keyboard"
Driver		 "kbd"
Option		 "CoreKeyboard"
Option		 "XkbRules" "xorg"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "fr"
Option		 "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier	 "Configured Mouse"
Driver		 "mouse"
Option		 "CorePointer"
Option		 "Device" "/dev/input/mice"
Option		 "Protocol" "ExplorerPS/2"
Option		 "ZAxisMapping" "4 5"
Option		 "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "stylus"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "stylus"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "eraser"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "eraser"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "InputDevice"

												  # /dev/input/event
												  # for USB
Identifier	 "cursor"
Driver		 "wacom"
Option		 "Device" "/dev/wacom"		  # Change to 
Option		 "Type" "cursor"
Option		 "ForceDevice" "ISDV4"			   # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier	 "hp f1723"
Option		 "DPMS"
EndSection

Section "Device"
Identifier	 "NVIDIA Corporation NV43 [GeForce 6600 GT]"
Driver		 "nvidia"

EndSection

Section "Screen"
Identifier	 "Default Screen"
Device		 "NVIDIA Corporation NV43 [GeForce 6600 GT]"
Monitor		"hp f1723"
DefaultDepth	24
SubSection	 "Display"
	Depth	   1
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   4
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   8
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   15
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   16
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection	 "Display"
	Depth	   24
	Modes	  "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Link to comment
Share on other sites

Oki merci

Mais sinon j ai une autre question comment je fais pour utiliser par exemble Vmware en plein ecran mais sur un seul pas comme les jeux :up:

Voia quant je lance Xgame par la console :)

boo@boo:~$ /usr/bin/xgame/xgame-gtk2
Starting Unreal Tournament 2004...
xauth:  creating new authority file /home/boo/.serverauth.15247


X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 i686
Current Operating System: Linux boo 2.6.15-26-386 #1 PREEMPT Fri Sep 8 19:55:17 UTC 2006 i686
Build Date: 16 March 2006
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.2.log", Time: Thu Sep 21 10:30:48 2006
(++) Using config file: "/etc/X11/xorg_mono2.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:		  Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>				   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
	No such file or directory.
Error opening /dev/wacom : No such file or directory
WARNING: ALC_EXT_capture is subject to change!
Couldn't set video mode: No video mode large enough for 1600x1024


History:

Exiting due to error

waiting for X server to shut down FreeFontPath: FPE "/usr/share/X11/fonts/misc" refcount is 2, should be 1; fixing.


Impossible d'obtenir un descripteur de fichier se référant à la console

Link to comment
Share on other sites

(EE) xf86OpenSerial: Cannot open device /dev/wacom

Là apparemment /dev/wacom doit pas exister, ou il y'a un problème avec la souris... je sais pas trop ce que ça peut être mais c'st en relation avec ta Section "InputDevice" de ton Xorg où tu parles de ta souris, je peux pas t'en dire plus... :transpi:

Couldn't set video mode: No video mode large enough for 1600x1024

Et là si je comprends bien, X essaie de se lancer en 1600x1024 mais cette résolution n'est pas indiquée dans ta partie Modes de ton xorg.conf... :smack: Je ne sais pas trop ce qu'il faut modifier, mais essaie de comparer ton xorg-dual avec ton xorg-jeux... :yes:

Mais sinon j ai une autre question comment je fais pour utiliser par exemble Vmware en plein ecran mais sur un seul pas comme les jeux

Je n'ai jamais utilisé VMware mais si tu le lances en windowed mode tu dois bien pouvoir te le poser où tu veux sur l'un des tes écrans nan?

Bonne chance :francais:

Link to comment
Share on other sites

(EE) xf86OpenSerial: Cannot open device /dev/wacom

Là apparemment /dev/wacom doit pas exister, ou il y'a un problème avec la souris... je sais pas trop ce que ça peut être mais c'st en relation avec ta Section "InputDevice" de ton Xorg où tu parles de ta souris, je peux pas t'en dire plus... :transpi:

Couldn't set video mode: No video mode large enough for 1600x1024

Et là si je comprends bien, X essaie de se lancer en 1600x1024 mais cette résolution n'est pas indiquée dans ta partie Modes de ton xorg.conf... :transpi: Je ne sais pas trop ce qu'il faut modifier, mais essaie de comparer ton xorg-dual avec ton xorg-jeux... :byebye:

Mais sinon j ai une autre question comment je fais pour utiliser par exemble Vmware en plein ecran mais sur un seul pas comme les jeux

Je n'ai jamais utilisé VMware mais si tu le lances en windowed mode tu dois bien pouvoir te le poser où tu veux sur l'un des tes écrans nan?

Bonne chance :transpi:

Non il a une ubuntu c'est normal jai le meme message, enfin par defaut il load (enfin il essaye ) de loader le pilote wacom ..

Link to comment
Share on other sites

(EE) xf86OpenSerial: Cannot open device /dev/wacom

Là apparemment /dev/wacom doit pas exister, ou il y'a un problème avec la souris... je sais pas trop ce que ça peut être mais c'st en relation avec ta Section "InputDevice" de ton Xorg où tu parles de ta souris, je peux pas t'en dire plus... :chant:

Couldn't set video mode: No video mode large enough for 1600x1024

Et là si je comprends bien, X essaie de se lancer en 1600x1024 mais cette résolution n'est pas indiquée dans ta partie Modes de ton xorg.conf... :mdr2: Je ne sais pas trop ce qu'il faut modifier, mais essaie de comparer ton xorg-dual avec ton xorg-jeux... :non:

Mais sinon j ai une autre question comment je fais pour utiliser par exemble Vmware en plein ecran mais sur un seul pas comme les jeux

Je n'ai jamais utilisé VMware mais si tu le lances en windowed mode tu dois bien pouvoir te le poser où tu veux sur l'un des tes écrans nan?

Bonne chance :p

Non il a une ubuntu c'est normal jai le meme message, enfin par defaut il load (enfin il essaye ) de loader le pilote wacom ..

Donc que faut il faire exactement pour regler ce probleme et merci a vous pour votre aide :yes:

@++

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...