Jump to content

Ubuntu Dapper Drake + Samba et fichier "smbusers"


Recommended Posts

Bonjour,

Etant déjà allé sur les sites principaux et ne trouvant toujours pas de réponses à mon problème, je décide de venir voir chez vous si la réponse s'y trouve.

J'ai déjà fais des recherches sur le forum, mais je n'y trouve pas mas réponse.

(Pourquoi mon fichier smbusers dans /etc/samba/ ne se crée pas !!!!)

Mon problème :

Installation de base Ubuntu 6.06 Dapper Drake Serveur (Version ligne de commande).

Je rentre en :

sudo -s

Je fais en premier lieux mes mises à jours :

apt-get update ensuite apt-get updrade

Après j'installe samba :

apt-get install samba

Mais à la fin des messages d'erreurs apparaîssent (messages ci dessous) :

*************************************************************

Dépaquetage de samba (Ã partir de .../samba_3.0.22-1ubuntu3.1_i386.deb) ...

Paramétrage de samba (3.0.22-1ubuntu3.1) ...

Generating /etc/default/samba...

Unknown parameter encountered: "SO_RCVBUF"

Ignoring unknown parameter "SO_RCVBUF"

TDBSAM version too old (0), trying to convert it.

TDBSAM converted successfully.

account_policy_get: tdb_fetch_uint32 failed for field 1 (min password length), r eturning 0

account_policy_get: tdb_fetch_uint32 failed for field 2 (password history), retu rning 0

account_policy_get: tdb_fetch_uint32 failed for field 3 (user must logon to chan ge password), returning 0

account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum password age), returning 0

account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum password age), returning 0

account_policy_get: tdb_fetch_uint32 failed for field 6 (lockout duration), retu rning 0

account_policy_get: tdb_fetch_uint32 failed for field 7 (reset count minutes), r eturning 0

account_policy_get: tdb_fetch_uint32 failed for field 8 (bad lockout attempt), r eturning 0

account_policy_get: tdb_fetch_uint32 failed for field 9 (disconnect time), retur ning 0

account_policy_get: tdb_fetch_uint32 failed for field 10 (refuse machine passwor d change), returning 0

* Starting Samba daemons... [ ok ]

*************************************************************

Par contre j'ai appris que le chemin de dépôt n'était par correct :

Generating /etc/default/samba... il devrait plutôt être dans /etc/samba

Je vous indique aussi ma configuration du smb.conf

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of

workgroup = VROUVROUM

# server string is the equivalent of the NT Description field

server string = VROUMVROUM

# Windows Internet Name Serving Support Section:

# WINS Support - Tells the NMBD component of Samba to enable its WINS Server

; wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client

# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both

; wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.

dns proxy = no

# What naming service and in what order should we use to resolve host names

# to IP addresses

; name resolve order = lmhosts host wins bcast

*************************************************************

####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account

# in this server for every user accessing the server. See

# /usr/share/doc/samba-doc/htmldocs/Samba-HOWTO-Collection/ServerType.html

# in the samba-doc package for details.

security = user

#Fichier utilisateurs

username map = /etc/samba/smbusers

# Emplacement du fichier de mots de passes

smb passwd file = /etc/samba/smbpasswd

# You may wish to use password encryption. See the section on

# 'encrypt passwords' in the smb.conf(5) manpage before enabling.

encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what

# password database type you are using.

passdb backend = tdbsam

obey pam restrictions = yes

guest account = nobody

invalid users = root

# This boolean parameter controls whether Samba attempts to sync the Unix

# password with the SMB password when the encrypted SMB password in the

# passdb is changed.

unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following

# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for

# sending the correct chat script for the passwd program in Debian Sarge).

passwd program = /usr/bin/passwd %u

passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes

# when requested by an SMB client instead of the program listed in

# 'passwd program'. The default is 'no'.

pam password change = yes

*************************************************************

############ Misc ############

# Using the following line enables you to customise your configuration

# on a per machine basis. The %m gets replaced with the netbios name

# of the machine that is connecting

include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.

# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/speed.html

# for details

# You may want to add the following on a Linux system:

SO_RCVBUF=8192 SO_SNDBUF=8192

socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package

# installed. The samba maintainer and the linpopup maintainer are

# working to ease installation and configuration of linpopup and samba.

; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this

# machine will be configured as a BDC (a secondary logon server), you

# must set this to 'no'; otherwise, the default behavior is recommended.

; domain master = auto

# Some defaults for winbind (make sure you're not using the ranges

# for something else.)

; idmap uid = 10000-20000

; idmap gid = 10000-20000

; template shell = /bin/bash

*************************************************************

Tout cela est peut-être lourd, mais je ne comprend pas et je demande votre aide, merci bien.

CyberLayer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...