Jump to content

[Resolu] [Debian] https, php4 et cacti


Recommended Posts

bonjour à tous,

j'ai un serveur Debian 2.6.12-2-686 sur lequel j'ai installé cacti version 0.8.6h

je l'ai compilé à la main :transpi::transpi:

j'ai ensuite mis tous les fichiers cacti dans /var/www/cacti

j'ai suivi la documentation sur ce site

http://www.debianhelp.co.uk/cactifromsource.htm

j'utilise aussi ssl sur ce serveur couplé avec apache2 :youhou:

j'ai aussi créé un virtualHost pour cacti dans /etc/apache2/sites-enabled , dont voici la configuration :


<VirtualHost @IP:443>[img]
	ServerName cacti.mondomaine.com:443
	SSLEngine On
	SSLCertificateFile /etc/apache2/ssl/phoenix.crt
	SSLCertificateKeyFile /etc/apache2/ssl/phoenix.key
	DocumentRoot /usr/local/cacti-0.8.6h/
	<Directory />
			Options FollowSymLinks
			AllowOverride None
	</Directory>

	Alias /cacti/ "/usr/local/cacti-0.8.6h/"
	<Directory /var/www/cacti/>
			DirectoryIndex index.php
			Options +Indexes
			AllowOverride None
			Order allow,deny
			allow from all
	</Directory>
Include /etc/cacti/apache.conf
</VirtualHost>

j'ai donc redémarré apache2 après avoir fait la configuration

par contre, j'ai un souci lorsque j'ouvre un navigateur et que je tape https://cacti.mondomaine.com

en fait, je vois bien l'authentification avec le certificat SSL

en revanche, c'est comme s'il ne reconnaissait pas le langage PHP

voici ce que j'obtiens en faisant lynx https://cacti.mondomaine.com

application/x-httpd-php  D)ownload, or C)ancel

pouvez-vous m'aider à résoudre ce probleme s'il vous plait ? :youhou:

merci d'avance :youhou:

sunfun :youhou:

Link to comment
Share on other sites

bonjour à tous,

j'ai résolu mon probleme :iloveyou::pleure::-D:D

en fait, il fallait mettre les 3 lignes suivantes dans le fichier /etc/apache2/httpd.conf


LoadModule php4_module /usr/lib/apache2/modules/libphp4.so
AddType application/x-httpd-php .php4 .php3 .phtml .php
AddType application/x-httpd-php-source .phps

ensuite, après quelques modifs dans le fichier virtual host, mentionné dans mon post précédent, ça donne ceci :


<VirtualHost @IP:443>[img]
	ServerName cacti.mondomaine.com:443
	SSLEngine On
	SSLCertificateFile /etc/apache2/ssl/phoenix.crt
	SSLCertificateKeyFile /etc/apache2/ssl/phoenix.key
	ErrorLog /var/log/apache2/cacti-error.log
	CustomLog /var/log/apache2/cacti-access.log combined


	DocumentRoot /var/www/cacti/
	<Directory />
			Options FollowSymLinks
			AllowOverride None
	</Directory>

	Alias /cacti/ "/var/www/cacti/"

	<Directory /var/www/cacti/>
			DirectoryIndex index.php
			Options +Indexes
			AllowOverride None
			Order allow,deny
			allow from all
	</Directory>
</VirtualHost>

en effet, les modules php étaient bien installés sur la machine, mais pas chargés :p

merci à tous d'avoir lu mon post

sunfun :oops:

Link to comment
Share on other sites

bonsoir à tous,

j'ai un souci avec cacti 0.8.6h :chinois::francais:

je n'arrive pas générer les graphes sous cacti

j'arrive à installer cacti, à aller sur l'interface d'administration :transpi:

j'arrive à récupérer des statistiques avec snmp :transpi::mad:

par contre, je n'arrive pas à obtenir les graphes :transpi:

j'ai suivi la documentation suivante pour réaliser cacti

http://www.debianhelp.co.uk/cactifromsource.htm

j'ai donc suivi ce tuto pour créer des graphes à l'aide des trees (arbres)

http://www.cacti.net/downloads/docs/html/faq.html

j'ai aussi mis les droits à www-data sur les répertoires /var/www/cacti/rra et /var/www/cacti/log

j'ai aussi rajouté ça dans la crontab de mon serveur cacti :

*/5 * * * * cacti php /var/www/cacti/poller.php > /dev/null 2>&1

voici ce que contient mon fichier /var/www/cacti/include/config.php :


/* make sure these values refect your actual database/host/user/password */
$database_type = "mysql";
$database_default = "cacti";
$database_hostname = "localhost";
$database_username = "cacti";
$database_password = "****";
$database_port = "3306";

je ne sais pas du tout ce qu'il manque pour générer mes graphiques :transpi::transpi:

par contre, je me rends compte d'un truc assez bizarre parce que mon répertoire rra est vide :francais:;)

voici ce que j'obtiens :

phoenix:/var/www/cacti# ls -l rra
total 0
phoenix:/var/www/cacti#

est-ce que c'est normal qu'il soit vide ? si non, à quoi sert ce répertoire ? :francais:

merci de me dire comment je dois faire pour générer mes graphes

merci d'avance de votre aide :transpi:

sunfun :francais:

Link to comment
Share on other sites

bonjour à tous,

j'ai mis ceci dans la crontab

*/5 * * * * cacti php /var/www/cacti/poller.php > /dev/null 2>&1

c'est censé poller cacti, mais ça ne fonctionne pas :francais:

pouvez-vous m'aider s'il vous plait ? :oops:

du coup, je suis allé regarder dans les logs

voici ce que j'obtiens :

phoenix:/var/www/cacti/log# tail -f cacti.log
09/06/2006 05:09:54 PM - POLLER: Poller[0] Maximum runtime of 292 seconds exceed
ed. Exiting.
09/06/2006 05:09:54 PM - SYSTEM STATS: Time:292.7120 Method:cmd.php Processes:1
Threads:N/A Hosts:3 HostsPerProcess:3 DataSources:5 RRDsProcessed:0
09/06/2006 05:14:54 PM - POLLER: Poller[0] Maximum runtime of 292 seconds exceed
ed. Exiting.
09/06/2006 05:14:54 PM - SYSTEM STATS: Time:292.7244 Method:cmd.php Processes:1
Threads:N/A Hosts:3 HostsPerProcess:3 DataSources:5 RRDsProcessed:0
09/18/2006 01:20:02 PM - POLLER: Poller[0] ERROR: The path:  is invalid.  Can no
t continue

09/18/2006 01:25:01 PM - POLLER: Poller[0] ERROR: The path:  is invalid.  Can no
t continue

09/18/2006 01:30:01 PM - POLLER: Poller[0] ERROR: The path:  is invalid.  Can no
t continue

je ne sais pas du tout ce que ça signifie :zarb::yes::pleure:

j'ai l'impression qu'il ne connait pas le chemin de poller.php

pourtant le fichier poller.php se trouve bien dans le répertoire /var/www/cacti

de plus, quand je fais un test pour poller cacti, ça me donne ça comme erreur :

phoenix:/home/swong# /usr/bin/php4 /var/www/cacti/poller.php

Fatal error: Call to undefined function:  mysql_pconnect() in /var/www/cacti/lib/adodb/drivers/adodb-mysql.inc.php on line 356

merci de votre aide :yes::transpi:

sunfun :byebye:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...