Jump to content

Problème de serveurs virtuels apache2


Recommended Posts

Bonjour,

Je fais un peu d'hébergement occasionnel pour mes copains et là j'ai un problème de serveur virtuel.

A savoir qu'il a reservé un nom de domaine gros.com par exemple, et qu'il le redirige vers le répertoire que je lui donne comme hébergement...

Seul problème, dans ses pages webs il est demandé ./ donc apache lui sort une url qui n'est pas son nom de domaine et ça fait tout foiré d'où l'idée de créer un serveur virtuel...

Ma direction partagée d'orginie est /var/www et j'ai fait un serveur virtuel comme ça :

<VirtualHost monadresseip>

DocumentRoot /var/www/sonrepertoire

ServerName www.grosbeux.com

</VirtualHost>

Et quand je me connecte au nom de domaine qui est redirigé à http://monadresseip/sonrepertoire, il ne me trouve pas le répertoire... :p

Quelqu'un peut m'aider s'il vous plais...

Merci d'avance :francais:

Link to comment
Share on other sites

bonsoir,

tout d'abord, ce n'est pas le bon forum

donc :ouioui:

est-ce que tu as bien redémarré apache pour la prise en compte ?

est-ce que tu as bien mis ce fichier dans le répertoire /etc/apache2/sites-enabled ?

dans ta configuration VirtualHost, je pense que tu as oublié de faire écouter sur le port 80

d'ailleurs à ce propos, as-tu mis le port 80 dans le fichier /etc/apache2/ports.conf ?

est-ce qu'il y a un firewall entre chez toi et chez lui ? n'as-tu pas fait de restriction d'accès par hasard ?

tiens nous au courant

bon courage :copain:

sunfun :yes:

Link to comment
Share on other sites

Salut et merci beaucoup de m'aider, désolé pour la section...

J'ai redémarre apache après la modification. Quel fichier je dois mettre dans sites enabled ?

Quand je met <VirtualHost mondomaine.fr:80>, j'ai ce message d'erreur quand je redémarre apache

* Forcing reload of apache 2.0 web server... [Thu Aug 31 23:07:24 2006] [error] VirtualHost linuxdocs.fr:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

[Thu Aug 31 23:07:26 2006] [error] VirtualHost linuxdocs.fr:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

[ ok ]

Or que quand je met pas le : 80 (obliger de séparer pour le smiley), aucun message d'erreur...

Le port est bien présent dans ports.conf

Oui il y a un firewall, iptables, port 80 ouvert toussa :copain: Il n'y a aucune restriction d'accès

En fait je suis quasiment sûr que je me plante dans le pointage du nom de domaine, je dois le pointer vers quel adresse ?

Autrement est-ce que ça peut provoquer des conflits de mettre un serveur virtuel dans le dossier par défaut déjà de Apache :yes:

Encore merci pour ton aide :ouioui:

edit : une autre question, est-ce que je dois réinstaller tout les portails et tout une fois le serveur virtuel fait ou ils prennent en compte la modification de la valeur ./ ?

Link to comment
Share on other sites

Est ce que tu as bien

NameVirtualHost tonip

au début de ton fichier de conf ?

Bah en fait avec un tuto que j'ai trouvé, j'ai changé un peu mon httpd.conf et ça fonctionne toujours pas...

NameVirtualHost nomdedomaine.fr

<VirtualHost nomdedomaine.fr:80>

DocumentRoot /var/repertoire

ServerName nomdedomaine.fr

</VirtualHost>

Voilà et j'ai enlevé le répertoire du répertoire d'origine de apache (var/www) je l'ai mis dans var...

Est ce que tu as bien des CNAMES (ou A) de tes domain name vers ton ip ?

Le nom de domaine est réservé avec 1and1 et je ne vois pas de cnames à l'horizon... :ouioui:

Merci pour l'aide tous :yes:

Link to comment
Share on other sites

Tu as essayé

apache -S

Chez moi ça fonctionne avec la configuration suivante :

NameVirtualHost *

<VirtualHost *>
 DocumentRoot /var/www/default
 ServerName localhost
</VirtualHost>

<VirtualHost *>
 DocumentRoot /var/www/test
 ServerName test
</VirtualHost>

⚠Les directives du VirtualHost par défaut (le premier pour moi) doivent avoir le ServerName et le DocumentRoot identique à celui de la conf main (en dehors des VirtualHosts).

Et en mettant test dans mon /etc/hosts.conf.

Si je tapes http://test, je suis dans test, si je tapes n'importe quoi d'autre (ip locale depuis le lan, localhost, host, dns,...) j'arrive sur la page par défaut.

Link to comment
Share on other sites

Alors Apache2 -S me donne ça :

sudo apache2 -S

[Fri Sep 01 17:50:25 2006] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

[Fri Sep 01 17:50:25 2006] [warn] NameVirtualHost *:0 has no VirtualHosts

VirtualHost configuration:

wildcard NameVirtualHosts and _default_ servers:

*:* is a NameVirtualHost

default server linuxdocs.fr (/etc/apache2/httpd.conf:6)

port 80 namevhost linuxdocs.fr (/etc/apache2/httpd.conf:6)

port * namevhost hostsites.hd.free.fr (/etc/apache2/sites-enabled/000-default:2)

Syntax OK

Bah le seul problème c'est que moi j'ai pas de virtual hosts pour le répertoire par défaut...

:francais:

Et au fait j'ai bien redirigé l'adresse A vers l'adresse ip de mon serveur :p , seul problème maintenant quand je veux visiter, il me renvoie vers l'index de mon serveur :paf:

Link to comment
Share on other sites

Après plusieurs recherches, je me suis rendu que ce n'était pas le fichier httpd.conf qu'il fallait modifier mais bien le fichier ./site-enabled/000-default où tous les paramètres sont...

Bref j'ai rentré mon virtual host, j'ai mis l'adresse A de mon nom de domaine vers mon adresse IP et ça redirige vers mon index :francais: ça redirige pas vers le répertoire :paf:

Et au fait plus d'erreur lors du redémarrage d'apache à l'horizon... mais toujous pas de site en vue lors de la visite du nom de domaine :p

Link to comment
Share on other sites

bonsoir darkhat,

comme l'as suggéré Xfaillez, peux-tu nous donner ta solution ?

ça m'intéresse aussi, et c'est tjrs intéressant pour les autres qui rencontreront ton souci de pouvoir le résoudre

et n'oublie de mettre résolu à ce topic après avoir livré ta solution

:byebye:

merci :sucre::yes:

sunfun :zarb:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...