Jump to content

debian sarge + apache2 + php4


Recommended Posts

bonjour,

ça paraissait tout simple :

l'install de apache2 a bien marché - ma //localhost marche bien

j'ai bien suivie les conseils pour l'install de php4 :

install libapache2-mod-php4

a2enmod php4

et un retart d'apache

j'ai placé un petit fichier test.php contenant <?php phpinfo(); ?>

Mais ça ne marche pas - j'ai l'impression que apache ne comprend pas encore le php !

Pouvez vous m'aider ?

Link to comment
Share on other sites

bonsoir,

j'ai trouvé un tuto qui peut t'être utile :francais::p

http://www.libordux.org/debian-docs/deb-lamp.php

et ce site là aussi

http://ed.zehome.com/?page=apache2

est-ce que dans ton fichier /etc/apache2/apache2.conf, tu as ajouté ceci :


 AddType application/x-httpd-php .php4 .php3 .phtml .php
 AddType application/x-httpd-php-source .phps

par défaut, dans ce fichier, ces 2 lignes sont commentées par un #

il faut les décommenter pour que php soit pris en compte par apache2

ensuite, il faut redémarrer apache2

bon courage :yes:

sunfun :byebye:

Link to comment
Share on other sites

Salut

En fait l'astuce a connaitre sous debian c'est le niveau de priorité de Debconf .

Plus la priorité est haute, moins le nombre de question posé a l'installation d'un paquet sera grand.

Il est donc interessant de la passer la priorité a basse, comme cela un maximum de question sont posées a l'installation .

Il en va de meme avec un dpkg-reconfigure .

Dans le cas de php, avec une priorité réglé a basse , il est demandé si il faut ou non integrer php dans le fichier de conf d'apache .

a+

Link to comment
Share on other sites

Salut

Fait ça dans un dpkg -l php4* dans un terminal et montre nous le résultat .

Sinon fait un dpkg-reconfigure libapache2-mod-php4

a+

pn php4 <néant> (aucune description n'est disponible)

un php4-cgi <néant> (aucune description n'est disponible)

un php4-cgi-curl <néant> (aucune description n'est disponible)

un php4-cgi-domxm <néant> (aucune description n'est disponible)

un php4-cgi-gd <néant> (aucune description n'est disponible)

un php4-cgi-imap <néant> (aucune description n'est disponible)

un php4-cgi-ldap <néant> (aucune description n'est disponible)

un php4-cgi-mhash <néant> (aucune description n'est disponible)

un php4-cgi-mysql <néant> (aucune description n'est disponible)

un php4-cgi-pgsql <néant> (aucune description n'est disponible)

un php4-cgi-snmp <néant> (aucune description n'est disponible)

un php4-cgi-xml <néant> (aucune description n'est disponible)

ii php4-cli 4.3.10-16 command-line interpreter for the php4 script

ii php4-common 4.3.10-16 Common files for packages built from the php

ii php4-curl 4.3.10-16 CURL module for php4

ii php4-dev 4.3.10-16 Files for PHP4 module development

ii php4-domxml 4.3.10-16 XMLv2 module for php4

ii php4-gd 4.3.10-16 GD module for php4

un php4-gd2 <néant> (aucune description n'est disponible)

ii php4-imap 4.3.10-16 IMAP module for php4

ii php4-ldap 4.3.10-16 LDAP module for php4

ii php4-mcal 4.3.10-16 MCAL calendar module for php4

ii php4-mhash 4.3.10-16 MHASH module for php4

ii php4-mysql 4.3.10-16 MySQL module for php4

ii php4-odbc 4.3.10-16 ODBC module for php4

ii php4-pear 4.3.10-16 PEAR - PHP Extension and Application Reposit

un php4-sablot <néant> (aucune description n'est disponible)

ii php4-xslt 4.3.10-16 XSLT module for php4

bonsoir,

j'ai trouvé un tuto qui peut t'être utile ;):transpi:

http://www.libordux.org/debian-docs/deb-lamp.php

et ce site là aussi

http://ed.zehome.com/?page=apache2

est-ce que dans ton fichier /etc/apache2/apache2.conf, tu as ajouté ceci :


 AddType application/x-httpd-php .php4 .php3 .phtml .php
 AddType application/x-httpd-php-source .phps

par défaut, dans ce fichier, ces 2 lignes sont commentées par un #

il faut les décommenter pour que php soit pris en compte par apache2

ensuite, il faut redémarrer apache2

bon courage :byebye:

sunfun :zarb:

Merci - ça marche !

Salut

En fait l'astuce a connaitre sous debian c'est le niveau de priorité de Debconf .

Plus la priorité est haute, moins le nombre de question posé a l'installation d'un paquet sera grand.

Il est donc interessant de la passer la priorité a basse, comme cela un maximum de question sont posées a l'installation .

Il en va de meme avec un dpkg-reconfigure .

Dans le cas de php, avec une priorité réglé a basse , il est demandé si il faut ou non integrer php dans le fichier de conf d'apache .

a+

j'aii reussi à baisser la priorité , mai sje n'ai pas compris quelle est la commande à executer apres où on me posera les bonnes questions - dommage

du coup j'ai fait la manip manuellement

Link to comment
Share on other sites

Pour avoir installé php il y a 2jours, il suffit d'installer php4 et les dépendances sont php4-cli, php4-common et libapache2-mod-php4

Je pense que le probleme se situe au fait que tu as installé le module apache pour utiliser le php mais que tu n'as pas installé php en lui meme! (a moins que a2enmod soit une commande d'installation que je ne connais pas... )

@+ :-D

Link to comment
Share on other sites

Merci - ça marche !
Je crois que c'est déjà résolu :roll:

:move:

D'ailleurs ;)

Nan j'ai pas tout lu, mais si il avait mis résolu j'aurais pas répondu :incline:

Pour mettre ton sujet en résolu (bon deja c'est expliqué dans l'aide et meme que c'est theo qui l'a fait, y va pas etre content...) ben tu édites completement ton premier message et tu inscrit [Résolu] dans le début du titre :non:

Pour la commande je sais pas.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...