Jump to content

acces à un disk usb


Recommended Posts

bonjour à tous

je débute sous linux :cartonjaune: . Je teste en ce moment plusieurs distribution pour choisir celle qui me corespond le mieux. après avoir essayé freespire, ubuntu, suse, j'ai jeté mon dévolu sur dreamlinux, la distribution qui imite mac osx :francais: .

le pb avec cette distrib, c'est que lorsqu'on branche un disk externe formaté en ntfs, on a pas acces au données. en fait, on y a acces via l'iconne qui apparait sur le bureau, mais seulement en root. ce qui signifie lque lorsqu'on copie ces données ds son home, on ne peut les utiliser car elle appartiennent à root :cartonrouge: . alors que sous ubuntu il n'y a pas ce pb.

j'ai bien été voir ds le fstab, mais les disk externe n'y apparaissent pas. que faut-i faire/modifier?

merci d'avance.

Link to comment
Share on other sites

Methode simple (en console) :

Quand tu copie en root les fichiers tu fait un

 chown <ton login>:<ton groupe> <nom fichier> 

toujours en root, en remplacants les mots entre <> par les parametres quivontbien. Tu peut mettre tout les noms de fichier à la suite.

Methode plus complexe mais definitive.

Je pense que ta distrib utilise automount pour monté les disques à la volé sans les inscrire dans /etc/fstab.

Donc dans le fichier /etc/auto.misc, dans la deuxieme colonne de la ligne qui correspond a ton disque externe, tu ajoute un "gid=users". Le mieux remplacer users par le numero de groupe donné dans gid par la commande id <ton utilisateur>

Voila, bonne chance.

Link to comment
Share on other sites

oui, moi, j'utilise plus le chown -R <utilisateur> <fichier> (ou *.<extension de ton fichier>)

d'ailleurs, je me suis jamais vraiment intéressé à cette commande, je ne connaissais pas ta méthode Gnaphron....

enfin, tu as toujours plein de solutions pour régler ces petits soucis :francais:

par contre, j'ai un problème équivalent sous ma deb, à savoir, j'ai rajouté deux partitions windows dans mon fstab (chose que je fais depuis quelques mois déjà, toujours de la même façon, et pour le moment, ça a toujours marché), mais depuis que je suis sous Etch, sur ce PC, les partitions windows ne sont plus modifiables, uniquement lisible, et pour copier les fichier, je dois passer par un sudo...

j'ai déjà tenté le chown, il me dit 'changement de propriétaire [...] : Opération non permise'

ça vous dit quelque chose ? (j'ai essayé le /etc/auto.misc, maus il n'existe pas sous deb...)

edit : oui, c'est du FAT32 :kill:

Link to comment
Share on other sites

oui, moi, j'utilise plus le chown -R <utilisateur> <fichier> (ou *.<extension de ton fichier>)

d'ailleurs, je me suis jamais vraiment intéressé à cette commande, je ne connaissais pas ta méthode Gnaphron....

enfin, tu as toujours plein de solutions pour régler ces petits soucis :francais:

par contre, j'ai un problème équivalent sous ma deb, à savoir, j'ai rajouté deux partitions windows dans mon fstab (chose que je fais depuis quelques mois déjà, toujours de la même façon, et pour le moment, ça a toujours marché), mais depuis que je suis sous Etch, sur ce PC, les partitions windows ne sont plus modifiables, uniquement lisible, et pour copier les fichier, je dois passer par un sudo...

j'ai déjà tenté le chown, il me dit 'changement de propriétaire [...] : Opération non permise'

ça vous dit quelque chose ? (j'ai essayé le /etc/auto.misc, maus il n'existe pas sous deb...)

edit : oui, c'est du FAT32 :kill:

essaye le coup du gid dans le /etc/fstab dans la colonne des options (4eme) ca marche tout pareil.

Link to comment
Share on other sites

Merci Gnaphron et Mephisto pour ces infos fort interessante :-D . Je ne connaissait pas le fichier /etc/auto.misc ;) . Je dormirais moins bète ce soir. En tout cas, c'est pour ça que j'aime linux 8) (même si je suis encore un newbie :smack: ), il y a toujours moins de s'en sortir car tout est fichier sous linux (avec bien entendu l'aide de sa communauté extraordinaire). Merci encore à tous :yes:

Link to comment
Share on other sites

En tout cas, c'est pour ça que j'aime linux :yes: (même si je suis encore un newbie :smack: ), il y a toujours moins de s'en sortir car tout est fichier sous linux
Je dirais surtout qu'il y a toujours moyen de s'en sortir pour plusieurs raisons :

=> Les logs sont bien faits, il y a pratiquement toujours moyen de savoir ce qui ne va pas.

=> La doc est plus qu'abondante (tutos, wiki, howto, info et manpages) et les erreurs connues / bugreports sont visibles, rien n'est caché. On peut trouver des solutions à chaque fois.

=> Tu trouveras toujours quelqu'un sur le net qui a eu les mêmes problèmes et qui a une astuce pour s'en sortir. Ou alors tu fais tu fais du très exotique

=> Au pire le code est lisible.

Comme on dit :

J'aime GNU/linux (ou BSD) pour trois raisons :

* Ça fonctionne.

* Ça fonctionne à chaque fois.

* Ça fonctionne toujours de la même façon.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...